Music Folder Disappeared

My music folder disappeared, I’ve been working with Eric to fix. I’ve tried the following and nothing has worked. I am working with the Nucleus as the core, a Meridian 218 and my MacBook Pro (brand new):

Please try the following troubleshooting exercises in the order listed below. If one does not yield a change in behavior please proceed onto the next…

  • The login credentials you are using to add the “network share” in Roon are the same that are used to access the device where the iTunes library is being accessed from, correct? In other words, let’s say I have my core on Nucleus and I am accessing the iTunes library on the MacBook Air in my office. The username and password that I enter in the “add network share” screen should be the same information that I use to access the MacBook Air.

  • Being that you are using the Nucleus as your core that means that your iTunes library is being accessed over the network via a “network share” from another device, as highlighted in the attached screenshot. Is that device currently up and running? If it is not, you should power it up so the share is active again and then try to re-add it using the same method you had used previously.

  • Try adding the “network share” via an IP address as opposed to the “hostname”…

    • First, please confirm that the “music” folder has “read” permissions set for “everyone” (i.e. users/guygridley/ music ).
    • Second, once the above has been confirmed, go back to the “add network share” window and enter the following:
      • "Network share location" = smb:// IP address of the device hosting the itunes library /music.(Example: smb://192.168.1.XX/Music)
      • "Username" = Your username assigned to the device hosting the iTunes library.
      • "Password" = The password you have assigned to the device hosting the iTunes library that coincides with the username.
    • Click “add network share”.

Hello @GGGG,

Thanks for contacting us regarding this case and I apologize for the continued frustrations here. I have been in touch with Eric regarding your case and we have enabled diagnostics mode on your Nucleus.

Upon taking a look at the diagnostics, I have noticed that you are seeing a “Permission Denied” error when attempting to mount your OSX folder. Based on this observation I would like to confirm a few things:

  1. Please make sure to use this path when mounting the OSX share in Roon: “smb://”

  2. Can you please post a screenshot of your “System Preferences -> Sharing” settings on OSX? This window should look something like this:

  3. Please double check to make sure that you have “Windows File Sharing” turned on for your OSX. You can click on the “Options” button on the previous screen to access this setting. I would also make sure that SMB is set to check on at this page and it should look something like this:

  4. After making these changes I would then try to re-add the network share in Roon using the following settings:
    Network Share Location: smb://
    Usermane: Your Mac Username
    Password: Your Mac Login Password

  5. After confirming that everything works as expected, I would also set your Mac OSX as a “reserved IP address” in your router. If you can let me know your router’s model/manufacturer I can see if there are some instructions available on how to perform this step, but here is a general overview of the reserved IP process:

There are a few threads that outline these steps for users who had a similar issue to yours and I have listed them below:

Please let me know my above suggestions help and if you have any other questions regarding this process, don’t hesitate to let me know.


Thanks, that finally worked, I appreciate the help. Do you have any idea why the folder disappeared in the first place so I can avoid it happening again in the future?

Hello @GGGG,

Glad to hear that mounting via IP address has resolved this issue!

I have looked over your diagnostics and I was seeing the following error trace:
11/19 20:12:58 Debug: [roon/cifs] returned 1: mount.cifs: bad UNC (/Users/guygridley)

This error sometimes occurs when the Nucleus is not able to resolve the dynamic hostname of your storage location, possibly due to networking difficulties.

Since you are now mounting the storage location by IP address, this is a much more reliable and stable method of mounting, my only word of caution here is to make sure that the IP address of your OSX system does not change by using IP Address Reservation in your router, because if the IP address changes, then you will not be able to access the directory anymore (since you are mounting via a specific IP address).

I hope that this answers your question but if you would like me to clarify anything else, just let me know and I will be happy to.



After a few hours of not using Nucleus, I’m getting an error message saying “Error Loading Folder”…“Not Found”.

Hello @GGGG,

Can you please confirm that your Mac OSX is still powered on and has the same IP address? Did you by any chance set it as a Reserved IP Address in your router settings to ensure that the IP does not change? If the Mac OSX IP Address changed or it was powered off that could be why you are seeing that message. I would also make sure that the path for your Music folder is still the same and has not been moved or renamed.

How is your Mac OSX connected to your network? Is it connected via WiFi to the Router or via Ethernet? Is the Nucleus connected to the same router/switch that the Mac OSX is connected to? Please let me know when possible.



The IP address remained the same as far as I can tell. I looked it up to verify that it was. I did not get a chance to set it as a reserved IP address which is what I was planning on doing when I discovered the error. I figured it didn’t make sense while it was not functioning properly. The MacBook is connected via WiFi to the router that is also connected to the Nucleus. The folder was not moved or renamed unless it happened unbeknownst to me.

Hello @GGGG,

Thank you for letting me know. I have asked the QA team to take a look at the diagnostics from your machine and they are noticing that the Nucleus is unable to access the shared Mac OSX folder on an OS level.

Can I please ask you to try rebooting your Nucleus to see if that helps resolve this issue? Can you please also confirm that Roon is added as an exception to your Mac OSX Firewall?


1 Like

The firewall was turned off. I rebooted the Nucleus and nothing has changed.

I just hardwired my MacBook to the network at the request of my dealer that I bought the Nucleus through, still not working. I can switch to an external hard drive as well. Do you think that will make a difference?

Sorry, forgot to add @support.

Hello @GGGG,

Do you have the media content saved on your external hard drive? If so, then yes I would try connecting the external hard drive directly to the Nucleus to see if that helps. You can add your music library to your Roon Database using these instructions but to give you an overview of the process, you would have to do the following:

  • Connect the drive to the Nucleus
  • Go to your Roon Settings -> Storage tab
  • Press “Add Folder”
  • Select the External USB Drive from the left-hand list of drives

Please let me know if that works for you.



Ext hard drive worked like a charm. I’m not gonna mess with he MacBook anymore other than for the control.


@GGGG - Great to hear that it’s up and running with the external hard drive! If you have any other questions, don’t hesitate to reach out to me.