My OPPO does not show up as networked Roon endpoint [Reason B&O ‘Special’ firmware]

I purchased the OPPO 205 exclusively so I can run it with Roon.

I am currently on th Roon 14-day trial, but if we can resolve this issue, I will purchase the life-time subscription.

The issue is simple: the OPPO never shows up in Audio Devices, the networked devices section. I tried everything.

My setup:
1… Brand new OPPO 205 with the latest firmware (224)
2. For the Roon server, I first tried Windows, then Synology, neither works
3. The network is a local area network, I tried making the OPPO wired and wireless, neither works.
4. Having said that, I installed the Roon client on my Samsung smart phone, and it showed up as a device right away in the networked devices section of audio devices! Just the OPPO does not show up. Again OPPO is on the latest firwmware.
5. The router is ASUS AC1200
6. Client Roon is Windows 10 64 bits i7 desktop.

Please help, I spent so much money on this OPPO and I think i got the last one in North America, just so I can run Roon.

Calm down. You did not buy the last OPPO UDP-205 in North America. And OPPO has a generous return policy if the UDP is not the right solution for you.

While an OPPO UDP will function as a somewhat limited Roon endpoint – I occasionally use one myself – few would buy one for the sole purpose of a Roon endpoint.

Your current issue probably is network related. Power cycle all Roon related devices, including the OPPO. And ensure that all are assigned IP addresses within the same subnet on your LAN.


Did you run the Oppo firmware update? As far as I know the Oppo is only roon ready after the firmware update.

Oh yeah? If so, why don’t I give you $1298 and you go ahead and buy me another brand new (or any) OPPO 205. You are clearly uninformed as to what is going on with OPPO in the last week.

Anyway, I thought this was Roon Support where I get a response from an actual Roon employee.

1 Like

Yes I did run the firmware update, it’s the first thing I did.

1 Like

Hi @Goran_Janevski ---- Thank you for the report and sharing your feedback with us. The insight is appreciated and sorry to hear of the troubles.

Moving forward, to help aide in my understanding of this behavior you are experiencing with the 205, may I very kindly ask you for the following:

  • I see from your post that you had tried hosting RoonServer on a Windows devices and a Synology NAS. Can you please verify for me where you are currently hosting your Core and provide the exact model/specs for the device.

  • Besides the mentioned router are there any other networking devices in play? These items can include switches, powerline adaptors, extenders, repeaters, etc.

  • In relation to the my previous question can you please describe how the 205 is communicating with your network?


Hi Eric,

Thank you for a quick response. Currently I am running the RoonServer on the Synology NAS. Details about this NAS:

  • No Powerline adaptors, extenders or repeaters, however, there is a switch between the router and the Roon client(s). This is a decent L2 switch, and it does not interfere with the higher protocol layers.

  • I tried having the 205 connect over the wired connection, and over the wireless connection. In both cases the OPPO gets its IP address from DHCP, it gets from wired and .111 from the wireless.

Also, when I installed the clients on various Windows 10 endpoints, they all offered to add two exceptions for raatserver.exe, which I accepted.


Hi @Eric Stewart, The info you requested is provided above.

Thank you kindly,

Thank you for the follow up @Goran_Janevski, I appreciate you taking the time to answer my questions/provide the requested feedback :+1:

A few things moving forward…

  • During your troubleshooting have you tried mounting the 205 directly to your router just to confirm what the experience is like? My assumption is that it is connected to the mentioned switch, but please do correct me if I am wrong.

  • The mentioned switch is it managed or unmanaged? If it is indeed managed switch we have seen a few issues crop up with these devices in the past ( Example: #1, #2, #3). I would recommend enabling flow control on the switch, as we have seen it help other users.

  • You mentioned that on the Win10 clients that they offered “two exceptions” for the “RAATServer”. If there are firewalls or antivirus active on any of your devices you will not only want exceptions for “RAATServer” but also for “Roon” as well.

Something to consider with your setup…

I noticed from your follow up that the mentioned Synology NAS is making use of an Intel Atom C2538 2.4 GHz which has the potential to cause performance issues as it is falling below our recommended specs. Does the device have an SSD installed for your Roon database?

Goran, I want to be clear that I do not believe that the behavior you are experiencing with the 205 is related to the NAS. I am merely pointing out the above as a, “head up” because I want to make sure that you get the best experience possible while using Roon, and if there is an underpowered device driving the system you may encounter limitations moving froward.


1 Like

It is worth getting this to work as I think the Oppo sounds great as an endpoint. Better than an Rpi via USB into the Oppo. I also use a Synology NAS and Asus router and everything works fine. When I first installed the Oppo it actually had to do 2 or 3 firmware updates before it was showing up in Roon.

Maybe try connect the Oppo direct to router just to see if the switch is the issue?

1 Like

Hi Goran, Did you check under settings>audio to see if the Oppo registered in the Roon Settings. You would need to enable it prior to use.

The Oppo would be listed in networked devices.


I echo @rrwwss52’s post, I had the same frustration after adding a new endpoint, only to discover I hadn’t enabled it. :yum:

1 Like

Thank you @Steve_C, I find your post most helpful.


Hi @rrwwss52, my problem is that the OPPO never shows up as a Networked device.

@Goran_Janevski It isn’t that you have the Oppo in standby is it, mine does not show up in networked devices to either enable or if it was previously enabled, as an endpoint unless it is on, eg: blue led by the power button.

Just a thought?


Can it connect to the network outside of Roon? Maybe a bad cable, switch, or connection?

This kind of troubleshooting gets frustrating for sure…especially for new equiment.

1 Like

Hi @eric, having compared the 205 to a 203, the latter had no issues and simply showed up as a network device in Roon, and what I found out along the way, this is not a problem that can be solved.

Turns out I have purchased the 205 from a Bang & Olafsen dealer, and BO forced OPPO to create a special firmware for them that does not show the OPPO logo on the screensaver. These people never told me about the firmware, and it wouldn’t have made any difference since it literally was the last OPPO 205 that I could find and I would have bought it anyway.

I am also guessing that this special firmware somehow disables Roon Ready. So I am screwed.

So you can mark this topic as closed.

Can you update your 205 directly through the Oppo website. I’d contact OPPO Digital support. They have phone support and are based in California.

It’s a special firmware, this oppo refuses the regular firmware. OPPO said I have to ship them the 205 in order to change to regular firmware. I hesitate under the circumstances.

I would send it back and have them flash it as long as you are sure you purchased it from an authorized dealer.