New Airport Express firmware 7.8 not working with Roon

I just updated two airport expresses to the new firmware 7.8 and Roon would no longer play to them. I reverted back to 7.6.9 and they work again. Is this a known issue?
Mac Mini 2011,4GB Ram, Roon server 1.5

Btw, they worked fine with iTunes on firmware 7.8.



1 Like

I tried disabling and re-enabling the devices, restarting Roon server, rebooting the computers, and the airport expresses before reverting back to 7.6.9.

I’ve seen similar reports. AirPlay 2 breaking Roon?

1 Like

Me too. Over to you Roonies.

@support for those in this situation

1 Like

Hey @Justin_Kurtz.

Thanks for reaching out to us, we appreciate your report. The team is currently looking investigating this behavior.

Regarding Airplay 2 support, we currently have no announced plans.



Thanks for the postings. After updating to 7.8, the DAC would not lock even tho Roon “saw” the A/E. A rollback of the A/E firmware fixed the issue. FWIW, I have no need for AirPlay 2 compatibly from Roon but streaming to A/E devices is very important to me. There are A /Es all over my house that Roon streams to for my casual listening.

I have a house of bricks now, any idea when Roon will work through this? I have had to go back to iTunes since the update…

1 Like

Hey @Rodney_J_Sorensen,

Others have reported that rolling back the firmware on their Airport devices has allowed them to continue using these devices with Roon. You can read more about rolling back the firmware here:



I cannot get Roon to play thru an apple airport express (version 7.8) using Nucleus +. Roon notices it and seems to capture it just fine. And, I can press play, but music counter won’t advance.

Roon on nucleus works fine streaming via airplay to an apple tv.

Had been using Roon on Mac Mini prior to nucleus. The airport express and airplay worked fine.

The express works with our various apple computers in the home streaming music via airplay so long as it is disabled in Roon.

I assume it is the AE newer software version 7.8 that is not cooperating with Nucleus.

What can I do?

Hi Fred,

I moved your post here. Check out this thread and Dylan’s link to rolling back the firmware above.

Cheers, Greg

1 Like

I figured it out… thanks…

I can no longer us Airport Express with the new firmware upgrade. I should not that Roon streams to a third party receiver with Airplay, but not my Expresses. I also tried all the “tricks”, including naming the speakers and adding passwords … .

Dear Dylan:

Thank You for posting the “how to” on Rolling Back Firmware. I once knew that, but that was a long time ago.

Thank You.


1 Like

I was streaming music from my Roon core to two different Airport Express devices with no problems whatsoever. Apple released Airplay 2 firmware for these Airport Express devices, and I upgraded the firmware. While I can now stream using Airplay 2 from my iOS devices (iPhone/iPad), Roon will no longer play to either of these Airport Express units.

Is anyone else having this problem? Does Roon have a known problem streaming to Airport Express devices that have had the Apple Airplay 2 firmware update applied? Is there a solution available or in the works? Please?

Hi Edward,

I moved your post here. Check out this thread. You need to roll back the firmware of your AE, as per Dylan’s post above.

Cheers, Greg

Please add me to the list. And thanks to Dylan for the link to rolling back the firmware version, which solved the problem for me. Hopefully, there will soon be a Roon update to address this issue.

I can verify that 7.8 is broken and 7.6.9 is working perfect. Just dont upgrade!

Well, rolling back the firmware to 7.6.9 is dandy but you lose the Airplay 2 capability. So now it’s time for Roon to fix their software to work with Airplay 2, or I won’t renew my license when time comes to do so.

Does the latest Roon update (Version 1.5, build 354) resolve the incompatibility with the latest Airport Express firmware (Version 7.8)?