No Volume Control and Play Starts at Max Volume

I stream Roon to a Zeppelin Air (via Airplay). I used to be able to control the volume through Roon, but ran into an issue where every time I switched tracks there was a huge delay in the sound, so I disabled volume control. Now I have an issue where the Zeppelin starts at max volume whenever I wake it up and start streaming. It’s essentially unusable - whenever I use it I start off with a track that I know is basically silent at the beginning to give myself time to crank down the volume on the Zeppelin.

Anyone else ever run into an issue like this? I would re-enable volume control in Roon and try to address the delay issue, but can’t figure out how to bring it back. Thanks for any help.

I have the exact same problem with a Denon AVR-X23000W via AirPlay. When playback starts, the Denon immediately cranks up to full volume, and I can’t control it from Roon. I have to sprint to the receiver and turn it down.

Hi @Matthew_Greig and @Michael_Hocter ----- Thank you both for the feedback!

I wanted to touch base with you both, because I use a B&W A7 for some of my testing and under “device setup” you are given the following option:

Can you confirm if this feature is currently engaged or disengaged?


Mine was disengaged, but engaging it seems to make no difference. Also, I found when I shut down Roon and reopened it, the “hide volume control” option was disengaged. I took the following steps: 1) open Roon, 2) go to Device Setup and select “yes” for “hide volume control,” 3) hit “save settings,” 4) begin playing music only through the Zeppelin zone, and it exhibited the same max volume tendency. If I turn the volume down and continue playing different tracks, changing albums, etc., the volume control stays where I put it. But if I close and reopen Roon, with the Zeppelin staying “awake,” Roon resets itself to “no” on “hide volume control” and the first track I play is at max volume. As noted, though, even if I engage it before playing any music, it starts at maximum volume. Thanks.

Same. Mine is disengaged and changing it makes no difference. Also that setting doesn’t seem to “stick.” If I turn it on, it will be off again the next time I go into Device Setup.

And I suppose I should have mentioned this before, I’m using Roon 1.3 (build 223) on Mac OS Sierra 10.12.4. My core is running the latest version of Roon on a Win 10 machine.

This is all I have in Device Setup for the Denon AVR-X2300W. Everything set to the defaults.

Mine is identical for the Zeppelin Air.

Hi @Matthew_Greig and @Michael_Hocter ----- Thank you both for touching base with me and my apologies for the slow response.

Moving forward, we’d like to take a look at your logs while your devices are in this state to see if we can determine what may be causing this behavior to occur. May I kindly ask you to please follow the instructions found here and dump us a set of logs.

Furthermore, may I also ask you to please provide a brief but accurate description of your current setup as seen here.


I’m running Roon 1.3 (build 223) 64-bit on a late-2013 MacBook Pro, 8gb ram, running OS Sierra 10.12.4. My Core is run on an Intel NUC, celeron N3050, 8gb ram, running Roon 1.3 (build 223) 64-bit on Win 10 Pro version 1607, OS Build 14393.1066. The database is stored on a SSD within the NUC. My collection is just under 8,000 tracks.

Let me know if you need anything else.

1 Like

Core: RoonServer 1.3 64-bit, Windows 7, Intel i7, 8GB RAM, 1TB SSD.
Music is stored on a Synology DS415play NAS (8TB). Only about 4000 tracks.
Network: Netgear Nighthawk X6 R8000 router. Core and NAS both have wired connections.
Endpoint: Denon AVR-X2300W (AirPlay), connected wirelessly to the network.

Here’s the device setup and signal path:

And here are my logs:

1 Like

@Matthew_Greig and @Michael_Hocter ----- Awesome work here, thank you both for the feedback and the logs.

I have everything in my queue for evaluation/testing and once I have some feedback I will be sure to follow up asap. If you can think of any reproducible steps that got you into to this state, please share, as that information will be greatly valuable when trying to replicate this in house.


Hi, i’m Just in a Trial of roon. Ist works great expect of the Volume Control. I Just started a Song from my library and wanted to Play IT with my Denon 7200wa over Airplay. The Receiver was Set to about 35 from 100, as the Song began to Play the Denon automatically leveled Up to 75 and almost blew my Kef R900 away. Thats a critical issued because the speakers could have been damaged. The Volume Control is disabled in the device settings, so again no clue about what Went wrong. Any idea?

Hi @ManInTheHighCastle ---- Thank you for report and sharing this observation with us. The feedback is appreciated.

Moving forward, may I kindly ask you to please provide with the following information to help aide in my evaluation of this behavior you’re experiencing:

  1. A brief but accurate description of your current setup as seen here.

  2. Screenshots of the device setting you are using for your Denon 7200wa zone in Roon.

  3. How does the Denon respond (outside of Roon) while sending content via Airplay?


Hi, thx for your reply.

  1. I have installed the latest core on my Synology DS916+. I use it as Music Library. All music is stored on that nas. I want to use my Android Smartphone as a control Unit but also my Macbook Pro Late 2016.

  2. see the configuration on the attached screenshots.

The Problem with that and maybe thats the point. Regardless of what i choose on Volume Level control i can’t level the volume with the roon software, as you can see on one of the screenshots. But that doesn’t explain why it levels so high that a possible demage of my hardware could happen.

  1. The Denon has never been of any strange behavior. Airplay as well as UPNP control commands are working fine. The Denon is also hardwired, so no WLAN here.

All ---- Please be advised that this issue has been addressed and a fix is set into place pending our next build release which we believe will address this behavior.

When we do release the next build, please let us know what the experience is like. Thank you again for your continued feedback and more importantly your patience.


@ManInTheHighCastle - When I saw your screenshots I moved your posts over to this thread as it appears that you are having the same issue being reported here.

Thx. I uploaded a video of that behavior. I have configured a max volume of 60 for my Denon, so that my speakers do not crash.


Which release do you mean? Control or Core? Will the Synology get the update as soon as the others? Is this only related to Airplay? Is it possible to extand my trial. I would buy right away without that issue, but thats kind of critical!

Hi @ManInTheHighCastle — Thank you for your patience, my apologies for the wait.

In regard to your questions. We periodically release new builds which address any issues or problems that we have been investigating and have since fixed. Think of it as an “update”.

More information on this process can be found here in our knowledge base.


A post was split to a new topic: Not seeing Airplay devices in Roon

Issue isn’t fixed for me in the latest build 242. Denon AVR=X2300W still cranks to full volume via AirPlay.