Nucleus is no longer visable as a core

When opening Roon remote saw a brief error message (didn’t catch any of it before it disappeared), the macOS app closed, and when I restarted the app it was unable to find Nucleus as the core. Same behavior on iOS app (unable to find Nucleus). Rebooted Nucleus (removed power cable) and router multiple times, but Nucleus is still not appearing as a Core. Nucleus Power light and network lights are on.

Nucleus is also no longer visible on the network. Xfinity router>network switch>Nucleus. Google wifi mesh running off network switch as well. Tried Nucleus direct into the router w/ no change.

Try rebooting your network gear.
If you have a phone or tablet install Fing to see if the nucleus has a network address.

Thank you. Rebooted all network gear. Using Fing and do not see the Nucleus on the network. Tried connecting Nucleus directly to modem, switch, and a Google wifi point with no change.

Tagging @support.

So I tried a complete network reboot one more time… and the Nucleus has come back from the dead! Back up and running as the core like nothing ever happened. Are there diagnostics I can provide to root cause the issue?

I bet this is your Google Mesh. If setup as it comes you will have a double NAT meaning devices on the mesh side are essentially a different network and DHCP is being controlled by the Google router not your main router. Roon won’t like this. You can put it in bridge mode I think which will then make it all one network but for some reason Google don’t recommend this.

I was just going to post the same.

@ged_hickman1, @CrystalGipsy Thank you. I’ve got some reading to do on double NAT. Would double NAT result in intermittent core visibility issues? The Nucleus and remotes have run pretty well with the current set up for the last 3 months since purchase. This was the first time it ‘disappeared’ from the network.

I don’t have them so can’t say just from issues others have had with Google Mesh it stems from this or if running a device off one the network ports on one of the aps as they often run on a different IP range. Double NAT basically is when a network has two routers present both running DHCP servers, any network should only have one really as it leads to the two getting isolated.

You can get given a lease by one and it renews over time and everything is fine. Then you get a glitch and end up with a lease from the other server pool and bad things happen as addresses and look ups are all out.

Hi @MaTo,

Glad you’re back up and running!

Yes, this is a possibility here if your Mac connected to the Xfinity WiFi. I would set the Xfinity router to bridge mode and have your Google WiFi perform all the routing and the only router broadcasting the WiFi.

@support, @noris

Unfortunately, I’m back. After almost 2 weeks of trouble free use, the Nucleus is offline again. Xfinity router is in bridge mode. I’ve tried powering everything off and back on again several times with no luck. Network setup all hardwired: xfi gateway (bridge mode)->Google wifi router->network switch->Nucleus

To add to the mystery I notice the Nucleus will cycle on/off by itself on occasion and the power button function is intermittent.


Hi @MaTo,

Are you able to access the Nucleus Web Administration Interface during this time? If so, can you share a screenshot of what you see here?


Hi @dylan,

The Nucleus has re-appeared/disappeared/reappeared since I updated the thread last week. Currently up and running so I was able to get a screengrab of the web admin interface.

Btw, thanks to you and the Roon team. Great product that I never knew I needed. Makes the downtime all the more painful though.

Add images

Hi @MaTo,

If this issue re-occurs, can you please note the exact local time + date of the issue’s occurrence? This will be useful for us in case we need to take a look at diagnostics for further clues, thanks!

Roger that @noris.

Thanks again

1 Like

Hi @noris, @dylan,

Nucleus dropped mid-song at 11:47 PM PST on July 14, 2020. I could still “see” it on the network using Fing (which is not the normal behavior, previously it was not visible during these events), but unable to connect using a Mac OS X or iOS. Re-connected again 10 minutes later at 11:57PM (also unusual as 10 minutes is a relatively short outage).

Hi @MaTo,

Thanks for that timestamp. I’ve activated diagnostics mode for your Nucleus and what this action should have done is automatically upload a log set to our servers.

However, I am not seeing the log report come through at this time. Can I please ask that you use these instructions (Option #1) to manually access them and send us a set?

Hi @noris

Looks like I’m currently unable to connect to the Nucleus which may also be why you didn’t see a log report come through? I’ll see if it comes back and grab the log files then? Anything else I can do in the meantime to assist?

Hi @MaTo,

Is the WebUI still accessible or does that not work either? You can try hooking up an HDMI cable from the Nucleus output to a monitor, it should provide some diagnostics info. I would be curious to know if there are any errors there, this is a example of what the diagnostics screen should look like: