Ongoing Tidal Problems

I’m not happy with the reliability of Tidal streaming in Roon.

Last week’s issue:

Now, I can’t get Tidal tracks to stream without periodic interruption.

Note that I have no problems streaming local content (music stored on my NAS), nor do I have problems (that I’ve noticed) using Tidal on my phone.

I have deleted the Tidal cache on the server, restarted it and the endpoint (a micro rendu, which I have also updated), switched the DNS servers to Google’s, etc.

And still problems.

Note also that I can go for weeks at a time with it working fine.

Hi @sm31 ---- Thank you for the report. The feedback is appreciated and sorry to hear of the frustrations.

Moving forward, to help aide in our understanding as to why you may be encountering this behavior when using ROON + TIDAL may I kindly ask you to provide the following information:

  1. Is your core machine making use of Wifi?

  2. Please describe your network configuration/topology being sure to provide insight into any networking hardware you are currently implementing. I want to have a clear understanding as to how your devices are communicating and all the tools involved with making those connection possible.

  3. Is Roon generating any error messages or warnings when the mentioned interruptions occur?

  4. Please verify the make/model of device that the MicroRendu is currently feeding into.

  5. Just to make sure we are on the same page here you are noticing this behavior with all of your endpoints correct? No matter what you use the experience is always the same, yes?



  1. no
  2. keep in mind, everything was working fine for weeks at a time, and nothing has changed with the network in that time. But, Core is on a DIY NAS, connected by ethernet to a managed switch. I also have an unmanaged one I can try, but haven’t yet. The microrendu is connected by ethernet to a WiFI extender. Yes, I know Roon folks have cautioned against these, but see again first line. I have zero problems now, too, streaming high resolution content from the NAS.
  3. sometimes the remote says it’s disconnecting from the Core, and other times there’s a Tidal error mentioning network problems.
  4. Schiit Gungnir MB.
  5. I’m streaming Tidal fine now to a Chromecast endpoint over Wifi (connected to main AP).

Hi @sm31 ---- Thank you for the follow up and providing the requested feedback! Appreciated.

In your latest post you mention the following after I asked if this issue is occurring with all of your endpoints:

“I’m streaming Tidal fine now to a Chromecast endpoint over Wifi (connected to main AP).”

Just to be clear and to make sure I am not assuming anything :innocent: Are you having no issues when streaming TIDAL content to this endpoint via Roon? Furthermore, if that is the case does this behavior seem to only be occurring with the MR + Schiit Gungnir MB endpoint?


It’s hard for me to be certain. I have one RoonReady endpoint (the MR, etc. I am focusing on here), and two Chromecast ones I use much less frequently.

I am only reporting that I have not observed the same problems on the latter, but the observations are much less extensive.

So it seems to me to be specific to the RR endpoint, and that this is only in the past week or so.

Hi @sm31 — Thanks for the insight! I would be curious to know if the Chromcast endpoints are exhibiting the same behavior because that may point to a more general issue occurring if they are. If you happen to do any more testing with these endpoints please do share your observations with me :microscope:

Moving forward, as you have already pointed out we typically warn against using such devices as Wifi extenders because we have seen our fair share of issues pop up due to these types of devices in the past. If we are going to focus on the single endpoint (MR + Schiit Gungnir MB) my first recommendation will be to verify what the experience is like when you mount the MR directly to your router.


OK, may be a couple days or so before I can look into that.

But why, if the problem might be my network, would I have zero problems streaming 24 192 files, but consistent problems in last week only with Tidal, and generally no problems previously?

Thanks @sm31, I will be on the lookout for the results of that test.

I think it is still premature to blame the network, generally speaking. This is part of the reason I had asked about the Chromecast endpoints :slightly_smiling_face: If ALL of your endpoints were displaying this behavior then the symptoms would point to a more general issue occurring (i.e something potentially occurring in the environment).

However, as you pointed out, this seems “specific to the RR endpoint” and as such the goal of this test is to remove a variable that we know has caused issue in the past to see if the adjustment triggers a change in behavior.


One piece of news, that contradicts earlier report: I see same behavior with the Chromecast endpoints now.

Again: only with Tidal. And only with Tidal on Roon.

If I cast to the same endpoint, from the same device, but using the Tidal app, no such problem.

And again: only last week or two.

When the music stops, the remote is indicating it’s losing connection (the select zone button appears).

Hi @sm31 ----- Thank you for the follow up and sharing this observation you have made with me. The insight is greatly appreciated!

“When the music stops, the remote is indicating it’s losing connection (the select zone button appears).”

The above means that the core is losing contact with the endpoint and as such I would recommend the following:

  • Let’s proceed with testing with the MR disconnected from the Wifi extender.
  • Once the MR is mounted directly to the router I would like you to please power down the Wifi extender.
  • With the MR connected to the router and the Wifi extender temporarily disabled what is experience like when you stream TIDAL content via Roon to your endpoints?


FWIW I have been having intermittent streaming problems from Tidal. Starting first track of album Roon will say Tidal stream speed too slow.
Who to blame Tidal, Internet backbone, at&t, local wiring, AT&T burying new cable, net neutrality BS…

Is there a typo in your post? I’m not following. Can you please restate?

I decided to bite the bullet and replace the existing network with a mesh system, because I’m too busy, and life too short to hassle with network problems.

I got the new Plume Superpods system, which seems pretty awesome; sort of combing the hardware power of the Netgear Orbi (one review described them as “highly miniaturized Orbi RBR-50s”) with the elegant hardware and software of the Eero.

I have the MicroRendu now directly connected, by ethernet, to one of the nodes, which the network app is telling me has an “excellent signal.”

An initial test seems to suggest that Tidal is working better. But it’s still not working acceptably. I get through a couple of tracks, and then it just stops, and I have to hit “play” again. This has happened like five times over the course of a single, six track, album.

And I’ll just repeat what I said earlier: I have not previously had these problems, even with the old network.

The Plume system does some network optimization over time, so I’ll monitor if anything changes over the next few days and report back.

Also … I have a few different Roku’s as well, for video streaming. I don’t have problems with those.

On Tidal, same behavior, regardless of network (standard wifi + extender vs mesh) or endpoint (MicroRendu vs Digione Signature): track will stop, and then remote will report a lost connection to the endpoint, and then reconnect.

This behavior does not happen at all when I’m streaming local content, regardless of bit depth or sample rate. And the problem seems new to me.

@eric - maybe it’s time for me to send in logs?

Hi @sm31 — Than you for the update and sharing you observations after introducing the Plume system to your setup. Appreciated.

Moving forward, I did have a chance to meet with the tech team to discuss open issues and brought this thread up in our conversation. As per the conversation the team has asked if you could please provide the following information:

  1. Please reproduce the issue, note the time of day when it occurred, and what track/album was being played when it happened. Once I have this information I will enable diagnostics on your account so we can have a closer look at what is happening when the error presents itself.

  2. What is the experience like if you temporarily host your Roon core on another device. Do you notice the same TIDAL playback issues as before?


As I’m posting this (3:25 PM today; EST), playing MQA version of Beck’s Morning (and yes, in general I did check if MQA made a difference; it didn’t).

I haven’t tried this yet.

Thank you for the quick follow up @sm31!

Now that I have an idea as to when the issue occurred I have went ahead and enabled diagnostics on your account. What this action will do is the next time Roon is active on your core machine a diagnostics report containing a set of your Roon logs will automatically be generated/uploaded to our services. When the report comes in I will be sure to let you know that we have it and then swiftly pass it a long to the team for review.

Please do let us know how the test goes with your core being hosted elsewhere as this was a data point the tech team was admit about having.


I’m currently testing running the Core on another machine. So what you get on your end will initially be from that.

I’ll switch back once I’ve come to some conclusion.

Actually, I forgot to switch the core on the tablet remote. So it caused the error just now.

Now on the other machine.