Over 300 Qobuz albums have disappeared [Investigating]

Fired up Roon this morning, and over 300 of my albums in my library are not showing up. This has all occurred in the last 9 hours since last night. I have rebooted my Nucleus, and restarted the server software. But they just appear to be gone. If this is permanent……I’m pretty much done with Roon. I don’t have hours and hours to waste curating playlists and album libraries to have them disappear. Has anyone had this happen? What can I possibly do to get back my full library that was just there last night? These are not albums/tracks that i have stored on my Nuclues. These are Qobuz albums/tracks that i had saved to my Roon library that are now mostly gone.

Also, these albums/tracks are still showing up as “favorites” like they always have in Qobuz. But they are missing in Roon. I strongly suspect this is an issue with the new Roon build that came out this week?

I’ve moved your post across to the #support category of the forum, where it will be seen and responded to by a member of the support team. I’ve seen this issue reported elsewhere in the forum today.

@support - is this a repeat of the problem of synchronising between Qobuz and Roon that occurred a few months ago?

1 Like

Here we go again! About 1000 of my Qobuz titles disappeared! :confounded:

And some wonder why some of us cling so dearly to our local collections. Online streaming is unreliable, IMHO.

Mine was reduced from 700+ to 48, also reported a few hours ago. Doesn’t seems to be isolated issues Since this is the third in a row I’ve seen I a few hours.

1 Like

What the heck? This is a basic failure of the service. And it represents in my case easily 8+ hours minimum work curating this library. I won’t bother rebuilding it, and I’ll be done with Roon unless it can seemingly magically be restored.

If it’s the same issue as before, you won’t have to rebuild anything. Once fixed, you’ll get everything back.

1 Like

Just had to “I told you so”, huh?. I would get into the discussion of what could happen to your “local collection” and all the inconveniences and drawbacks of it, but now isn’t the time. There are no free lunches.

1 Like

It will be, since you presumably still have all your albums and tracks marked as favourites in Qobuz.


Same here, a lot of albums have disappeared. If I look into “Added” there is a gap of more then 200 days all missing albums what I have added.

Luckily I see them all in Qobuz App under Favorites.

This has happened on a number of occasions before. They do come back (as long as you stay away from “Clean up Library”).

1 Like

Also happening to me, think it’s the fourth time this has happened since I’ve been on Qobuz.

Happened to me last night; I’ve lost ALL my Qobuz albums, well over 400. Was planning to restore a backup but will now wait for word from support.

Hey @Lance_Smith as well as everyone else experiencing this issue,

While we take a closer look on our end, can you please share more information around your system setup? As a first step can you also sign out of your Qobuz account in Roon, clear the cache in your database, and re-sign in after? Steps to follow below:

  • Sign out of Qobuz
  • Stop Roon Server from running in the Web UI
  • Find and open your RoonServer database
  • Navigate to RoonServer/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon Server via the WebUI, re-log into Qobuz, and verify if the issue still occurs

I’ll be on standby for your reply :+1:

In my case using a Salkstream III (it uses Linux Arch) I’m unable to stop Roonserver to clear the cache. I tried logging out of Qobuz, then rebooting the Salkstream, but it didn’t make any difference.

I guess like last time I just need to wait for it to be fixed on Roon’s/Qobuz’s end.

My Roon install is on a Windows 10 PC. Have followed the instructions but Qobuz albums aren’t (yet) reappearing. (I’ve also clicked on ‘Sync library now’ in the qobuz popup under services - comes back immediately.)

I have the same issues, followed the steps and my albums are still missing.

Roon Core Machine

MBP 14" 2 GHz Quad-Core Intel Core i5

Networking Gear & Setup Details

Google WiFi

Connected Audio Devices

RopieeeXL endpoint
Local Mac System Audio out

Number of Tracks in Library

Local files is <500 tracks
Rest is Qobuz

Description of Issue

All of a sudden most of my albums are gone, leaving only 62 albums in “My Album”. At the same time Qobuz retains all my favorites.

One example is this album

It’s no longer searchable from Roon, but avialable on Qobuz (and in my fav album)

Tried rebooting machine, rebooting network, DNS is Google, nothing works.

This is from the logs and certainly doesn’t appear to be correct. The fav albums in my Qobuz app is around ~700 albums.

02/02 20:13:12 Trace: [storage/streaming] [Qobuz] sync completed in 4137ms
02/02 20:13:12 Info: [storage/streaming] [Qobuz] library for userid xxxxxx has:
02/02 20:13:12 Info: [storage/streaming] [Qobuz] 688 favorite tracks
02/02 20:13:12 Info: [storage/streaming] [Qobuz] 48 favorite albums
02/02 20:13:12 Info: [storage/streaming] [Qobuz] 0 purchased tracks
02/02 20:13:12 Info: [storage/streaming] [Qobuz] 0 purchased albums
02/02 20:13:12 Info: [storage/streaming] [Qobuz] 0 playlists
02/02 20:13:12 Info: [storage/streaming] [Qobuz] 13 favorite playlists
02/02 20:13:12 Info: [storage/streaming] [Qobuz] Scan reported Library updated LastScanned=2023/2/2 12:13:08 PM

Hello Yeh,

I’ve seen several people reporting this today.
I don’t think it is an issue with your equipment.
It seems Roon is having problems communicating with Qobuz for some people.