Pops when switching songs or stopping music

I am experiencing the loud pops as well.
I am using a Roon Rock playing to a Gato PDR-3S.
As described abov only between some songs or when eg stopping the music…
… to me it sounds like a software problem with Roon…

Hi @Peter_Bagger,

Is there any change in behavior if you add a bit of Resync Delay in the Device Setup tab for the zone in Roon?

FWIW - adjusting the resync delay never had an impact on my issue - RPi3 with HiFiBerry HAT running DietPi. Only changing to an RPi4 and the same HAT but running their HiFiBerryOS truly solved the problem for me in all cases.

Hi Noris
Adding a bit of resync dalay do nothing to this problem. Pops after playing stille happens.

Here is where you should investigat:

  • The pops only happens with DSP active. Eg. adding Max PCM rate (power of 2).
  • The pop happens at the same time as the “signal path icon” disappers if you stop playing.
  • Or when changing song having another quality (e.g. 44,1 kHz 16bit to 48 kHz 24 bit maq).

Thank you Dean.
Agree that resync delay does not help.

Hello @Peter_Bagger,

I spoke to our team regarding your case. Roon is not causing these pops, they happen when playback is stopped and the device is stopping audio output.

Roon is not in control what a device does after it stops playback. We will reach out to the manufacturer, Gato, on your behalf to look into this further, and we suggest you do the same.

I have the same kind of problem with a GATO 450 NPM. When upsampling DSP is active, I have a crackle 6 seconds after pausing the music, when the “signal path icon” disapears.
Do I have to open a new case ?


Hi @Claude_Troncy,

I would suggest you reach out directly to Gato support regarding this behavior.

Hi Troy
You say it is Gatos problem and I will report to Gato but…
How can it be at the Gato side when this only happens with DSP activated?
I could understand your reasoning if this always happened?



Hi @Peter_Bagger,

Generally speaking, pops happen when an application requests the audio device to switch sample rates and the time it takes to perform this action is a bit longer than usual.

As I mentioned in my previous post, Gato Support would be in the best position to address why these pops are occurring when the sample rate changes.

Hi @noris @Peter_Bagger
My problem is not exactly the same than Peter’s one, as described here
but I have contacted GATO, and in a first analisys it seems that they never heard about the problem.

Hi Claude and @noris

I have also reported to GATO and Kresten is looking in to our problem. The GATO people are so genuin and serious about their products, but we also have to appreciate they are a small company :slight_smile:

My personal analysis is that this problem is only there with HIGH sample rates - and ONLY using Roon.

I have used below file for testing:

Playing Living through DNLA 192/24 directly to Gato - does NOT create any POPs.

Playing Living through Roon 192/24 to Roon with a ‘clean signal path’ WILL CREATE POPs.

Playing Living through Roon but downsampling to 48/24 does NOT create any POPs.

Playing Living in MQA quality from Tidal does NOT create any POPs.

Don’t know where this brings us, the problems seems to be something with high Sample Rates and Gato in combination with Roon (and it appers in Roon even without using DSP to upsample).

At least, I seam to be able to get rid of the pop’s for most music by avoiding to use Roons’s upsamling functionality (which is probably OK as Gato is upsamling to 192/24 anyhow).

And then one could choose to use the DSP in Roon do downsaple High Res Music - which would be a shame - but a least one can avoid the POPs.

This is probably all I can bring to the table :slight_smile:



1 Like

Bonjour Peter,
That’s exactly what I see (hear) with my Gato 450S NPM.
I also have contacted Kresten, he sent me a video and asked me if it was also my problem. I think it’s your video ?
So they are investigating the problem.
The Pop also happens when I pause the track but not the first time. This is very strange.
I had a look into the Ethernet packet, but i could not see any difference between when there is a pop and when there is not.
I also downsample everything above 96kHz in roon DSP to avoid the pop.

I think in DLNA UPnP there is no protocol above TCP, but there is one in roon ready device. That could explain why there is no pop in UPnP, the software involved in the Gato is no the same.

Another thing which is strange is that you do no have pops in Tidal. Did you try to disable the MQA support in the Gato, just to see if it has an impact.
Have a nice day

Hi Claude and @noris

Gato have solved the problem. No more pops!

I have just beta tested software version gato_1cu_br v3.6.82. I have listen for two hours without Pops!

Don’t know how long time it takes before they are able to release an official firmware version though. :slight_smile:

What a serious, responsive and agile Company Gato is!
(not to mention their great sounding products!)

1 Like

Hi @Peter_Bagger
Yes I agree with you, the 400S is a fantastic sounding product.

Hi @Peter_Bagger,

Thank you for looking into this issue further with Gato support and happy to hear they have a new firmware in the works that helps with this reported issue!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.