QNAP - Roon Server = Stopped after update [Fixed in build 880]

:mega: See staff post


Original post

Hi. After I updated ROON software on all devices (as usual) the APP can not find the core: neither via IP, nor automatically.

I updated ROON SERVER on QNAP HS-251 too, but it did not help, it shows the status of the server “STOPPED”.

Here below are some screenshots:

Can you please help?

Please install the latest RoonServer.qpkg and try again. Read more about changes: Roon 1.8 (Build 846) is Live!

Hi BlackJack.

I did it. I went to the QNAP APPS and installed the latest build 846, which is shown on the screenshot of my post. Still nothing happens.

For QTS 4.3.6 you’ll not get the latest (and needed) Roon pkg 2021-10-03 from the appcenter. You must download and install it manually.

Thank you @Burkhardt_Petermann. Do you have a tip for dummies (like me) on how to do it?)

Download from here https://www.qnap.com/de-de/app_center/con_show.php?op=showone&internalName=RoonServer&version=2021-10-03&II=197&qts=5.0.0&seq=155&os=qts
Then go into the app center and choose manually install.

1 Like

it worked!!! I appreciate your help @Burkhardt_Petermann.

Now the app finds the core but then I am pushed to a black screen with “Loading” icon and nothing happens. The same occurs when I am trying to connect to the core via my mobile phone.

Did someone meet the same problem before?

I am having the same issue as you with Roon server stopped on my QNAP. The link above to a download does not work for me. Anyone got a solution as to how to get Roon back working on my NAS? Are these updates Beta tested before they are released?

OK solved the issue by going to App Centre on the NAS and updating from there. All working fine now.

Lucky you ) The update worked for me but I still can not access my library because the “loading in progress” black screen never disappears (like shown in the image above).

I had this problem too. Had I not seen this thread I would have no idea there was an issue.

Happened to me also, endless loading logo and nothing happening. After the update, Roon on QNAP can’t use local NAS folders anymore. You need to add network share folders as source of your storage. Not sure if it’s a bug or intentional. Anyway, I had to reinstall the Roon core and eventually was able to log back in to the core. This obviously means that you need to restore from backup after that.

Maybe @crieke can chime in since this seems to be a common problem after the update?

I created a special thread for this topic, but no reaction of the #support so far. In any case all kind of advice is welcome here too

Hi @Vladimir_Grayvoronsk,
Can you send me your logfiles? They can be gained from the roon server web ui (ambulance icon). Will send you my email in a private message.
I am trying to figure out what’s happening here.


I too have the issue on my QNAP, after updating this morning my UI won’t find the server any more.

Would you like my logs before I apply the above fix? FYI I don’t have access to the UI / ambulance icon as my UI isn’t working.


Ambulance icon can be found from Roon core interface on QNAP/QTS. Open Roon server application in QTS and you can see the ambulance icon in the lower left corner. You don’t need to have Roon UI running for that.

I hope the local storage problem can be solved since now when using network share, the library won’t update itself. I need to manually rescan every time I add new music or wait untul the 1 hour scan interval rescans the whole library (which is quite slow process with ~3700 albums). This was the reason why I moved to using local library in the first place since local library tracks changes in real time.

Thanks, found it now. However I click to create zip and it does nothing, just sitting there.

After 10 minutes of a couple of tries, I’ve given up and installing the manual pkg from above. That seems to have done the trick.


I have a QNAP TS469 pro, with the same issue. I have manually uploaded the latest version, but I am now stuck on the loading screen. How do you add network share folders? If this is the solution I would appreciate any advice that can be provided.

There seems to be a lot of problems with getting ROON up and running on a QNAP NAS. You guys should get an Intel Nuc and run ROCK. Your NAS is for serving up music files. Get an Intel NUC with max RAM and a 1 TB SSD for your ROON library (NOT for your music files). My setup is VERY stable. Rarely do I have any issues,

The same is true for my Roon on NAS setup. Sadly rarely is not the same as never and it also might get anyone at some time.

1 Like