Qobuz gapless playback gone [Improvements released with Roon build 1202]

This gapless problem would only be noticeable on consecutive tracks that flow from one into the other with no break. I don’t recall Roon Radio playing consecutive tracks from an album so how would this affect Roon Radio in any significant way?

Because gaps between tracks in mixed playlists are - sometimes - up to 20 or 30 seconds. Mostly when using streaming content, but also when mixing local and streaming content. So the issue is not only that gapless albums might be non-gapless, but also pauses between tracks generally might be very long.

If you are affected by this issue, you‘ll notice. Because music flow is interrupted. Everyone who‘s not: good for you!

I think that such behavior is generated by another problem, which is local and not related to gapless play.
I advise you to open a technical support ticket dedicated to your problem.

1 Like

I did that weeks ago. But I was told it is not a local problem and my network is stable, my Nucleus is fine, my router also.

There is an issue with Roons streaming cache support have already indicated this to me in another thread. Can we please stop trying to palm this problem off to local users as it’s not, it’s a Roon issue pure and simple.


Deleted not worth it

I’m dealing with the gapless problem, but this generates extremely short pauses (well below 1 second). I think that the pauses of 20-30 seconds, appearing including local files, show the presence of a problem other than the gapless one (and it does accumulate with the gapless one).
I didn’t say that there is no issue with Roon streaming cache…


While we are talking here: today the problem hardly occurs at all here. But - I can try the same play list tomorrow and I will probably get many many seconds of gaps between tracks. That is the problem with the issue: one day like this, one day like that.

It’s would be better to test this on continuous albums than on a playlist. You may not catch to the gap on a playlist.

Well, had to join this microcommunity starving for gapless (Qobuz + Tidal + Local) playback :sneezing_face:

The latest early access release (build 1197) should have a fix.


1197 appears to have fixed the gapless problem…at least on my setup.

1 Like

@musicjunkie917 That’s good news.

Can you play Qobuz as well as Tidal streams gapless? I experience the gapless issue with both, but attention is mainly given to Qobuz.

I have Qobuz only…

Thanks, @musicjunkie917, looks like I’ll have to be patient then :wink:

At least it’s a good start.

I’ve joined up for early access today, in order to try out the early access build 1197.

Very early indications after doing so suggests that this specific early access build has indeed fixed gapless playback and/or removed the delays experiences between tracks.

This has been when selecting and playing an album, from beginning to end, via qobuz. Albums that were frustrating listens due to this issue have all played through fine so far, and without issue.

I don’t ever play Qobuz playlists, so haven’t tested those, nor do I tend to use Roon Radio much, as I prefer albums to finish and for playback to cease at that point, so can’t comment on that working smoothly, either.

Also, I don’t have Tidal.

Anyway - this could be a great big YAY from me if this issue proves to have been completely negated by this specific early access build! :joy:


Hey Everyone,

Yes, this is correct - we have released a fix in early access :pray:

Here is more information on early access if you’d like to learn more:

As well as the recent release notes:


OK. The situation remains stable at this point, across my endpoints with early access build 1197. Same use case (Qobuz, album playback, only). But, with one exception that I’ve identified thus far:

Pauses/delays/gaps in playback of an album, following an instance of a very short track track. In my experience, these problem tracks tend to be super short - around 10 seconds or less. When the song/track is that short, buffering and delay tends to follow it, ahead of the subsequent track playing, eventually. The delay is then like those we’ve been seeing reported in this or other similar threads. After the delay, playback then returns to normal and remains gapless, until another short track encounter arises (should there be one in the album).

Things have improved, hugely, with 1197, judging on my playback experience, today, but this scenario outlined above still results in the issue. Plus, it’s also potentially possible that interacting with the UI of Roon Remote running device at the point of buffering may even help trigger progressing to the next track (fyi my iOS devices running Roon Remote tend to have the beta Lock Screen controls enabled - all are running the early access app versions).

Lastly, just to add, this behaviour when encountering very short tracks has actually been an issue that I’ve encountered for quite a long time (I just happen to have a number of albums I play that has such tracks), and this was before the more general gapless/delay problems that appear to have evolved recently.

Hope this is useful @benjamin in general this early access version is doing the trick, aside from the scenarios outlined above.

EDIT: I also think this short track issue may actually apply to local AND Qobuz playback scenarios.


I have downloaded the Early Access builds for my MAC server and remotes. While I have JUST done this (within the past hour), I am still finding gaps in what should be a gapless playback experience (the transition from Breath In The Air to On The Run on Dark Side of the Moon or side 2 of The Beatles’ Abbey Road) using a BlueSound PowerNode as my transport using Qobuz. They remain properly gapless with Tidal and the Qobuz versions play properly when using their App (not Roon) as the control mechanism through the same PowerNode. So things here, in my setup anyway, remain problematic.

I’m very sorry to hear that @James_McKeand

@Early_Access is this reason to look further into a solution?