Required Audio Codecs Missing error on Windows 10 Pro N

I am running Windows 10 Pro N(10.0.14393). After Windows upgraded itself, I keep on getting Required Audio Codecs Missing prompt. I have downloaded and ran the media codecs (both for x64 and x86) but rebooted multiple times and reinstalled Roon, but nothing is helping. On this machine, I run Roon mainly as a controller app

If your Windows N machine is just a controller, then what is the computer that is running the Roon Core software? Can you describe your system and how is it setup. do you get the message when you start Roon, or is it when you are playing something on the remote server or playing something to the actual Windows N machine.

The Roon server runs on a Windows 10 Pro VMware (separate) and the media is stored on a QNAP TS-231. I also
use LG GPad, Samsugn s6 and a OPO 2 as controllers. The particular machine that I have described here is an Asus Zenbook and I primarily use to control music to a Windows Server 2012r2 running the Roon Bridge which connects via asio to my DAC. The only reason, I want this Zenbook based Roon controller to work is, I have noticed that, I can only changes the metadata for unrecognized artists through the windows client. None of the Android based clients allow me to do that or I simply do not know. It does not matter if Roon Server already is playing something via other controllers. The Roon on the Asus Zenbook, simply would not come up.

Have you installed the media pack for Server 2012r2 on the Roon Bridge machine ?

Yes I have. The Win10 machine that I am having issues, used to work fine, till the Windows got updated a few days back.

Let’s leave a tag for @support to follow up with you.

Hey @ahmed_iqbal – can you try this media pack? Thanks!

Hi @mike @support

I was not able to install this media pack on my machine where I am having issues. I have downloaded both the media pack (x86 and x64) and I get an message, while installing saying that this update is not compatible with my machine. Any other ideas.


Hello ahmed,

You might try this link:

This update supersedes update 3010081 in Windows 10 build 1511.

1 Like

Looks like I have this media pack already installed. I gave up on getting this to work on my laptop and primarily use the Android devices to control the Roon Server.

Hi @ahmed_iqbal – we took another look at this and it looks like the correct media pack is this one:

I think that should help if you’re still having this issue. Thanks!

Thank you, Mike. This one absolutely worked.


A post was split to a new topic: Codecs Missing Staging

If you go type About into the Start menu and go to the About Your PC screen, what edition and version are you running?

Feel free to post a screenshot or PM it to me. Thanks!

Thanks for the screenshot @Jon_Leonard – can you try this one?

Let me know if that doesn’t work and we’ll take a deeper look. Sorry for the trouble here!

Sorry, “not applicable”

Did you get my PM?

Hey @Jon_Leonard – sorry for the trouble here. This is definitely strange.

Can you give me a full rundown of your setup, as described here? Can you also confirm the Media Packs were installed on your Core machine?

This is surprising too:

Since you’re running Windows 10 Enterprise N, and that operating system is supported by that Media Pack:

No, I’m sorry. I coulda sworn…oh, never mind. I actually hadn’t installed kb3099229.

Hi @Jon_Leonard ---- Wanted to check in with your after I saw you response to @mike. Let me know the current state of things and we’ll keep the ball rolling :wink:

Looking forward to your feedback!