ROCK install/update error on NUC8i5 [resolved]

I installed ROCK on NUC8i5 with HP 250GB NVME SSD.
It works well.

But there was message about version update.

Then I tried update but NUC goes to kernel panic.

Then I tried to make new ROCK installation USB and to re-install ROCK but NUC show another error message.

“ERROR: Roon Optimized Core Kit could not find disks to install”

New ROCK installation image is " roonbox-linuxx64-nuc3-usb-factoryreset-100000221.img".
Flashing was done by etcher with original “.gz” file on Windows 10.

Then I found old rock image and re-install this old ROCK it was installed well and booted well.

ROON show update message and can’t go further.

Old version > Update > Kernel Panic > Old version re-install > Update …

How can I install latest ROCK/ROON core on my NUC8 ?
Is there any other latest ROCK image ?


tell me about your ROCK system

NUC model? m.2 ssd model? internal drive model? anything else attached?

Hi Danny,

Bios is latest, 2020-0730 version.
RAM is 8GB
SSD is HP ex900 250GB NVME m.2

Hi @Jay_Seong,

We have an idea about how we might be able to resolve this, but we haven’t been able to reproduce this issue on any of our devices in-house. If you’re interested in testing this solution for us we can send an updated image that contains the changes that we think might help here. Please let us know and we’ll pass the image along to you. Thanks!

Have the same problem, would appreciate the new image.

Go ahead and send me the beta image. It is just bizarre that this happens with 221 but not with 219 and that bios sees the drive fine. I cannot believe others with the identical hard ware are not having the issue. The other guys who posted with the problem has the 128gb transend ssd. Anyhow, send me the image.

Hi @pascabl — Can you give us some details on your setup? NUC model, SSD model, any connected drives / internal storage, etc.

Can you also send a picture of the HDMI output so we can confirm it’s the same? Thanks!


SSD Transcend 110S (128GB)
No connected drives

Can‘t do anything further because I‘m missing a keyboard

thats ok to test the beta fix… if you can boot up and it finds the drive, itll prove the fix worked.

@pascabl PM sent

Does work.

I have the same issue. My NUC is dead. I just clicked “update” in the Roon client and the server looks like this.

Please advise. I am dead in the water with no way to get music going!


Intel BOXNUC8I3BEH3 NUC Mini PC - (Black) (Intel Core i3 8109U, Intel Iris Plus Graphics 655, BareBone)

Transcend 128GB NVMe Pcle Gen3 x4 MTE110S M.2 Solid State Drive

Crucial CT8G4SFS824A 8 GB (DDR4, 2400 MT/s, PC4-19200, Single Rank x8, SODIMM, 260-Pin) Memory

2x SanDisk SDCZ48-128G-U46 Ultra USB Flash Drive.

Nothing has changed recently FWIW

@dylan can i have the image too, please.

just grab latest stable from image – we’ve released a fix.

run the recovery procedure once you boot from USB



Same problem here as displayed by others. It happened when I hit update this morning



Hi Danny:

Please send instructions on how to fix issue



Not sure how to do that. Please explain

Thank you,

I’m having exactly the same issue with the same 256GB Transcend SSD, I’m getting an identical message. If there’s some kind of fix can you share it please, along with instructions on how to apply it? Thanks so much.

@danny Can you point us to an URL where the instructions are documented, I don’t know how to do what you just recommended…

1 Like