Roon 1.8 (Build 880) Feedback Thread

How many Roon customers use an iPad Magic Keyboard? Can you accomplish the same functions with the touch screen?

1 Like

Same happened to me cannot update on android devices:

Opening roon and it says needs update with “Get it on Google Play” Icon.
Clicking that icon opens Google Play Store app but there is not ‘Update’ button, instead is the Open button.

But if close roon, and open Google Play Store and then search for ‘roon’, it display the roon app information with the Update button and then clicking it the build 880 is installed.

1 Like

That happens with the IOS Play Store sometimes. You go to the app and all you see is “open.” Then, you click that and you see the “update.” Strange.

On a mac mini. Never had one issue until trying to install this update.

tried restoring, no go. (Roon opens, plays half a song, then quits and I get the same alert.)

Tried reinstalling (creating ROONSERVER_old folder, reinstalling app, and doing another restore), and getting a “backup failed” message.

Good times.


The update went very well, with Roon Core installed on AudioLinux, and Roon Remote on Windows 10 and Android One.
Thanks to the Roon Team!

Enough people complain about these, the respond from Roon would be nice. It’s tiring to use touchscreen while other apps can just scroll via trackpad. If you have a chance to use one, I think you would understand.


Yes, I’m sure. However, I think Roon probably prioritizes by their bottom line. I would.

Roon on iPad OS is a pretty crappy experience. I turned off my auto-renewal for Roon. When Roon decides the iPad Pro is worth their time and fixes the constant crashing and usability issues I’ll turn renew back on. Otherwise, sayonara to Roon when my paid subscription expires. It’s not that essential.


Roon seems to work well on my iPad Mini 4 and 8th Gen IPad. However, I usually use a Dell laptop instead of iPads.

Definition of disaster


Update went well in my NUC Core running ROCK and in all my Macs, iPads and iPhones. Thanks for fixing iPad mini 6 screen ratio issue :wink:


And I say thanks for completely gutting my search. Jeezus

I’m having an issue with getting any of my Ropieee zones to appear. After rebooting the Rock docker container and each of the Ropieee’s, they now show up in Settings / Audio, but not in the zone picker. All I can see are my Sonos zones.

1 Like

Same exact behavior here. System is unusable.

1 Like

Having the exact same issue and can’t figure out how to fix it.

1 Like

Try uninstalling, then reinstalling Roon Remote. Reboot core & remote. It finally worked for me once I could see 880 on PlayStore.

1 Like

So as a M1 user I‘ll better wait?
(iOS already shows that an update for the remote is available)

1 Like

Has the problem of roon remote iOS devices constantly crashing been fixed in this version? Should I buy an android tablet?

1 Like

I would say wait.

I was able to get some stability by having a screen share open from another computer to my M1 Mac mini. If you’re using an M1 as a core and it’s connected to a monitor you may have more luck than I did.

I’ve now been able to listen to about 2 hours of music uninterrupted. Fingers crossed it continues.


Do we really need an “! improve this photo” right there on every @#£&* artist image? Nice feature, but can’t it be hidden in the 3 dot “edit” menu?