Roon ARC Error code 504 happening for past 2 days

It’s still happening to me since 2 days ago. I didn’t change anything on my configuration. I have port forwarding set up on my Asus RT-AX88U and the settings look good.
The only thing I can think of is that I changed plans on my internet infra provider and the modem reset itself. This is the error I get from Roon -
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“77.ddd.eee.fff”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“doaction request return statuscode: ConnectFailure”}

Seems like an error in your or your ISP’s configuration. I know you said nothing changed, so maybe your ISP. The original error in this thread (caused by Roon server outage, expected to be resolved since November 14) resulted in no error message, the Roon ARC settings continued to say “ready”, and no error.

Your error looks exactly like one I solved just recently here, also with an Asus, an RT-AX82U in this case:

However, in this case the issue was an ISP router in front of the Asus router, which necessitated two port forwarding rules, one on the ISP router and one on the Asus router. You don’t seem to have this according to your description, and anyway it worked previously for you, so I guess it’s something different.

Nevertheless, probably something specific to you and not a general Roon server problem. It’s timing out and not getting an external IP address (“router_external_ip”:“null”)

Another similar error here, but also caused by having two routers:

1 Like

Thanks @Suedkiez. I never needed to go into the settings of the internet provider’s modem but maybe something they changed remotely causes this issue. I will try looking into how I can configure a DMZ or port forwarding on the modem. Can’t think of anything else that might be a problem all of a sudden.

Don’t configure the router so that the core is unprotected in a DMZ, if you have only one router. It’s a recipe for disaster. (It can be done safely with two routers, but this does not seem to be your scenario)

Wait, so do you have a modem and a router separately?

1 Like

Yes, I have a modem from the ISP (can also be a router but configured only as a modem), and the Asus router.
I saw in a different thread that someone had to restart their core so I will try that first (when I get home).

Oh. I didn’t realize that. Then it’s most likely exactly the solution from the first linked thread. You need two daisy chained port forwarding rules. One on the modem that forwards the external port to the router, and a second one on the router that forwards it onward to the Core.

I.e. this one:

Thanks! I’ll try figuring it out

@Suedkiez I restarted my core, and now I get a different error -

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“77.ddd.eee.fff”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="\” s:encodingStyle="\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}

Another strange thing is that going to “About” to upgrade to the new release, I get this message:

It’s may be a bit strange that the error changes after a reboot, but :man_shrugging:

ConflictInMappingEntry may indicate that you have this:

Or maybe more likely because you have a modem and a router:

The new error when checking for update may or may not mean anything. Possibly just a temporary issue on the Roon server, for instance. They released an update earlier today. I would wait for a day to see if it goes away before I’d start worrying about this.
EDIT: Just saw someone else with a similar update error when trying to install, so I guess it’s really just a general issue on Roon’s update server

1 Like

About the 1st option, is it wrong to have both upnp enabled and manual port forwarding?

As a general rule, probably yes, it seems definitely safer. We have definitely seen cases on the forum where a router did happily try to do both, use the manual rule and also configure the same thing based on UPnP, and ended up with conflicting settings and this error.

(I would expect that a decent router somehow figures out that it makes no sense and, for instance, does not accept a UPnP request coming from an IP address for which a manual rule already exists. But maybe I am being naive and there is a reason for why at least some routers don’t do this)

I disabled UPnP and it still doesn’t work.
My ISP modem is configured as a bridge, and I don’t even know how to get to its interface… so I’m kinda stuck

Hmmm. When having a router in modem mode and a separate actual router, it’s usually (always?) necessary to have daisy-chained rules, as I tried to explain in the second link above. The first router/modem, which is connected to the ISP, needs to get the external traffic to the other router and the other router needs to get it to the core. If the first router/modem doesn’t forward the traffic for the ARC port to the router, there is nothing that the other router could send to the core…

It helped in the linked case and several others with this error.

I’m not sure if there are dedicated cable/DSL modems where this is not necessary, and how this would work, but cannot rule it out.

Is the modem from your ISP? Is there no manual for it?

Else, we need to wait for smarter people than me, I’m afraid.

At least your error checking for updates is clarified :slight_smile:

Yes, this morning I was able to update Roon to the latest version :slightly_smiling_face:
However, ARC still doesn’t work. I had a chat with the ISP and they claim that there are no special security settings in place, and that not his has been changed for me in the past week. I don’t know whether to trust the support agent in this case but I’m running out of ideas by now…

So what about setting up a port forwarding rule on the modem?

When I get home I’ll try entering its interface. Thanks!

1 Like

It’s not just about changes related to security, it’s mainly about whether you still get a public routable IPV4 address from your ISP or whether they no longer provide it to you.
You could try to figure that out by testing:

Please enter the displayed IP in the next test:

To verify that you have a public IP that is addressable from the outside.
If canyouseeme can’t see it, ARC can’t see it either and you will need to contact your ISP again.

Thank you Axel!
The test failed for me on port 80. Is that the right port to check? It also failed for the Roon port obviously.

Roon uses normally 50000 or 50002. Go to Roon remote > Settings > ARC settings, and it should tell you the port that it is using.