Roon can't find my music files anymore since the update

Yes please ! This morning my collection has reverted again to just 2 albums down from 43k tracks last night ! How can this behaviour be stopped ? Can I/we revert to production software without losing our collection(s)/drives ??
M

Just wondering does nobody from Roon Team actually read any of these enquiries ? I have had no Roon/Arc music playback available to me since the weekend ! I’m now thinking that I shouldn’t be recommending Roon to so many people as it is not as secure as I once thought . I have reverted to latest production software for Nucleus+ (A) and remotes and Roon Arc , my library has reappeared but nothing will play " Playback was stopped because a track failed to load " no matter what track is attempted .
Really disappointed that Roon are staying on the sideline as these problems are ongoing with many people .

~M~

@Early_Access @metadata_support

I think the topic wiil close before someone at Roon office acknowledge our problem.

@Roon_QA please flag someone to help us

Hi @Benjamin, I have a similar problem with a NUC ROCK setup, as do several other members. Please give us news.

Not Roon support but trying to help :slight_smile:

If I understand correctly, your music files are on the WD My Book Duo 16To, and this was always attached to the Nucleus and never another machine?

Do you know if the drive is formatted as NTFS? (If you bought it new and never changed anything, it probably is)

I see that you tried attaching it to your Windows machine but that did not help. When you removed it from the PC, did you properly go to the (far too small and unobtrusive) icon in the Windows taskbar and remove it safely like this?

Sorry about your troubles

Most likely, earlyaccess has nothing to do with the issue. However, if I may say so, if you are not comfortable with computers and sorting out issues, you should stay on the regular “production” branch. Earlyaccess is precisely for finding problems before they hit the “should just work” population. And if it’s not fun for you to tinker, waiting a few weeks for the latest features is not so bad.

That said, it is not great that currently Roon support needs a few days until you are at the top of their list. However, you have a Nucleus and paid for support. Therefore, if you have a specific Nucleus problem, you should not post in random threads that are about similar but not necessarily your specific problem (your disk is internal, others here are external which is very different), but go here to the dedicated Nucleus support area, where hopefully you will get faster help:
#support:nucleus-support (you can click this)

I would help, of course, but I am not sure what is going on in your case. The Roon support knows the Nucleus and they can look at your technical logs remotely to see what is going on

Hi, @Pierre_Dallaire, apologies for the delayed reply. Could you, please, confirm that I understand your problem correctly:

  • You had an external drive connected to a NUC running RoonOS
  • After an update you stopped seeing content associated with this external drive in Roon

May I kindly ask you to answer the following questions:

  1. Have you tried rebooting NUC unit running RoonOS?
  2. What file system does your external drive has?

Thanks!


Ivan

@ivan
You understanf my problem correctly

  1. Have you tried rebooting NUC unit running RoonOS?
    ==> Yes several time

  2. What file system does your external drive has?
    ==> no system files. Only music files

Thank you for the reply. By file system I meant it’s type: NTFS, exFAT, FAT32, etc. Could you, please, provide this info?


Ivan

Thank you @Suedkiez,

I had to format the drive when I installed it and I know just enough about NTSF and Fat32 to remember that I checked before on Roon community to see if an option was better than the other. Can’t remember which one I choose, but the one I din’t choose seemed to be really problematic for Roon users…

Anyway, I can’t transfer my files on another drive and format again, because I don’t have another drive. And I can’t imagine that Roon people are stupid enough to impose an update that will banish NTSF or Fat32 without any kind of warning… Right?

NTSF

Thank you for the reply. Could you, please, make sure that RoonServer is running on your RoonOS box at the moment. I am going to request a diagnostics report so that we can start investigating your case internally.


Ivan

Ok, one minute, I will plug the Drive on the Nuc

ok, hardware is on

Thank you, @Pierre_Dallaire, confirming that your diagnostics report was received. I am going to examine it and the discuss with our tech team.

Apologies for troubles.


Ivan

I see that Roon is on it, but just to clarify why I was going on about the disk format: It’s not that Roon removed support for any.

However, the new Linux kernel in the new RoonOS update has much safer NTFS support. One part of this is that it is more strict about NTFS disks being error free.

There have been several cases on the forum since, where it turned out that NTFS disks had once been connected to Windows PCs and removed by pulling the USB cable without properly doing the “safely remove” procedure of Windows. This leaves an “unclean removal” flag on the disk.

Earlier Linux kernels didn’t insist and mounted them anyway, which in some cases led to later NTFS corruption.
The new kernel, as used now by RoonOS, is strict about the NTFS requirements and refuses to mount such disks. The solution being to attach them to Windows again and doing the safe removal.

Here is one such case and Danny recommending exFAT for external drives:

Which was the recommendation previously as well. More:

2 Likes

I understand, but I did the procedure to securely eject the HD from Windows. I received service from Roon technician. Waiting for a diagnosis

Yeah I was not aware of that at the time and it was one thing I at least wanted to rule out first.You are in good hands now :slight_smile:

But the memory disk in my brain must be corrupted, because I was shure I have formated in exFat… Perhaps the Raid 2 option I wanted on my WD Book Duo required the NTFS… I may check

1 Like