Roon dropouts

(Christian Fredrik Steen) #1

To whom it may concern:
We have an ongoing issue with a Roon nucleus integration in a custom installation containing smart-home integrations and many end-points for audio and video. The topology of the network consists of Pakedge routers, switches (both managed and unmanaged) wireless access-points. The router feeds the main switch with ip’s and from the main managed switch, all other switches are connected. I have tried to install the Roon Nucleus on various points in the network, i have also tried 3 different Nucleuses both the standard and the +. The issue is as follows:

While all other products and integrated systems works on this network, the Roon has issue with drop outs and the only way to resolve it is to manually restart the product. Has this something to do with IGMP configurations in regards to snooping and quering (multicast ip’s)? The main endpoint that is being used is a Devialet 220 pro with the roon ready driver installed. Since all other products in the network works fine, i’m thinking that the most likely scenario is that there is a bad config in the network in terms of how information from the Roon is being distributed on the network.

Hoping that you can provide me with some help, i’m stuck.

Much thanks, Christian.

Continued Roon dropouts
Continued Roon dropouts
(Jeff) #2

Have you looked at the other Devialet issue threads? If using the new RAAT feature the only work around at this point until Devialet fixes the issue is to limit your Devialet down to 100mbps.

(Christian Fredrik Steen) #3

Hey! Thank you for you answer. I’m using the new Roon ready driver in the Devialet, i’m not really that accustomed with the RAAT feature, but if this is included in the new roon ready driver, then yes that’s what i’m using. To limit the Devialet, is that something you do in the Devialet config? or in Roon?

(Jeff) #4

You can’t do it in the devialet config. If it’s plugged into a managed switch, do it there.

(Christian Fredrik Steen) #5

Cheers, i will try it and get back to you :slight_smile:

1 Like
(Christian Fredrik Steen) #6

On second thought, I am not really able to limit the Devialet to 100 mbps from it’s current setup location. Is there some other way to get around this issue without limiting the bandwidth on the Devialet?

(Michael Fanning) #7

@Christian_Fredrik_St I could be wrong but I believe some people with the Devialet are using Roon’s implementation of Devialet AIR (not straight Devialet AIR but rather Roon’s adaptation) with some success. That defeats the purpose of the Roon Ready (RAAT) implementation but, on the other hand, it seems to be rock solid with the Devialet platform.

(Mike) #8

Can you use WiFi? Wired to Roon Core, WiFi to Devialet. This works.

1 Like
(Christian Fredrik Steen) #10

Thanks for the reply! I’ll try this tomorrow.

(Noris) #11

Hi @Christian_Fredrik_St,

As other users have mentioned here we are currently investigating an issue with Devialet regarding the RAAT implementation (main thread here: Audio file loading slowly since Devialet RAAT).

The 100 mbps workaround mentioned is not meant to be a permanent solution but rather just a tool to see if this is the same behavior that we’re aware of and discussing with Devialet.

While our investigation with Devialet progresses you can try using the Devilaet Air driver to see if that works as expected. You can find more information on how to set this up by looking over the following guide: https://kb.roonlabs.com/Devialet_AIR.

Thanks again for your report here and I’d definitely suggest keeping a close on on the main thread I mentioned for any new updates. Do let me know how things are going with the Air version of the driver!

Thanks,
Noris

1 Like
(Christian Fredrik Steen) #12

Hello again,

The customer tried the Devialet Air driver, both the ETH (ethernet) and the Wifi driver. This yielded no change in result. However, while using the Roon ready driver and wifi connection on the Devialet, it worked! @MJB Thank you for suggesting this, I now have a satisfied customer. Hope this info will help others in their troubleshooting.

Cheers,
Christian
Duet Audio

2 Likes
(system) closed #13

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

opened #14
(Christian Fredrik Steen) #15

@Steve @support

Unfortunately, the Roon still stops playing music suddenly from time to time. While trying to reconnect to the device, the customer is stuck at the “choose your Roon Core” screen, with the message: “initialising”. To get the unit up and running again, a physical restart is needed.

Any tips?

(Michael) #17

An easy workaround I found was to insert an inexpensive unmanaged 10/100mbps ethernet switch in front of my Expert Pro. I got one on Amazon for about $10. This throttled the ethernet speed into my Expert Pro to 100 mbps and the dropouts and errors went away.

Haven’t a clue why this works, but it seems to. As Roon has stated, it’s a temporary solution until they and Devialet can properly resolve this issue.

(Christian Fredrik Steen) #18

And this actually works, with zero dropouts?

(Mike) #19

That’s what we’re hearing anecdotally, but obviously it’s not what we would consider a fix.

Devialet is still investigating this issue, as mentioned here.

(Michael) #20

It worked for me. I first stumbled on this by switching my network speed on my Win 10 PC running RoonServer down to 100mbps. At the time, I was just trying different things to see if anything made a difference. This did! Of course, I didn’t want that PC running at just 100mbps since I also do backups there, so I put it back to gigabit speed and put the 10/100mbps switch in front of my Devialet. That also worked. No dropouts, no “audio file loading slowly…” errors.

I have heard from several others that it also worked for them.

Nope, not a fix, but a nice workaround until Devialet can get it resolved.

(Christian Fredrik Steen) #21

@mdconnelly

Did you also try the Roon-ready driver and wireless connection to the Devialet?

(Michael) #22

I did not try wireless because my wireless router is just a bit too far away from my Devialet to be dependable. Not sure what you mean by Roon-ready “driver”. In Roon Setup Audio under Networked - I enable the following:

Capture

Roon AIR works fine when my ethernet into the Devialet is at either 100mbps or 1000mbps. Roon Ready works fine at 100mbps but I get dropouts and the “audio file is loading slowly…” errors at 1000 mbps - particularly with hi-res (24bit, 96kHz, or 192kHz) content.

Hope this helps…