Roon internet radio and USB issue Soulution 540 DAC?


Hello, how can I add Sacramento’s Classical Station 88.9 - Capital Public Radio? I used the TuneIn link but it did not work, help?

Also, my Soulution 540 SACD player has a USB input, but when listening to Roon I get sound that cuts in and out rapidly, 5x per second. Any idea what might be causing this issue? The SACD player also has a SPDIF input, but my iMac only has USB, so I’d need another piece of gear to convert USB to SPDIF, but I don’t want to purchase it if my player is incompatible with Roon…

Thanks, Harry

Hello @Harry_Elliott,

Thanks for contacting support, I’d be happy to take a look over this issue with you.
Can you please provide more information regarding your setup using this thread as a guide?

As for the radio station not being added properly can you please provide a link to the radio station that you are attempting to use so that I can test it on my end to verify the behavior? I have found the following two links to be working on my end: (found from here)

For the Solution 540 SACD:

  • Do you by any chance have the USB drivers installed yet? I would take a look at the downloads page from solution-audio and see if installing the driver for your operating system helps resolve the issue, here is a link to the downloads page:
  • Does the issue of being unable to play music affect all kinds of content or is it restricted to only TIDAL or Local Media?
  • Can you please provide a screenshot of your Signal Path after starting playback?
  • Do you have another USB cable around and can verify the same issue exists with another cable?
  • Can you try another USB port on your computer?

Please let me know your reply to my above suggestions/questions when possible.


Hello Noris,

Thank you. I was able to add the radio station with your link. For some reason TuneIn had a link that was much shorter and Roon did not recognize it.

For the Soulution 540, I tried to install drivers but I have an iMac so the download did not work (Microsoft only available). Playback does not work on everything (Roon, Tidal, iTunes, etc.). I tried another USB cable and USB port, no luck. I will have to get a screenshot of the signal path tonight and post to this thread.

Any other ideas, let me know!

Thanks, Harry

Hello @Harry_Elliott,

Thanks for confirming that the TuneIn link I provided works and that playback does not work for your Solution 540 on any software. I am curious, does the Solution 540 show up at all on your iMac’s Audio Midi Setup? Can you please provide a screenshot of that page as well as the signal path?