Roon loses connection to Chord Poly when accessing via App [Pending firmware update from Chord]

I have a strange probl em with mye setup
Intel NUC with Roon connected with cable to router
Chord Mojo/Poly as endpoint
Ipad with Roon app for control

Playing music via poly from Roon works fine, but when I access Roon with the Ipad app I get choppy audio and often loose connection to the Poly. After 5-15 seconds Poly are available again and I can start music again from the app.

I very rarely have problems when I don´t have the Roon app active. Surfing the web from ipad does not generate problems.

Problems happens both with music from Tidal and Flac from local NAS (connected to same switch as Roon server). I first suspected my home network, but removing wifi extender and rebooting router did not have any effect.

I have latest firmware on Poly and Roon 1.4 (build 310)
300Mbit internet access via fiber and no congestion in the network.


Hi @Per-Oyvind_Odegard ---- Thank you for the report and sharing this observation you have made with us. The feedback is appreciated!

Moving forward, just to make sure I am understanding the issue correctly, you are only noticing the “choppy audio and lose of connection” when using the iPad, correct? Other devices acting as Roon remotes do not yield the same behavior?

Additionally, may I kindly ask you to please provide the following:

  • What is the exact model of the iPad experience the issue?

  • During your troubleshooting of this behavior have you tried reinstalling the application on the iPad?


Hello, I tried again now.

Used my iphone X with IOS 11.3 as remote instead of the ipad, and got exactly the same behaviour.

  1. Open app, it connects to roon server
  2. About 1 second of choppy audio before silence and then the iphone app show that roon looses contact with poly.
  3. After waiting 10-30 seconds I can press play and audio continues on Poly

I think the audio problem I hear just is the poly loosing the stream from the roon server.
I´m quite sure the problem is in the roon server and not in the iphone/ipad since that device is not in the signal path.

Normally I use my 12.9" Ipad Pro IOS 11.4 beta and get the same behaviour.

Tried again now and got an orange error message about roon having problem with communication with audio device. I have only seen this message ones.

Hi @Per-Oyvind_Odegard’ ----- Thank you for the follow up and providing the requested information, both are very appreciated!

Continuing forward, my assumption is the Poly is connected directly to the NUC hosting your Roon core, is this correct? Furthermore, can you please provide me with the exact specs of the NUC currently hosting your Roon core?

Out of curiousity during your troubleshooting have you tried testing with another DAC in place just to verify what the experience is like? Additionally, if you playback content via one of the mentioned remotes (iPad or iPad) what do you observe? Is playback/the connection stable or does it drop as well?


I´m not at home now, but just a bit of info. I will try to debug more tomorrow.

Chord Poly is a wifi module for the Chord Mojo, so the Poly is connected via wifi to the roon server. I don´t have any problems with DAC connected via USB.

My suspicion is that when I access roon via app the roon server do something towards the poly that breaks communication (or increase needed bandwidth). Poor wifi coverage might be the root cause but I´m not sure yet.

This is the poly:

Thank you for the reminder about the poly, @Per-Oyvind_Odegard. Getting my Chord devices confused obviously :dizzy_face: My apologies.

The fact that there are no issues when the device is connected via USB strongly suggestions that there is either an issue occurring with the Core machine and/or potentially with the network. I am definitely curious to hear what the experience is like when the iPad or iPad are used as an endpoint.

Additionally, can you please provide me with the exact details of your network configuration/topology while being sure to provide insight into any networking hardware you are currently implementing as well.


Hello, some more information

Before I got the Poly I have been streaming on Mojo via USB from my Ipad pro using the Roon app.
I have never had any problems while streaming through the ipad.

Intel® Core™ i5-5250U Processor
Crucial® MX300 275GB M.2 Type 2280 SSD
Crucial DDR3L 1600MHz 16GB

Router Zyxel FMG (Gigabit router with fiber interface towards my ISP)
HP Procurve 1800-8G ethernet switch
Qnap 219p NAS
300Mbit symmetric internet access
Both NUC and NAS are cabled, the rest is wifi (single SSID with 2.4 and 5GHz)

Testing today is done much closer to the wifi router (about 4 meters) to see if better wifi coverage change the behavior

  1. Headphones connected to Mojo/Poly combination, playing via Roon on Ipad
    Start music in Roon app on ipad pro
    Surf the web on ipad while listening
    After a few minutes I switch to roon app
    Roon app reconnects to server and roon loose connection to the poly (choppy music then silence) after poly reappears in the app I can start music streaming agin.

reboot NUC (I have tested with reboot of NUC before also without effect)

  1. Connect Ipad pro via USB to Chord Mojo (Poly disconnected from Mojo)
    Start music from Roon app on ipad
    Surf the web on ipad while listening
    After a few minutes I switch to roon app
    Roon app don´t reconnect to server (I guess this is because the app is active streaming)
    No problems with audio
    I repeated these steps several times without any problems

  2. Disconnect USB cable and connect Mojo to Poly again
    Start music in Roon app on ipad pro
    Surf the web on ipad while listening
    After a few minutes I switch to roon app
    Roon app reconnects to server and roon loose connection to the poly (choppy music then silence) after poly reappears in the app I can start music streaming again.

I have had the same problem both streaming from NAS and Tidal.


Hi @Per-Oyvind_Odegard ----- Thank you for the update and sharing the observations made during your testing. The continued insight is very appreciated!

Continuing forward I noticed from your network topology description that you are making use of HP Procurve 1800-8G switch. If I am not mistaken this a managed switch and we have seen a few issues crop up with these devices in the past ( Example: #1, #2, #3). I would recommend enabling flow control on the switch and confirming if this triggers a change in behavior with Chord Poly as we have seen it help other in the past.


I tried to power off both switches and move the roon server to the Zyxel router.
Still same problem.

Multicast was a bit interesting, do you have a link to more technical information about how you use it? Altibox use multicast for TV distribution but it is not supposed to create any problems for local multicast in the LAN. I disconnected the TV STB while testing today to avoid any problems caused by that.


Hi @Per-Oyvind_Odegard ---- Thank you for the follow up and sharing the results of your testing. Very appreciated!

Continuing forward, I noticed in our "partner device matrix to confirm that the POLY is certified as a Roon Ready device and I can see that it is not. In your “audio” tab is the POLY being listed as “uncertified”?


Hi @eric
I see that Chord Electronics advertise Chord Poly as a “Roon ready” device:

But your support Matrix does not list it as a “Roon ready” device. (Which I assume is correct)

Can you tell us if the Chord Poly is under review to be “Roon ready” certified as Chord is obviously aiming for that.

Best regards

1 Like

I was waiting for that answer :wink:
I have created a support question with Chord with link to this tread.

No information in the app about not certified in the default view, but it does say so under settings, as I´m sure you know. Hope this will be fixed when you are done certifying the Poly.

1 Like

Response from Chord:


We are aware of an issue with Poly and Roon currently. We are in constant communication with them and will be fixing this in a coming firmware update.

Kind regards

Mitch Duce

1 Like

Thank you for following up with me @Per-Oyvind_Odegard!

I appreciate you posting the response from the support team over at chord. Please let me know how the POLY performs with Roon once the firmware update goes live :microscope:


Thanks to the Roon team for looking into this. I too had choppy audio from the Poly/Mojo combo when playing simple flac files through Roon. The only time I saw this issue from the combination was when I was in the same room as my Orbi router. Up to that point Roon and Poly had been flawless. I suspect Poly’s limitation of 2.4 Ghz WiFi and Orbi trying to provide more BW is what caused it. When I attempt again I will post my results.

On a side note mobile Roon and Poly should be awesome… anxiously waiting for that release!

Just to keep this updated: I experience this same thing, too. I’m running Roon core off of a MacBook Pro 15”, connected to the router via Ethernet. When accessing the Roon remote app on my iPhone while a song is playing, the audio breaks up, then Poly disappears from my zones. Playback stops. A few seconds later, it reappears, remembers where I was in the song, and waits for me to press play again.

I noticed that in the most recent Roon update, Poly now has its own device icon—spiffy—but that it’s still listed as “unverified.”

1 Like

Remember to create a support case at so that Chord maybe solves this problem with the Poly firmware faster.

I have just contacted Chord support as I have the exact same problem, both with an Android phone and an iPad as remote.

The reply was that they couldn’t replicate the problem.

I then referred them to this thread and what Mitch Duce from Chord had said about working on the problem but I haven’t heard back from Chord yet. It will be for next week.

Hope this will be resolved…

1 Like

Had the exact same problem with an ASUS AC68U. After I replaced the ASUS with a Google WiFi Router the problem is solved and Poly/Mojo plays without any disconnects. Seems like Poly has problems with certain routers…

Well, that would be bad news as I have been using a new and expensive Asus RT-AC86U for only a few months.

But then Poly doesn’t seem to work with a Zyxel or Orbi router either. To me, that’s a Chord Poly problem.