Roon Nucleus+ Networking Problem - Unable to Reconnect to Network after Roon 2.0.20 Update


It’s been a recurring issue, the Nucleus+ Core unable to reconnect to the network after Roon updates.Sometimes it reconnected after multiple resets and reboots of the router, switches and Nucleus, kind of random, hit or miss.

It happened again this morning after the latest Roon update, still unable to reconnect. It seems there’s some bugs with Nucleus’ Ethernet hardware/software, protocol as it’s the only device consistently having network reconnecting issues in my system. Every Roon update is a nail biting process, wondering if the Nucleus+ will comeback again.

Do note that this is my second Nucleus+, the last one bricked after a Roon update & had to be replaced a couple of weeks out of warranty, $$$ software update that bricked the device, very disappointing!

Core Machine (Operating system/System info/Roon build number)
Roon Nucleus+, Serial #54B203946A54104F, 4TB SSD
Roon OS 1.0 (254), Server 2.0 (build 1223) early access

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
All devices are on the same network.
Netgear Cable Modem (Cox Gigablast up to 1Gb/s)
Peakedge SE26 24 port GigE Switch
Netgear 16 port GigE Switch
Linksys 4 port GigE Switch

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Devialet D250 PRO v.13.1
Meridian: 218 (3u), MS600, Control 15 (2u)
AppleTV 4K (2u)
Airport Express (2u)
iMac 5K

Other Devices
Meridian Core on QNAP
Crestron Pro2 Controller
Crestron CNX-PAD8 (Audio Matrix Switch)
Crestron MT-MC2W Controller

The same happened to me this morning with the same update. It happened to me once before, out for several days then just reappeared as if nothing happened. You are right, for me each update since…many have worked, has been nail biting. Today’s did not work. Dead in the water. Moved my core to my mac and put in a support ticket.

The same thing has happened to me (yesterday). I’ve tried everything but I’m having no luck. This is the first time I’ve had an issue with a release. This is really unacceptable.

1 Like

I am once again without a ROON CORE following the update that was sent out on Aug 14, 2023. What really annoys me the most is the fact that no one from Roon will kindly notify users of an issue with the latest update on Roon Nucleus and Roon Rock it seems. It should not be something out of the ordinary to recognize that something obviously did not go as plan. But regardless of what you did wrong and how it was not captured by the testing group prior to release is really a mistery to me. Now, would someone from Roonlabs be kind enough to provide an operation timeline for expected resolve.


2 posts were split to a new topic: Nucleus no longer appearing on remotes or network

I had to replace the Nucleus+ motherboard after a Roon update bricked it 16 months ago. it was 1 month out of warranty and I had to pay for it; now it happened again. I’m still unable to reconnect it to the network after multiple attempts. I wonder how much testing was done before the release. Nucleus is their own device, it’s unacceptable!

1 Like

A post was split to a new topic: Nucleus is unresponsive to remotes and network

I have the same issue - started today 15 August. I have a 6 month old Nucleus, Roon OS 1.0, Build 250. Neither Roon remote or Web interface can access Nucleus. This is supposed to be a self healing appliance!

As I previously stated, this is the second time my Nucleus+ has gone dark. I am very troubled that in both cases hooking up a monitor and keyboard displayed nothing at all. Ok, I get it, one of the beauties on Nucleus is that you just plug it in and leave it alone. But when a problem arises, it is prohibitively difficult to diagnose. You look at a box, wait for paint to dry, and pray. It seems this is widespread and I am willing to give the foks at Roon some time to respond to all of us with a fix. Have a good evening all.

Hi All,

Thanks for letting us know you’re all experiencing issues getting your Nucleus back online. As a good next step, can you please connect your Nucleus to a monitor via HDMI, and share a screenshot of what you see, if anything?

Be sure to test different cables, as well as ports on both devices.

If you haven’t yet, I would also give your Nucleus a hard reboot: power down, and completely unplug the device for a few minutes before rebooting.

Rebooting your router may be helpful as well.

We’ll be on standby for updates. :+1:

+1 on nucleus plus being non-responsive after the most recent update (wish i checked the forums before approving and a bit frustrated that roon was continuing to push the update after what seem to be a number of user issues). i’ve hard reset the nucleus and the router. the router shows no sign of the nucleus and i’m only seeing a flashing green light by the ethernet port on the nucleus with a solid orange light. Not outputting any video signal via HDMI (not sure if its supposed to, i have never used it before). i opened a separate support ticket but if you’d rather handle here i can close the other one.

As stated above, I also was unable to open or control the Roon core from my Roon remote apps. The remote app could not find any core. I tried attaching a screen. Screenshot attached. I rebooted the Nucleus several times and then ensured that both Roon remote apps were upgraded. The Remote apps and the web interface all failed to find the core before the Remote app update. However - after the update of the Remote apps (on Mac Mini & iPad), the core was identified as Nucleus, but the iPad and Mac Mini remote app still would not connect. I turned on my Lyngdorf MP-60 and magically music was playing…with no remote connected to the core. The music playing was the selection from the previous day - even though no remote app was identified as “connected” to the Lyngdorf MP-60. My guess is that this problem is related to the Roon remote software update’s failure to find the core.

1 Like

A post was split to a new topic: Roon remote Can no longer find server after latest update

A post was split to a new topic: Nucleus+ (rev B) seems stuck in an infinite reboot cycle

I’m running ROCK on a NUC and have never had an update issue in the four years I’ve had it running this way.

But this morning, clicked on the update button, as prompted by Roon remote.

Now I can see the core, but remote won’t connect to it…

So for me a complete reboot of the NUC and the whole network including router, switches and endpoints seems to have worked.

Hi Ben, I followed your instructions to the letter a few times already. Monitor to both HDMI ports, nothing. I have an amazing ip Scanner on my mac. It sees everything, including Roon Nucleus, when it is working right. Everything else on my network is there except the Nucleus which was always It has been replaced by my printer. My Roon devices are all connected still, and playing with the core moved to my mac. The scanner shows no unidentified devices that might be the Nucleus.

The only thing I might not have done long enough in previous tests was leaving the power disconnected for more than a few minutes. Tried that cleanly this morning. Power off and disconnected for 20 minutes. Power on, network lights flashing, power light lit. Nothing. Can’t connect, nothing displayed on monitor. No Nucleus on ip Scanner.

Looking forward to a fix.

One more thing. My Nucleus has always been cool to the touch. Now it is warm. Not hot, just warm…has never happened before. I think it is churning.

problem fixed. Was running Roonserver. Uninstalled all and installed Roon Core. now working fine.

A post was split to a new topic: Nucleus no longer appearing on remotes/network