Roon remote no longer works after updating Windows 10

Core Machine (Operating system/System info/Roon build number)
Lenovo i5 Windows 10. Running headless
Can’t work out how to access details of the core from Roon remote.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Bluesound vault connected by cable via the router

Description Of Issue
Roon remote no longer works after updating Windows 10. Have tried reinstalling the remote app as well as checking the video drivers which the correct ones.

When Roon remote is accessed, it briefly displays the musician quote and then disappears. Uninstall and reinstall does not help.

The video drivers are the latest manufacturer versions for each driver.

Works fine when accessed via an iPad.

Is there any change if you temporarily disable the firewall on your Windows device?

A post was split to a new topic: Remotes could not access the Roon Core after Windows update

No disabling the firewall makes no difference. Roon already had permission to be allowed through the firewall.

Hi @Frank_Rome,

Can you please try a reinstall by removing and reinstalling the Roon Remote directory?

  • Exit out of Roon/RoonServer
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon” on your Windows PC (not RoonServer)
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Let us know if this helps

I have done that and it still isn’t working. By the way, I am now receiving Dirk’s replies to his issues which he tried to add to mine.

The below is from the roon log.
Maybe this will help identify what is wrong:

08/19 15:44:34 Info: Starting Roon v1.7 (build 571) stable on windows
08/19 15:44:34 Info: [URI] Checking that FriendlyAppName == Roon
08/19 15:44:34 Info: Registering for URI scheme: Roon, roon
08/19 15:44:34 Info: URI scheme executable path remains "C:\Users\Optiplex\AppData\Local\Roon\Application\Roon.exe" "%1"
08/19 15:44:34 Debug: looking for *_old files in: C:\Users\Optiplex\AppData\Local\Roon\Application
08/19 15:44:34 Debug: looking for old numerical version dirs in: C:\Users\Optiplex\AppData\Local\Roon\Application
08/19 15:44:34 Trace: Checking if we are already running
08/19 15:44:34 Trace: Nope, we are the only one running
08/19 15:44:34 Info: Is 64 bit? True
08/19 15:44:34 Trace: [orbit] init seq=0, pending=0, spcount=7, uidcount=0
08/19 15:44:35 Trace: [broo/imagecache] loaded 0 cache entries from C:\Users\Optiplex\AppData\Local\Roon\Cache\brooimages_1\index.db, current: 512mb / 0mb
08/19 15:44:36 Info: Loading broo project: ui.broox
08/19 15:44:36 Trace: [realtime] fetching time from NTP server
08/19 15:44:36 Trace: [realtime] Got time from NTP: 19/08/2020 5:44:35 AM (3806804675427ms)
08/19 15:44:36 Trace: [realtime] Updated clock skew to -00:00:00.6102368 (-610.2368ms)

Hi @Frank_Rome,

Thanks for giving the Roon reinstall a try.

Can you please upload the full log set, from both Roon/Logs and RoonServer/Logs to Dropbox / Google Drive / ect? It seems you know how to access logs, but in case you need a guide, these instructions provide guidance.

If you don’t have Dropbox / Google Drive / ect. to perform the file transfer, just let me know and I can provide alternate means.

I actually don’t know how to access the Roon server at all.It is running headless and I am unable to see it on the network at all via my other computer that I use as a remote. When I try the Network, the only option is “computer” and I can’t get into this without a user name and password. I have no idea what this may be.

Is the only option to attach a keyboard and screen to the core computer and copy the files to a USB drive? I only have Roon on this machine so there is no email or other software on it. This machine is in a different room without access to a desk or chair, so it is a real pain to attach anything to it and work directly.
The core is still working correctly if I use an Ipad as the controller. I can’t see how to access the roon server files via the Ipad either.

Hi @Frank_Rome,

If you cannot access the RoonServer logs, that’s ok, I want to look primarily at the Roon Remote logs.

Can you open Windows Explorer (the app you use to browse folders and C: drive for example and type in %localappdata%/Roon/Logs and send a .zip of the logs there.

It looks like you might have already accessed them here once?

How Do I send the files to you? There appears to be no way of attaching files to these messages. Will you get them if I attach them to an email reply?

Also I found many files under windows: Appcrash_roon.exe

Here is a drop box link with the four Roon log files:

I hope this works!

Hi @Frank_Rome,

Thanks for sending over that log, but unfortunately it does not have any new info, it appears to end abruptly. In this case, we might need to take a look at Windows Event Viewer logs, I have provided the instructions below:

  1. Press Win + R and type eventvwr.msc
  2. Press OK – this should open Event Viewer window
  3. From the left sidebar go to Windows Logs > Application
  4. Right click on the Application subsection and pick Filter Current Log... from the context menu
  5. On the Filter tab for the Logged section pick a parameter Last 30 days and press OK
  6. Right click on the Application subsection again and pick Save filtered log file as.. from the context menu
  7. Enter the log file name, for e.g. Roon_USERNAME , and press Save
  8. Upload the Event Viewer logs to Dropbox and provide a link

Hi Noris,

Thank you. Please find below the link to to the Event Viewer logs in Dropbox:

My Issue is STILL UNRESOLVED. Now days since I sent the logs. What is happening? A response please!! As you can see, I have been unable to use windows as a remote for two and a half weeks now.

Hi @Frank_Rome,

Thanks for your patience while I have had a chance to consult with QA regarding your case.

They have reviewed logs and mentioned that these logs reference an outdated version of Roon and that we should update your Roon app manually, as there have been updates to graphics processing.

I suggest that you remove your old Roon folder and reinstall the latest build manually:

  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon” (Note: Not RoonServer - RoonServer is your database, don’t rename this)
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Connect to Core

I know you may have tried this in the past, but now build 610 was released and we should check to see if it helped with the issues.

I followed your instructions and downloaded again and reinstalled. No difference, it still quits at the same point.

How do I check if my Roon core has updated? Under setup on the Apple Ipad remote core, should I use Configure?

Hi @Frank_Rome,

In the logs you sent before I saw that RoonServer was up-to-date, but the Roon Client/UI part was out of date. Can you please send me a new log set from %localappdata%/Roon/Logs when you have a chance? I’d like to see if there was any change in behavior, thanks!

Hi Noris,

That file name is only present under Roon_old.

The folders present under Roon are shown in a Word File in the dropbox link below. I will also include the log files under Roon.



1 Like

Thanks for sending those over @Frank_Rome, I’m not seeing much new info here unfortunately, but I’ll also ask QA to review the new logs just to make sure.

A post was split to a new topic: Roon begins to start and then shuts of its own