Roon Server on QNAP QTS 4.5.1 Situation

The app has temporarily been pulled from the App Center due to a security vulnerability in my webinterface 2 days ago.
I am in communication with Qnap to fix this issue and hope it will soon be back in the App Center.

Any news please?

Hi there,
I am using a Qnap TS-4790 pro… app stopped working completely. Please provide solution soon.

Christopher has said he already provided a solution. We are waiting on QNAP to make it available.

I’ve shut down my Qnap that was running my Roon core until this is sorted out.

I’ve gone over to Bubble UPnP on my Galaxy Tab to Ropieee endpoints via dlna. It’s suprisngly stable. Just using Qobuz, which made up the majority of my listening anyway.

1 Like

Hi @crieke Christopher,
is there any forecast available?
Without the App nothing will be possible to install (Build 795) on a QNAP NAS, right?
Thanks a lot.

Wrong thread? You can download and install the app manually until it becomes available again in the app store (took QNAP months to publish an update last time).

I think it broke my install with this update. Having logon issues again with the Roon server. Found an error in the log. Dam it this is getting very old and not a very good reason for me to continue with Roon and not go back to my other good choice soolos. About to loose my patience.
06/22 18:42:55 Trace: [fiveaccountserver] POST
06/22 18:42:55 Trace: [fiveaccountserver] BODY<<>>
06/22 18:42:55 Trace: [broker/accounts] Data updated. AccountStatus=NoAccountConfigured MachineStatus=NeedsAccount UserId=
06/22 18:43:03 Info: [stats] 2245mb Virtual, 196mb Physical, 71mb Managed, 0 Handles, 31 Threads
06/22 18:43:15 Warn: Error in web request NetworkError (The request was aborted: The request was canceled.)
06/22 18:43:15 Trace: [push] request to manager failed

Roon Server
V 1.8 (build 790) stable
OPKG-VERSION 2021-02-01
ffmpg system default

My account says it is active on the Roonlabs site and the logon works fine there.

I’m on QTS NAS CPU is Intel Core i7-7700.

I tried to install git amd 64 build from Van Sickle’s website, but it still shows “system default” for my FFMPEG. I had the new folder pop-up just like in the video and I dragged and dropped the FFMPEG, hit refresh, and it says “FFMPEG version will be used now” in green, but again I’m still showing system default after I reboot Roon. Thoughts on how to fix?

Hi Shane, did you completely unpack the file. It’s this ffmpeg folder that needs to be installed:-
Capture 6

Worth checking that you’ve read this:-

1 Like

Thank you both, I did that (proper extraction with 7Zip) and it ( FFMPEG) does copy over but Roon continues to show default. I rebooted Roon.

Worth checking. Have you tried a full reboot of the NAS rather than stopping and starting Roon?

May also be worthwhile reinstalling the Roon App again if the reboot doesn’t do the trick.

I just tried a full reboot of the NAS and then re-tried using my own user-supplied ffmpeg file. Everything went like the video and I got the green circle that stated “FFMPEG version will be used now”…but it still shows system default.

I’m willing to uninstall / reinstall Roon server on my NAS, but first I need to research how to do a good backup so I don’t lose anything.

I don’t actually know if my issue is caused by the FFMPEG issue.

The issue that I am having that drove me to try to use my user supplied FFMPEG is that I experience freezing of Roon and the core has to be rebooted when playing playlists or adding / removing files from a play queue.

Is there an expert that can look at my log file and see what is going on and if this is driven by FFMPEG or something else?

Thank you very much Christopher.
I had just migrated my Roon server to QNAP, this resolved my issue. Great job!

I’m having the same problem on a Synology (DS1821+) server.

After tinkering with the respective package installation on DSM, I found out that the location that Roon expects to find user provided ffmpeg (or other codecs) is /RoonServer/RoonOnNAS/bin

I downloaded the amd64 version (both static and git) from John van Sickle’s page (John Van Sickle - FFmpeg Static Builds), I upload the ffmpeg file to that location, restart the Roon package but I still can’t get AAC radio streams to play.

Can someone please help me out?

See also guide on setting up AAC Play functionality in Roon on Qnap by adding a link pointing to Cayin ffmpeg for AMD based Qnap with firmware v5.0

Quick update: With the latest updates (I’m on Roon Server V1.8 (build 903) stable and my QNAP firmware is, the folder on Qnap to put your ffmpeg file into is now RoonServer/RoonOnNAS/bin per the QNAP app instructions. Testing now to see if it works.