Roon Server on QNAP QTS 4.5.1 Situation

Thanks for this. Okay, I got the package installed and now have the same screen as you do. But then I get this message. There is the correct ffmpeg file in the music folder for sure. I’m not quite sure why it doesn’t recognize that.

Hi Kevin,
Before checking the ffmpeg issue, I noticed your database location is set /multimedia/music. I sounds like this is your music directory. If that’s the case, I’d recommend using a dedicated folder for Roon’s database which is outside your music directory.

In regards to the “ffmpeg file not not found”, can you check: the following:

  • Please make sure you have downloaded the correct version of ffmpeg (static build for amd64)
  • Has the downloaded tar.xz been extracted correctly? (on Mac a doubleclick will extract it correctly without the need for additional tools, on Windows systems I know of Winrar which can decompress the file properly).
  • In the folder of the extracted files, you’ll need to copy “ffmpeg” inside the folder ffmpeg_For_RoonServer

Extracting ffmpeg using 7Zip

  • Download 7Zip & Install
  • Download ffmpeg as per @crieke video
  • Create a folder & name it “ffmpeg” on your Laptop/PC
  • Copy “ffmpeg-git-amd64-static.tar.xz” into folder (3)
  • Right Click File & choose “Extract Here”
  • You will see this file “ffmpeg-git-amd64-static.tar”
  • Right Click File & choose “Extract Here”
  • A Folder will be created called “ffmpeg-git-20210127-amd64-static”
  • Open folder (8) & copy the “ffmepeg” to “ffmpeg_For_RoonServer”


Hope this helps.


This worked in getting Roon to play through my Naim Muso’s Gen1 again on Airplay

Thanks dude, really appreciated


I have installed the latest version from the Appstore. Does this version create the folder ffmpeg_For_RoonServer or do I need to create this folder. I have Roon installed in its own folder but I can’t see the ffmpeg folder. My Roon folder looks like this

No the appstore one is not up to date…download from the link provided further up in the devs post.

Simon, I think @crieke has removed the link above to the modified version and the one in the QNAP store is the modified QPKG – Version: 21-02-01.

1 Like

The new QPKG will create the folder for you but you need to follow the video to allow it to be created. It’s not just a matter of installing the QPKG just follow the instructions and you should get there.

Hello Scotav

Thanks for your help with this. Yes, I have now got everything working. I only have one question though. The ffmpeg_For_RoonServer folder seems to have disappeared so I am not sure why it’s still working. It seems a little strange to me.

Hi Stephen, good to hear you got things working.

Chris has confirmed that the “ffmpeg_For_RoonServer” folder is only created to allow you to add the ffmpeg file, it’s then imported into the App and the “ffmpeg_For_RoonServer” folder is removed as it’s no longer required.

Hi Scotav

Thanks for the clarification. I wonder what will happen at the next release. Will we have to perform the same procedure again. Not a problem now we know the process.

No problem. I don’t think you’ll need to do this with any future updates but you never know :wink:

Sorry for not keeping up here - is this now solved using regular QNAP firmware etc or should we still download a version of the static one? My ffmpeg is 3.3.6 System Version. Not sure if I should be manually updating but having some real performance issues (dropping connections) again and now everything hard wired I have a lot fewer things to test…

I updated my Ffmpeg app when I finally found it… It had to be there as I kept getting reminder emails. Anyway, AAC still works perfectly.

Thank you - this was incredibly helpful and resolved my problem too!

1 Like

Good to hear Gavin, glad it helped.

It didn’t exactly work like that but with a few tweaks I got it to work

This is now Resolved.

Thanks, all, for the help!

As I said this was for a QNAP but the process is very similar for a NUC. Glad you got it sorted and see that you’ve updated it in the original thread (just for others, the post above has nothing to do with the QNAP).

Maybe I’m I wrong but I am not able to find the roon server in the qnap app store as mentioned above …