Roon Server on QNAP QTS 4.5.1 Situation

Hi everybody,
I have been working hard on a workaround for the ffmpeg issue on QNAP NAS with QTS 4.5.1 and will forward the update to QNAP.
It has an option to manually add ffmpeg to a folder in the specified database shared folder.

You’re more thanwelcome to give it a test. Feedback is really appreciated (preferably as a PM).

Link removed.

→ The Update is now available in the QNAP App Center.

You need to download a static build of ffmpeg manually (you can find good build for example on John Van Sickle’s page.
Make sure to download it for the correct cpu architecture. In case of Roon Server on QNAP, it should be amd64.

You can copy ffmpeg to a folder named “ffmpeg_For_RoonServer” in your database shared folder. The folder is created in the Roon Server web panel.

13 Likes

Hi Christopher,
Great job! I installed your new version of RoonServer with the ffmpeg you mentioned in the directory created by installation and is running 2 days flawlessly. My be a hint for more win. orientated users .xy is the extention for compressed files. I used 7zip for unzipping.
Thank you so much for your work hopefully you can adapt 1.8 soon.
Best Bernd

1 Like

can confirm this works perfectly.

A cheeky question, has Roon 1.8 been tested on Qnap ?

This is great!

  • After updating QNAP a few months after the last, Roon only worked for non-AAC files. Then after attempting to play AAC, no audio works out all. Reinstalling Roon in QNAP gets non-AAC files to work again.
  • Downgrading firmware to the version I had prior (before the 4.5.1 releases) had no effect. Roon still didn’t work.
  • I tried actually purchased the full Cayin QNAP package. It didn’t fix Roon
  • I found the ffmpeg file using WINSCP for Cayin, it’s 1kb, didn’t bother replacing the old qnap file with this
  • Using the QNAP store I installed ffmpeg. Turns out to be the same version 4.3 as the open source Van Sickle version. It didn’t replace the original file. Moving the new ffmpeg file to the original location still didn’t fix roon.
  • This is the only fix that worked. Please have this ffmpeg location option in 1.8.

Steps:

Download the new roon server pack in crieke’s response. Move it to a folder in the NAS. Use the instructions below to install it:

Download the Van Sickle codec amd64 (this works for qnaps with intel processor). Use winrar or 7zip to extract it. You’ll see the ffmpeg file.

Follow steps in crieke’s video. It will make the folder needed for you. Roon should work with AAC from there, no need for a restart.

Note:
The new ffmpeg file is around 73mb big, the one qnap 4.5.1 one is only 3mb. So far, no issues. Roon’s playing AAC with DSP on with 3% CPU utilization on the old ts-251+. Sound quality is the same as prior.

4 Likes

This won‘t work because Cayin does not create a link in the system binary directory. I could have modified RoonServer to use cayin‘s ffmpeg, but I decided against that, as I did not want to depend on their app. instead I was aiming for a longterm fix. :wink:

5 Likes

It should work. :wink:

1 Like

Hi Christopher,
thanks for your great job! :+1:
With the new ffmpeg-file ROON 1.8 works perfectly (aac-files/radio).
Installed under ROON 1.8, Qts 4.5.2, Qnap HS-453dx like shown in the vid above.
Best regard/ Liebe Grüße
Florian

2 Likes

Hi Christopher,
Roon 1.8 works on my tvs 873 perfect so far. Great job :smiley:
Thank you
Best Bernd

1 Like

Hi Christopher,

thanks again for your great work. Installation worked on my HS-453DX, although the progress bar stopped at 1%. I just closed the App Center after some time, et voilá, everything there like in your Video.
As I read the posts concerning Roon 1.8 on Qnap (this time I´m prepared before updating :face_with_raised_eyebrow:), my impression was that some users ran into the same problem (aac not playing), obviously they updated their systems for the first time in a long time and now took it as an 1.8 bug.

LG Heiko

Having the same issue and keen to hear if there is any fix planned either by Qnap or Roon. Music Station is able to play these type of files. Thanks

1 Like

Dear Crieke,

Due to firmware update I had the opportunity to install your package with ffmpeg build from the John Sickle’s page. It works perfectly :smiley:

Thnx

2 Likes

Thank you for this! After a reboot I finally got this working again-- what a nightmare!

1 Like

I am attempting this. Why does my Roon Server Overview not show the FFmpeg selection? I created a (ffmpeg_For_RoonServer) folder in my shared music database that Roon utilizes on my NAS. I then downloaded the appropriate static build from John’s page and placed it in the folder but nothing has changed. I’ve stopped and re-started the Roon Server, but nothing. I am totally lost.

Are you using the linked qpkg version (2021-02-01) linked in my post above?

Earlier versions, do not offer the options and it seems, QNAP did not publish this update yet in their App Center (will contact them, in the coming week for a status update).

Make sure you are only copying the file named ffmpeg across and not the whole static build folder.

HTH

Yes, I did.

could you post a screenshot of your QNAP RoonServer web panel? I am confident we can get this fixed.

Sure. Thanks.

Hi Kevin,

You are not running the latest build by Crieke. Should look like this:

Please download and install the latest QPKG file, see above : Roon Server on QNAP QTS 4.5.1 Situation - #21 by crieke . And then set /copy ffmpeg.

1 Like

Thanks @Kevin_Gordon ,
as Pascal_Simons already pointed out, You need to install the new qpkg version, which is not yet available in the App Store and therefore must currently be installed manually.
To do that, download the qpkg file from the link in my post and click the “Install Manually” button in the QNAP App Center.

This graphic illustrates the process of a manual installation briefly:

1 Like