Roon stops playing music

Core Machine (Operating system/System info/Roon build number)

Mac Mini (Late 2012)
Intel Core i5 2.5GHz, 4Gb RAM
MacOS Mojave 10.14.4
Roon: 1.6 Build 401 (64-bit)
All music files are stored locally on Core machine (480 Gb SSD)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Apple AirPort Extreme router (the ‘flat one’, non ac version)
2 Airport Express units to extend wifi connection
100/10 internet connection
Mac Mini connected to router via WiFi (on 5Ghz band)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Roon setup to CoreAudio in Exclusive Mode

  • Meridian AC200 (to DSP3200) connected to Core directly via Toslink.
  • 2 x Sonos Play 3 connected on Wifi
  • 1 x Sonos Play 1 connected on Wifi
  • 1 x iPhone X connected on Wifi

Description Of Issue

Error description is valid independent of end point used (so it does not matter if I play on the Meridian system directly connected to the core or if I play to any of the Sonos end points).
I only play files that are stored on my Core machine (do not use Tidal or Qobuz)

I start playing music, any file, any sample rate(flac/alac, 44.1/16 or 96/24) and after a while Roon just stops the music. When this happens I can press play again and the music will continue.
My feeling is that this happens more often now since I updated the Core machine to MacOS Mojave (was El Capitan before)

There is no difference if I start the music from the Core or from any of my remotes (MacBook Pro/iPhone X)

It does not feel like it has anything to do with my network setup since the issue exist when I play directly from core to my Meridian system (connected with toslink).

Hi @Andreas_Andersson,

Has this setup worked for you previously or have you always received errors when playing content?

If you play directly to System Output of the Core machine do you receive the same errors?

Hi @dylan,

I tried with System Output, issue still exist.

My feeling is that this problem started to occur more frequently when I updated Roon to 1.6. But then I also upgraded my Core by replacing the HD to an SSD and upgrading the OS from El Capitan to Mojave (made all those upgrades within a couple of days…)

Hi @Andreas_Andersson,

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more by playing local content to System Output of the Core machine. When you do so, please make a note of what time the errors occurs as well as what content you are playing. Then respond here with that time, your timezone, and the content you were playing. Once I have this information I’ll make sure we review the diagnostics related to that timestamp.

Here’s the information you were asking for.

Soon once again stopped playing music at 20.06 (GMT+1, Sweden)
I was playing the song Ten Storey Love Song from the album Second Coming (artist Stone Roses)

And I was using System Output during the test.

Hi @Andreas_Andersson,

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

@dylan perfect!

Can I switch back to Exclusive Mode or do you prefer that I keep using System Output until you have gathered more data?

Hi @Andreas_Andersson,

I wanted to update you and let you know that the diagnostics report was received and has been passed over to the team. I’ll be sure to update you ASAP when I receive their feedback. In the meantime, feel free to use other playback sources besides System Output, everything needed by the team should be in the diagnostics report.

I was also hoping that you could share a screenshot of Settings > Storage so I can pass it along to the team too.


Ok, here’s a screenshot of Settings-Storage

Hi @Andreas_Andersson,

I spoke with the team about this and we were hoping you could perform a test that should give us some additional information here.

If you completely disconnect your Core machine from the network (no WiFi or Ethernet connections) and play local content to System Output does the same behavior occur?

Hi @dylan,
I have now tried to play without any connection to the network and it seems like the problem is still there.

Thanks for giving that a try here, @Andreas_Andersson!

Since the network connection doesn’t appear to be playing into things, it appears that this behavior is stemming from the Core machine.

Are you running any other applications or anything at the time that you’re playing Roon? Can you confirm what resource usage is looking like when this occurs?

If you have another device handy, can you try running Roon on a different Core machine in this same configuration? Does the same behavior occur?

Hi @dylan ,
I am usually running this machine headless (once in a while I connect it to a TV) controlling it from my laptop. But it is ONLY used for Roon, no other programs are running (except for those programs/processes that are up and running for the OS). Spotlight may be active from time to time (indexing) but that should only happen right after I have moved a newly ripped CD from my laptop to the Roon Core machine.

Regarding resources:
I do not see anything strange or odd here. Roon takes about 15-30% CPU all the time, until the music stops, then the CPU load drops down to 5% (which is expected I think…). Do not see any other process that is peaking at this time.

I tried to restart Roon on the Core (it felt like the issue I have appeared more frequently). It has not reappeared since the Roon restart, but I know that a Roon restart or computer reboot does not solve the issue since I have tried this before, it does however seem to make it happen less often…
Could there be a problem with Roon when it has been up and running for too long?

I have not yet tried activating my laptop as a core. Will try that.

I have now tried to play from another Core and did not have any issues at all. I used the same setup (optical from computer to Meridian AC200)

When playing with my original setup I can see that Roon briefly shows “no output zones found” (or something similar) when the music stops.

Any ideas?

Hi @Andreas_Andersson,

Thanks for giving that test a go. Since things seem to work without issue on a different Core machine, it confirms that the behavior you’re seeing is stemming from a performance issue on the Core.

There are a few things that can play into this type of performance issue. The size of your library, the specs of the machine, what other work the machine is doing, how much you’re doing in Roon, etc.

2 posts were merged into an existing topic: Issues with Remote Connectivity on Linux Cores in 416?

@dylan @c2c2c2
I just performed a quick search now in the forum and I see more posts about Roon pausing/stopping the music with “lost zones”

Why does roon pause itself?

And this one…

Is my core really underspec?
As a reference I used an old MacBook Pro (Core 2 Duo) when I performed the test on another core (but with just a few albums in the library) and it worked just fine

Hi @Andreas_Andersson,

As mentioned above, there are several factors that can play into this.

When you tested the other Core, did you import your entire library?

Were you running the same programs that the other Core is running?

This test helped to rule out networking issues and pinpoint the behavior to performance on the Core machine, but there are still other factors that could play into this.

  • How many tracks total are in your Roon library?
  • What other programs are running on the Core machine?

Hi @dylan
Haven’t been able to listen to music for a couple of days, hence the late response.

No, when I tested with another core I had to just choose to add a couple of albums to my library (local on the HDD on the new core). This new core is an old MacBook Pro Core 2 duo. Worked just fine for the testing I did, without any “stops” and it never lost the output zone.

I am now back to my original core again and it is becoming unbearable. Right now I have been listening for about 20 minutes and it has stopped several times…

No other programs are running on my core, except for what is automatically started by the os (macOS Mojave). I only use this machine for Roon (ok, I log in remotely with screen sharing some time when I want to transfer new music to the machine)

Do you have anything else for me to go on? Any diagnostic files I can look at myself?

Hi @Andreas_Andersson,

Can you confirm how many tracks total are in your library? You can find this by navigating to the Overview section of Roon.

The team also previously saw that there appeared to be some dropouts to what appears to be a built in soundcard when they reviewed the diagnostics report. Can you confirm what zone you see this the most with? If you’re using an internal sound card, can you confirm it’s running the latest firmware