Roon stuck on "Scanning now"

Core Machine (Operating system/System info/Roon build number)

Ubuntu 20.04.1 LTS
Intel NUC8I5BEK
Roon Version 1.7 (build 667) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Asus RT-AC68U router
Core and client are connected through Wi-Fi
Music library on NAS, connected to router by ethernet cable

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Schiit Modi USB connected to Linux Mint PC (running Roon client through Wine)

Description Of Issue

Roon client constantly shows the rotating circle on the top right corner, indicating a library scan. I can still play and browse my music as usual, the scan is just stuck. I’m not sure if it’s actually accessing the HDDs in the NAS all the time, but if it is then that would be somewhat undesirable.
I’m quite certain this behavior started today, but I can’t say if it coincided with the latest Roon update which also came today. I haven’t added any new music files today, but I did do some library cleanup (fixing albums/songs credited to wrong artists etc.).

I found several other tickets for this issue, however none of them contained hints on how I could solve this problem on my own.

I have tried restarting Roon Core and the client, no luck there.

roon_ticket

I have the same issue from the last update…

I came here to report this as well. It just started with 1.7 build 667. Restarting Roon or the host it’s on (an Ubuntu 20.04.1 host) doesn’t resolve it. Prior to this, I was on build 610, and didn’t see this behavior there.

Hello @Olli_Schroderus, and thanks for your report!

Could you please connect your core via Ethernet to the router just like your NAS and reboot then see if this scan gets stuck again?

That will be a bit tricky with my current setup. However I can’t really see how the physical connection type could have an effect here, the Wi-Fi link connection is very good and as mentioned I am able to play and browse/edit my collection without any issues.

Just wanted to chime in and say “me too”. My hardwired system had been running great for a couple of years. It’s a NUC running Ubuntu Server & Roon Server with an internal SSD. Connected to the router is another remote Ubuntu server that has a large HDD storing additional music.

After the last upgrade, the local SSD on the NUC is fine but the remote HDD on the other server has been stuck in a “Connected Scanning now…” state for the last 3 days. Patching & rebooting everything didn’t fix it. Every part of the system has been powered up/down. Everything seems to work well. It’s just a bit annoying to have that distracting spinning icon going around & around all the time.

Because the remote drive only has music added to it at sporadic intervals, I had it set to rescan only on startup. Whenever I add new music to it, I just manually “Force Rescan” to show the new albums. This option is now grayed out as the drive is in constant scanning mode 24x7. One interesting note is that I disabled the remote storage & then reenabled it to see if that would have any affect. When reconnecting it displayed a message that it was “Watching for new files in real time” before replacing it with the never ending scan message. I don’t know if this actually indicates anything, but I had specifically done whatever I could from the Roon interface to try to make sure Roon only scanned this drive for new files when I manually told it to.

I am having same issue. I am using Roon Server on Linux. Since 667, server is continuously scanning. I checked in logs and I see lots of
Warn: [storage] [directory] Cannot iterate dir: ‘/media/multimedia/Music/iTunes/iTunes Music/Music/DXXXXXXX’, ex: System.IO.IOException: Interrupted system call

I reverted back to 610 and everything was working with no errors. Did fresh install of 667 and errors came back

Same for me…
Rebooted, restarted, nothing stops the “scanning now…”

@nuwriy

Ever since Build 667 was released recently, there have been multiple reports of people having their Roon client showing a constantly rotating scanning icon. Trying to relocate this thread to post this update, I noticed there were about five threads devoted to this topic. Support technicians were responding to them but no resolution has appeared yet. The additional information I’m going to provide may not be of any use to other users, but I thought I would share it in case it gave some insight to the Roon techs or anyone searching these forums who might benefit from my solution.

I have a two Ubuntu 20.04 servers. My primary box is a NUC that runs Roon Server with a local SSD. The secondary box runs Samba and has a large 4TB HDD on it to store extra music. I rip my music on a Windows PC then move it to the appropriate folder on one of the Ubuntu boxes in order to listen to it.

In the screenshot below, you can see the local SSD is the first line (/dev/sda1). The next two lines are remote mounts to the other Ubuntu server that were created by the Roon interface when I used the Settings->Storage-Add Folder and Settings->Backup->Scheduled Backups->View-Add buttons. Roon created both of these links as CIFS shares.

These remote mounts were in place before my servers were upgraded to Build 667 and everything worked fine. I only scanned the remote HDD at startup and then manually whenever a new album was added to it. The local SSD was scanned in real time. After the upgrade, the local SSD was fine but the remote HDD was stuck in constant scanning mode.

One big problem with this is that while it indicated that it was scanning, it really wasn’t. If I added a new album to the remote HDD, it never appeared in my Roon client. I had to disable the remote drive from the Storage settings then reenable it to get the drive to rescan from zero until it got stuck again at the final track where it sat spinning forever.

I tried cold rebooting my entire system, I patched it, I disabled & reenabled, I read logs files & searched the forums to no avail. Finally this morning, I permanently deleted the remote mount from the Roon Storage settings. Then I logged into my secondary remote Ubuntu server, loaded NFS server and set my music storage folder for sharing in the /etc/exports file. Then on my primary Ubuntu server, I loaded the NFS common files and set the remote music folder to automatically mount locally in the /etc/fstabs file via NFS instead of CIFS. From the Roon interface, I added the newly created NFS mount (which now appears as a local folder instead of the remotely mounted one it actually is).

After rebooting, the remote folder was scanned one time, the spinning scanning icon disappeared and everything is working great. Because of my unique setup, this might be totally useless to many of the people experiencing this problem. But to me there was obviously something problematic with the original protocol and the way the remote drive mount was created. I hope this helps someone.

3 Likes

Thanks for the detective work, I have my NAS mounted as a CIFS/SMB share as well so maybe that’s the root of this issue. I never mounted it through Roon though, it’s done in an /etc/fstab entry and then added in Roon as a local folder. So as far as I understand, Roon shouldn’t even know it’s a network mount (but I’m hardly an expert on this topic).

@Olli_Schroderus, If your remote drive is already manually mounted via CIFS, then this potentially points to the CIFS protocol as the potential culprit. I’m not sure if this will be solved by changing a configuration parameter or if a completely different protocol is the better solution. Like most users, I rely on these foundational pieces of software to “just work” and I really don’t have a lot of insight into the nuances of fine tuning them. As someone who has spent a lot of time debugging stuff, sometimes knowing what does and does not work is useful information to arriving at an optimal solution. My particular workaround would be difficult to impossible for some users depending on their hardware configuration & skill level. Not everyone is a computer geek.

Mine’s also loading stuff over SMB. I didn’t use the SMB functionality in Roon for it, though. Just one that gets mounted in fstab since I use it for other things as well.

I might try switching over to NFS, though, if there’s a way to do that without destroying the metadata I’ve entered into Roon for things like favorites and which albums should use the data in their files rather than from Roon’s metadata services.

1 Like

@Chris_Gelatt, When I switched protocols, no other settings (e.g. playlists, favorites, album covers, artist photos, etc.) that I had manually tweaked were lost. Since that info is kept in the centralized database, when the drive is rescanned, it doesn’t wipe out any previous references to an album and treat it as a new album. It was easy to verify this by looking at albums that were recorded by some friends that weren’t commercially available and had to be entered manually. All the manual edits were still in place.

I’m having the same issue. I had a prior version of Roon Core installed as an unraid docker and elected to install it under an Ubuntu VM (ver 20.04.1), restored my backup from the docker and Roon is now seemingly stuck on “scanning now…” (ver 1.7 (build 667)). I’ve mounted my music via SMB too. It appears all of my music is available for playback via my Roon end points though. Profiles, playlists, favorites, and play history are restored as well.

Just an update - Roon is still importing tracks (screenshot below). I also noticed at one point last night it imported all the tracks, but then lost my share paths (the paths turned red and were flagged as not available under settings | storage) so I removed and added them back again. Do I need to move off of CIFS/SMB and try NFS instead? The Ubuntu VM running Roon Core physically resides in the same server that houses my music share so all this networking is seemingly a software abstraction layer. Ties my brain into knots at times. :slight_smile: :crazy_face:

NFS worked for me, no issues since then.

Update: Thanks to @Darryl_Caillouet suggestion. I switched to NFS4 from CIFS and issue went away.
I agree with Darryl’s statement - I rely on these foundational pieces of software to “just work”

1 Like

Looks like that was the case for me, too. I switched over to NFS, and all my info seems to still be there afterwards. And, no more permanent scanning in Roon.

I’m on the same boat with my Nuc, but I’m not able to mess around with terminal commands… do you believe that they (Roon tech guys) are working on a solution?

Ten days of silence from Roon support… this is not good.
Not everyone is supposed to be a Linux techie.

2 Likes