Roon + TIDAL frequent errors preventing streaming

Hi, @support
This weekend I tried 6 different configurations for Roon:

  1. NUC + ROCK
  2. NUC + Linux Mint + Roon Server
  3. NUC + Ubuntu Server + Roon Server
  4. Fujitsu Laptop + Linux Mint + Roon Server
  5. Fujitsu Laptop + Window 10 Pro + Roon App
  6. Fujitsu Laptop + Window 10 Pro + Roon Server

What can I say, Windows is the less problematic system in my case.
Didn’t notice any skips, only a few slow loading tracks. But I don’t like Windows. And I don’t want to buy extra license for it to install on NUC, because I’m not sure that this will fix all issues.
ROCK is the worst, surprisingly and unfortunately.
Now I’m on Laptop + Linux Mint + Roon Server, but I made some tricks.

I read that it could be specific global (national) firewall issues.
Some Amazon IPs are blocked.
Some users can fix it by adding their own firewall rules and block these IPs locally on the router with “reject” parameter, not “drop”
So Roon can immediately switch to another.
But these IPs change from time to time.

So, what I did: I manually add one firewall rule to iptables on Linux Mint:
sudo iptables-legacy -A OUTPUT -p tcp -d 13.32.123.24 -j REJECT
+
sudo iptables-legacy-save
to save the rule

This is the exact problem IP address for now.
6 month ago that address was 65.9.57.52
(Maybe I should add this address to that reject rule too. Unsure)

I left Roon to play 24 hours playlist in the background and this evening I will check if there will be any skips. (8 hours it’s ok so far)
If it work, I will move to NUC + Linux Mint + Roon Server + this firewall rule.
This is not elegant and not universal solution, but it works so far. Until another IP will be blocked.

Anyway, it doesn’t explain why Qobuz in Roon and Tidal itself work fine.
I think the issue must be solved somehow inside Roon.
And I hope that my sitiation will help Roon to fix that uncertain issues with Tidal or ROCK or Linux Roon Server.

Don’t want to mark this post as a solution.

BTW, Roon Remote on Android sees multiple Cores:

And these cores multiply and multiply.

Roon Remote on iPad sees one core at the same time:

Where are you from, Serge?

Vladislav, I’m from Russia. Read it here :wink:

кажется, ЗАРАБОТАЛО! не спугнуть бы

1 Like

Windows or Linux?
If Linux, don’t forget to
sudo iptables-legacy-save
it will save the rule to work after reboot

add new Firewall Rule in my Mikrotik Router
chain - Forward
Dst address 13.32.123.24
Protocol TCP
Action Reject

1 Like

It looks like I have to buy a new Router :man_facepalming:
Mikrotiks are more flexible.

Hi, @support

My second setup:
Roon Core - Intel NUC 8i5BEH2 (16Gb RAM, 512Gb M.2 SSD) - ROCK Version 1.0 (build 227) stable, Roon Server Version 1.8 (build 814) stable
Roon endpoint - KEF LS50 Wireless
Network Router - ASUS RT-N65U
Core connected directly to router via ethernet cable
KEFs - via WiFi
DNS - 8.8.8.8

The same issues as I already described here and here right in time when I’m posting this

I can see in router log that ROCK and Roon Remote can’t acces a dozen of IPs with “TIME_WAIT” state
These IPs are:

13.32.123.23
13.32.123.95
13.32.123.6
13.32.123.2
35.231.208.158

and they were not blocked by national firewall unlike 13.32.123.24

I hope this will help to resolve many issues like this
and this
and this
and this
and many others

Hello @Serge_Tse ,

Thanks for the additional details here! Let me discuss your findings with the QA team. Can you please confirm - if you by any chance have a VPN or mobile hotspot, does the same issue occur? Or does the issue only occur on your home network?

No, I don’t have any VPN. As I said earlier when I block (reject) 13.32.123.24 address Roon starts to function more or less stable.
But I can do it only if I’m on my main setup. Now I use Microtik router instead of TP-Link and it makes possible to add that specific firewall rule:

On ASUS router (second setup) I can’t do it.

If it will be helpful, here are ping and traceroute results from ASUS:

PING 35.231.208.158 (35.231.208.158): 56 data bytes
64 bytes from 35.231.208.158: seq=0 ttl=107 time=139.543 ms
64 bytes from 35.231.208.158: seq=1 ttl=108 time=138.375 ms
64 bytes from 35.231.208.158: seq=2 ttl=107 time=138.365 ms
64 bytes from 35.231.208.158: seq=3 ttl=107 time=138.378 ms
64 bytes from 35.231.208.158: seq=4 ttl=107 time=138.789 ms

--- 35.231.208.158 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 138.365/138.690/139.543 ms
traceroute to 35.231.208.158 (35.231.208.158), 30 hops max, 38 byte packets
 1  95.67.224.1 (95.67.224.1)  4.870 ms  5.252 ms  5.820 ms
 2  213.59.233.194 (213.59.233.194)  4.165 ms  3.618 ms  10.063 ms
 3  87.226.181.89 (87.226.181.89)  18.072 ms  87.226.183.89 (87.226.183.89)  16.992 ms  17.208 ms
 4  5.143.253.245 (5.143.253.245)  16.775 ms  5.143.253.105 (5.143.253.105)  16.827 ms  5.143.253.245 (5.143.253.245)  17.558 ms
 5  108.170.250.130 (108.170.250.130)  62.226 ms  108.170.250.51 (108.170.250.51)  16.927 ms  108.170.250.113 (108.170.250.113)  17.242 ms
 6  142.250.238.12 (142.250.238.12)  34.494 ms  34.378 ms  142.251.51.218 (142.251.51.218)  35.351 ms
 7  142.251.51.217 (142.251.51.217)  49.799 ms  142.251.51.215 (142.251.51.215)  48.963 ms  209.85.248.7 (209.85.248.7)  48.314 ms
 8  *  142.251.71.163 (142.251.71.163)  129.559 ms  134.152 ms
 9  209.85.254.106 (209.85.254.106)  139.408 ms  142.250.209.130 (142.250.209.130)  138.892 ms  216.239.47.82 (216.239.47.82)  139.593 ms
10  209.85.253.71 (209.85.253.71)  139.389 ms  216.239.46.64 (216.239.46.64)  151.552 ms  138.091 ms
11  142.250.60.97 (142.250.60.97)  139.203 ms  172.253.76.155 (172.253.76.155)  139.525 ms  216.239.50.29 (216.239.50.29)  138.906 ms
12  *  *  *
13  *  *  *
14  *  *  *
15  *  *  *
16  *  *  *
17  *  *  *
18  *  *  *
19  *  *  *
20  *  *  *
21  *  158.208.231.35.bc.googleusercontent.com (35.231.208.158)  138.015 ms  138.465 ms
1 Like

Hello @Serge_Tse ,

Thank you for those additional details, I spoke to the QA team and we are looking into your report. Can you please confirm my previously asked question? If you try to use a mobile Hotspot, do you still see the issue occur when connecting that way? Or does the issue only occur on your current ISP network? Thanks!

Hi Noris,

Still have no idea how can I check this.
I can’t connect ROCK to Wi-Fi
Unfortunately, in two different locations I have the same ISP.
But I will think about it.

1 Like

If it will be helpful to anyone else, here are additional IPs to reject:

13.33.240.14
13.33.240.21
2 Likes

Спасибо за апдейт, только начал использовать и столкнулся :frowning: А как найти эти ip?

*Ну и лапти, конечно, такую проблему не починят никак

I found information on the Internet, but in general, you need to analyze the logs of the router.
These are specific for russian Internet segment. Maybe there are others.

Hi @Serge_Tse ,

Did you get a chance to test ROCK on a different ISP?

You are saying since you blocked these IPs, you have had a stable experience in Roon?

No, I didn’t :frowning:

More or less :slightly_smiling_face:

Not block, but reject :point_up: That’s important

1 Like

I had similar issues connecting to Tidal. Rebooting my ROCK core solved it.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.