Roon + TIDAL Issues

I have the same issue, Tidal is completely screwed after this latest update.

Deleting Cache fixed it, maybe this should be in the upgrade script Roon staff write…

Hi @Snook,

Thanks for the feedback here and for letting me know that deleting the cache resolved the issue on your end as well. Deleting the TIDAL cache should not be necessary in normal circumstances but after the latest TIDAL security changes, we have seen that it helps some users with issues.

We are of course still investigating any improvements we can make to TIDAL syncing following this latest security change and your reports on our forum are helpful for showing the devs the common TIDAL issues that users face after this change, so do let us know if you have any further issues.

I had to re-enter info as well several times recently. Will look into the cache clear if it happens again.

I came here to report its all broken again today… This is rediculous and frustrating as all hell. I feel like I have not even been able to use roon recently and keep having to use tidal app itself… why am I paying for ROON??? Please help…

Did the most recent sign in attempt from Roon trigger your web browser to open to complete the links? At least that is how it works on MacOS now. Depending on what you have open or your browser settings you could miss it.

Done it many times, it works for a day then breaks again. It needs an urgent patch, makes roon unuseable with Tidal currently.

Hi @Snook,

What are your exact symptoms? Could you share some more information regarding you setup and screenshots of the issue by using this link as a guide?

Hi There, it just sits spinning on here in the tidal section. The only way to fix was to delete cache. Synology NAS. But then it come straight back again later.

Hi @Snook,

Can you please use these instructions to grab a copy of your Roon logs the next time Roon is in this state? I would like to take a look at the logs to see if they have further clues. The best way to get them over to me would be via a shared Dropbox / Google Drive link. Thanks!

Sent to you in PM just now

1 Like

Hi @Snook,

Thanks for sending the logs over. I’m noticing a few Name Resolution Failures in your logs, which may be related to this issue. We have seen users have a better experience in the past if they change their Router’s DNS servers from the ISP provided ones to Cloudflare DNS, Quad9 or Google DNS. Can you please give this a try and let me know if it helps?

Funny you say that, I already use and (Cloudflare) and always have on my DHCP scope for my PC and also on the NAS hardcoded. I never use ISP DNS.

I opened Tidal again today (have not bothered for a few days) and still just get a spinning icon on the tidal section and in the accounts section.

What next? Clearing the cache every time isn’t exactly a solution! Thanks for looking at the logs.

Hi @Snook,

Thanks for clarifying. I noticed a few Name Resolution Errors, so it might have just been an intermittent networking request fail.

Let me get QA’s take on the logs since I am seeing one trace here which they might be able to provide more context for. I just requested they look over the logs and once that’s done I will reach out once more with their analysis.

Hi @Snook,

I spoke to the QA team regarding this issue and the reason why this appears to work for a day or two is because the TIDAL login token automatically refreshes every 24 hour and once that occurs, this issue seems to pop up. We have a few further questions to clarify this issue:

  1. You mentioned you had to clear the TIDAL cache to temporarily resolve this issue, but can you let us know if logging out/back in to TIDAL also resolves this issue? Or does it have to be the cache clear?

  2. Do you have another PC which you could temporarily try using as the Roon Core? It would be very interesting to know if the same behavior occurs on a different PC when it’s a Roon Core or if the issue is limited to your NAS Core. To switch Cores in Roon:

  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings -> General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like.
  • Verify if the same behavior occurs on the different PC

Hi Noris,

So I can confirm that I do not have to delete the cache, although this likely forced a re-sign in.

The issue is fixed by signing out and back in again to Tidal each time. But obviously this is not a ‘solution’ as this happens every day.

Am I safe to assume there is a current bug/issue with Tidal and authentication tokens not renewing automatically?

This must be a common issue currently.

Hi @Snook,

Thanks for confirming that logging out and back in also temporarily resolves this issue.

No, I would not say that this is a bug yet since this doesn’t occur on any of Roon staff member’s Cores. What is possible here is that something environmental on your end is triggering this behavior to occur, but what exactly is triggering it is hard to say. Let’s proceed with the other test I mentioned to clarify if this issue affects just the NAS Core or all Cores on this network:

Hi @Snook,

I’ve been discussing this issue with the technical team and in addition to trying the other Core there is one test that we could try performing first:

  1. Log out of TIDAL in Roon
  2. Perform a full reboot of the Core
  3. Try logging back into TIDAL and verify if the same behavior occurs

Can you give this a try and let me know if it changes anything? Thanks!

2 posts were split to a new topic: Roon - "Your OAuth2 client configuration is not correct. Please check with TIDAL Partner Support”

Tried this, worked fine for 3-4 days then its screwed up again, same issue.

Want the fresh logs now after a reboot?