Roon won't play files again

I’m having the same problem again. This time changing firewall settings doesn’t help. Also, Roon keeps scanning my library over and over again for some reason.

Can you give us the details of your setup @David_Olegar?

Same as it was before:

Roon has stopped playing files. I can access the file, and hit play, but the file doesn’t start. The right bitrate shows up on my QB 9, but the file doesn’t play. After about 20 seconds, it skips to the next file in the queue, where the same thing happens.

This spontaneously resolved once, but nothing I have done, including rebooting the NUC where Roon core is hosted, helps now.
My NUC runs Win 10, my streamers are a sMs 200 and a 2011 Mac Air, files are stored on a Synology NAS. Everything is controlled by iOS devices or core.

The clock is ticking on my subscription, and this software is useless. I have emailed you about this and you have not responded

Please help.

Hi @David_Olegar ---- Thank you for touching base and providing the details of your setup as asked in Mike’s previous post, very appreciated!

Moving forward, the last time we had discussed this behavior (in the thread mentioned above) the issue was resolved by making adjustments to your firewall settings. Just to confirm, are those adjustments still in place and furthermore in regard to the Windows Defender, have you verified that Roon and RAATServer are not being blocked?

Additionally, may I also kindly ask you to verify the following information for me:

  • Is this issue being experienced will all of your endpoints OR just with the QB-9. My assumption is that the SMS-200 is feeding the QB-9, please confirm.

  • Have you tested the playback via the Mac Air with both the QB-9 attached and via the internal speakers on the device? If so, what was the experience like?

  • If you play directly out of the NUC via the headphone jack or with the QB-9 mounted directly to it, what is the experience like?

  • Have you tried putting some media on an external storage device and mounting it directly to the NUC to see how playback performs with the NAS temporarily removed from the equation?

  • Please verify the model of Synology NAS you are implementing and the size of the library (based on number of tracks) being housed on the unit?



Thanks for getting back to me.

  1. The issue is being experienced with every source and endpoint. the sMS-200 goes into the QB-9. The Mac Air goes to a Cambridge SM 6. An Oppo UDP-205 is it’s own streamer and endpoint. I operate all 3 zones simultaneously.

  2. Regardless of how I try to play files, the same thing happens. Tracks are recognized and load, but never play. After a few seconds, Roon moves to the next track loaded, where the same thing happens. This includes trying to play files on the NUC.

  3. See 2.

  4. I haven’t tried playing files from any source but the Synology. It is the only place large enough to store all my files.

5 It is a Synology DS 412+. Roon lists 71,682 tracks

My firewall settings did not change. All Roon and Roon bridge applications have full access to all public and private networks. Turning the firewall off does not change anything. I find no Windows Defender settings that are program-specific irrespective of firewall.

Again, Roon was playing just fine and abruptly stopped playing the files it is still accessing, without my changing a single setting in Roon or Windows. This has now been going on for several days.


Hi @David_Olegar ----- Thank you for touching base with me and taking the time to answer my questions. The feedback is appreciated!

A few things moving forward…

Further Data Gathering:

  • I have went ahead and enabled diagnostics on your account so we can try to get a sense as to why you are experiencing this behavior during playback. What this action will do is the next time the application is active on your core machine a diagnostics report containing a set of your Roon logs will automatically be generated/uploaded to our servers. I will let you know when it has been received.

  • Can you verify for me if you have taken any Win10 updates since we last spoke about this issue in November? If you are unsure you can confirm this by going to “settings” - > “update and security” - > “view installed update history”.

  • Just to re-confirm. I know you have mentioned this, but I want to be 100% certain. Firewalls settings have been adjusted for both your “Private” and “Public” networks, correct? If an automated update has occurred I have seen settings get adjusted in the past and I want to make sure that is not the case here.

Troubleshooting Exercise:

  • I understand that you are making use of a 2011 Mac Air which is currently acting as RoonBridge feeding into the SM 6. Can you please try hosting your Roon core on this device (temporarily) and confirm if playback is stable with the core on this machine.

    • very important - before performing the above test please make sure to make a back up of your current DB.



Thanks for your reply. This application is wonderful when it works, but this is becoming increasingly infrequent.

Roon is always running on a NUC that is dedicated to it.

Win 10 is fully updated on the NUC and the firewall has been configured so that “roon.exe” and "roonbrigehelper.exe are allowed on both “Public” and “Private” networks.

I am unclear on how to transfer Roon core to a different computer. It sounds cumbersome and time-consuming. I also am not sure what a “DB” is or how to back it up. I have already spent a great deal of time and effort in a futile effort to get this application to work. It was my understanding that Roon was supposed to work on a NUC. I bought and built the NUC for the express purpose of running Roon. I hope I haven’t wasted my time and money on it.

If there is no other solution to my problem, I will take these steps. I will need to know how to do them.



Ok, it turns out when I brought the Mac Air out of sleep mode (I hadn’t used it for a while), files started playing again in Roon. Why should this be the problem? The core is on the NUC, and the Mac just has Roon Bridge.

So thanks for your assistance. I’m not sure this has solved my issues, but it’s working now.


Hi @David_Olegar ----- Thank you for the follow up and the update. The feedback is appreciated.

In order for the core machine (i.e the NUC) to stay in communication with the RoonBridge (i.e the MacAir), the RoonBridge must be “active” and not hibernating. In my home use I run RoonBridge on an older MacBook-Pro and in the “energy saver” settings I have the sliders set to “never” under the “power adapter” tab with “wake for network access” box checked.

Try to think of this behavior the same way a Roon remote works. If a remote is to stay in communication with the Core, the core must be active, if it is not the remote will not connect. Same principal here.


“I also am not sure what a “DB” is or how to back it up”

FYI: DB stands for “database”.