Roon won't play my Bose usb speakers

Core Machine (Operating system/System info/Roon build number)

Windows 10 64 bit

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Bose USB speakers

Description Of Issue

I am having a technical issue with my Roon. I’m not getting any sound. When my paid account became active yesterday it installed an obviously newer version than what I had during my 3 month trial. Roon has found all my music files for the core but when I try to play an album the songs quickly flash by but there is no sound. I also linked my Tidal account and the same thing happens with it. I have Bose USB speakers and they work. If I play a song through Itunes or Windows Media Player it plays perfectly. If I go to Tidal directly it plays perfectly. I have gone into my Audio Settings on Roon it shows the Bose USB speakers are enabled but something is obviously wrong.

Please advise,


Only if you allow automatic updates. I don’t, but I think that’s the default.

Some screen shots might help -

Settings==>About, to check out the Roon version, etc.
Settings==>Audio, perhaps your speakers are sitting there waiting to be Enabled?

Also, as to trouble shooting, did you see this thread?

Yes the device is enabled in Roon. It is also the selected device to play. Here are some screen shots

Add images

Hello @John_Dickerson,

Thank you for those screenshots!

Can you please confirm, are just the Bose speakers impacted in this case? It looks like you also have a Sonos zone, is that working properly?

I would also advise a reboot of your Core and to try to re-plug the USB cable in to the Core.

There are 2 options. One is to logout and one is to disconnect. Which one do I need to do. Also, should I plug the usb Bose in after I reconnect to the core or before I reconnect.



I tried a reboot of the Core and re-plugged the USB cable to the core. Nothing still plays out of the Bose USB speakers.

I can get sound through my Sonos Play 5 and my Apple Home Pod Speakers. The Home Pod speakers play individually not together which they do with my Itunes.

If I toggle my Iphone or Ipad wifi off then on it will also add and play on those devices as well as a Bose Soundtouch Radio.

Please advise

Hi @John_Dickerson,

Can you please try to play to your PC’s “System Output” Zone?

This should start playback to the internal speakers of the PC, please let me know if there are issues there as well.


Same issue there. The album files flash by but not playback/sound.


Hi @John_Dickerson,

In that case what you describe could be a firewall issue.

Since you are using a Windows PC, I would verify that both Roon.exe and RAATServer.exe have been added as exceptions to your Windows firewall.

You can use these instructions to add the exceptions and the executables themselves would be located in your Database Location/Application folder path.

I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have and ensure that you connected to your network via a Private network, not a Public one, see this guide for more information.

Noris as you can see on the screen shots Roon.ex and Raatserver are allowed in Windows firewall.

I also use Webroot and I tried it with Roon.exe added and then turned Webroot completely off. Still no sound

Any other suggestions?


Thanks for the details, @John_Dickerson.

Can you try playing to System Output once more and:

  • Note the time that you receive an error
  • Note the track that you tried to play

Respond here with that time and track and we’ll enable diagnostics so we can take a look at what’s occurring during that time on System Output.


3:02PM Eastern Time
Life In A Northern Town by The Dream Academy


Hi @John_Dickerson,

I wanted to reach out because I’ve been keeping an eye on our servers, waiting for the aforementioned diagnostics report.

For some reason it is not reaching our servers, even after I tried re-enabling diagnostics on your account. I also ran a quick test and I was able to submit a similar report from my setup here, so something else is going on.

So we can move forward, I was hoping for now you could use the directions found here and send us over a set of logs using a shared Dropbox link.


I emailed this to you and also attaching a Dropbox transfer link in case the email doesn’t come through.

1 Like

Hi @John_Dickerson,

Thanks for sending those logs over! According to the logs, it looks like your System Output zone only supports 6 channel content: "supported_formats":"48000/16/6".

Can you please try to open the Device Setup tab for this zone and change the Channel Layout to 5.1?

You’ll also want to enable Send stereo/mono content as 5.1 so that all the content gets set to the appropriate channel rate before output.

Let me know if this helps!

Yeah that solved it! Thanks for all your help.


1 Like

Happy to hear that the suggestion helped, @John_Dickerson!
If you run into any other Roon issues or questions, please let us know!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.