Settings not displaying properly or crashing [Resolved with Build 756]

Installed 1.8 on my NUC and the 1.8 remote on both Windows10 and ipad. The only Settings screen I see is the General settings. Where are the AUDIO and Storage locations in the Settings? Also, the screen looks ‘crippled’ on the position where I can set the language. Both when I select English or Dutch, the screen is crippled

See attached screen

9 Likes

Others on the beta forum had this to. I had no issues on my Surface Laptop 3 running latest W10

1 Like

Hi @Ron_Witkamp,

We’re investigating this issue but have a workaround for now. We’ve learned this issue can occur due to OS-level language settings — If you temporarily switch your device’s operating system to English it should work okay.

Our team is working on a permanent solution for this. Apologies for the trouble!

1 Like

Hi, i change the language to en, de, fr but nothing change. My OS is Windows 10 H2 64 Bit german

Changing the OS-level language settings on Windows 10 is not possible on my PC. It’s a Dutch Windows 10, not able to change to another language.

On my iPad, changing to English is indeed solving the problem with the Settings screen.

Change Regional Format to English and it should work

Changed to English from Norwegian. My iPad app still crashes when i try to go to settings.

Hi Ron, you can add English(US) to the language settings on Windows 10 (Taal toevoegen) en set it as your windows display language. It than downloads the language package and after logoff and logon switches to English.
I had the same settings problem on my windows 10 pc and was able to solve it this way.

1 Like

Core Machine (Operating system/System info/Roon build number)

Qnap TS452

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet Gb LAN

Description Of Issue

On the Windows version I can’t see all settings. Only “General”. Not possible to change the system language. No issues via iOS remote.

2 Likes

Same thing for me. Win 10 here. IOS machines are ok.

1 Like

same thing for me

Also iPhones and iPads crashes at Preferences and in Tidal when scrolling down with system language in German. Changed to English and everything worked smoothly.

1 Like

Finally switched the Roon language interface to English: same issue.

System:
2XGeForce GTX550 SLI configuration

Monitor 0
Model SMEX2220 (Samsung)
ID SAM0686
Serial H9XB302466
Manufacturing Date Week 10, Year 2011
Size 21.7 inches
Max Resolution 1920 x 1080 @ 60 Hz
Horizontal Freq. Range 30-81 kHz
Vertical Freq. Range 56-75 Hz
Max Pixel Clock 170 MHz
Gamma Factor 2.2

Software

Windows Version Microsoft Windows 10 (10.0) Professional 64-bit (Build 21301)
DirectX Version 12.0

2 Likes

Only english speaking beta testers is no good !

5 Likes

For this issue, the language in Roon doesn’t matter, but the OS (Windows, iOS, etc.) language does. If you set your OS to use English is there any change?

Same for me

I haven’t tried yet. By the way…I’ll wait for a patch to solve the issue.

Issue on iPad, settings button leads to a crash.
Switching to iPad-Language English ( from German) settings button works fine!
Back to iPad-Language German crashes again…

ipad>settings>crash. Disappointing!

Same here. And settings menu in Windows is broken.
I guess we’ll see the first bug fixes soon.