Tablet, previously working fine, won’t connect to Nucleus

Roon Core Machine

I have had a Nucleus for two years, controlled by a MAC tablet. Now the tablet won’t connect to the Nucleus.

Networking Gear & Setup Details

Tablet on Wi-Fi; Nucleus on Ethernet cable. Same network. 300mbps. Not a problem. Has worked for years.

Connected Audio Devices

Nucleus to Lumin Mini U1, to Mytek Brooklyn DAC+. All Roon Ready and working fine.

Number of Tracks in Library

Don’t know, Can’t get in Roon to see. I think 300-400 albums.

Description of Issue

“Searching for Roon OS Core” Can’t paste screenshot.

Please help. Very frustrating. A phone call would be fabulous.

[Moderator edit: Personal details removed]

Mac tablet ? You mean an iPad ?
Did you try to restart / reboot the Nucleus I assume ?
Delete the Roon app from the tablet, re-install the app and see if this solves the issue

If @Protyreus’s suggestions don’t help I’d also recommend that you reboot your iPad, Nucleus and any network equipment (router and any switches).

If the sensible replies above don’t work, it may be worth plugging an HDMI monitor into the Nucleus to see what (if anything) it’s displaying.


Thanks all. Have done most, not all, suggestions. Will proceed.
Ipad, correct. Please forgive the technical ignorance.
One thing I forgot to mention; the tiny lights around the Nucleus Ethernet port, one is flashing green, and the other is constant orange, which I think may be related to the problem.
Your responses are much appreciated.

Try rebooting your full network including routers / switches etc. as @DaveN suggested.
Do you have a PC / Mac with Roon installed ? If yes can you connect ?

I don’t think this is an issue: Ethernet green & Amber LEDs lit - #2 by Martin_Webster

Thanks for ethernet light edification.
Have rebooted everything with no luck. The attached image is all I get. Configuring Roon OS devices results in a similar screen. Tried the HDMI suggestion but get nothing. Can’t connect with my PC either.
Any suggestions are welcome, thanks.

Ok this is not good.
Your SSD with Roon Core in the Nucleus might have gone bad.
Get in touch with Roon on the website and see if they can send you a replacement SSD

Thanks, will do.

To confirm the boot SSD is dead, power down the Nucleus, remove the m.2 SSD, then power it up. Check if there is now some power up text via HDMI if the m.2 SSD is absent.

When is your Nucleus purchased - over 2 years (i.e. warranty expired) or less?

Purchased from Amazon 1/30/20.

I am not tech savvy. Could use more dumbed down instructions. Will attempt to remove the m.2 SSD (not sure what that looks like; hopefully is labeled) this morning.
Thanks for your response.

Wikipedia is your friend…

When I connect the Nucleus to my labtop via HDMI, I get no response. I called Geek Squad, who have no familiarity with Roon and don’t want to touch it, but advise there is no HDMI signal coming out of the Nucleus because my laptop is not recognizing anything. I took off the bottom (photo attached) to remove the m.2 SSD as suggested, but see nothing that says m.2. Looks very complicated and I am loathe to start pulling out stuff. Remedial help very much needed please.

Hi Covington,

You need to plug the nucleus into a monitor, not a laptop. Most laptops cannot take incoming video signals, they just send them out.

Anyhoo, Below I took a picture and circled the M.2 drive. To remove, all you do is take off that one little screw I have an arrow pointing to, and then gently lift and pull out.

m2 drive

In that case, just contact Roon and send it to be repaired, even though the warranty is probably just expired.

1 Like

Very helpful! Thanks Daniel

Thanks to Daniel’s advice about the HDMI/monitor, I was able to get this image from my Nucleus:

Don’t know enough to follow these instructions. Am assuming it still might be helpful to remove the m.2 SSD to see if that changes the image. Any suggestions welcome.

The only relevant thread I could find is this one, which indicates this could well be a problem with your SSD.

Seems that either boot setting has changed, or the M.2 drive is dead.

Can you enter the bios ? Connect USB keyboard and do the following (turn device completely off, then on again).

  1. Press F2 during boot to enter BIOS Setup.
  2. Go to Advanced > Boot > Boot Priority (or Boot > Boot Priority.)
  3. Set the drive with the operating system to be the first device in the Boot Order.
  4. Press F10 to save and exit BIOS.

Not sure how this works on Nucleus, but a Nucleus is in fact a NUC.