Tidal - "error loading page" - always “synching library now” [Ticket In]

My Tidal won’t update within ROON - I keep getting this message:

I’ve done all the fixes I’ve been able to find on the forum - I’ve restarted the core, I’ve restarted my WiFi/router, I’ve logged in and out of Tidal, etc. to no avail.

When I check Tidal in settings it’s always “synching library now”.

I have a simple setup = an ethernet-connected Intel NUC 7 connected via USB to a pro-ject pre box S2 DAC into my receiver.

All my software/CORE is up to date and this worked just a few days ago.

PS: When I add albums from Tidal within ROON they show up fine - the problem seem to be when I’ve added things to my Tidal library within the Tidal app. But the albums I’ve added are in the general “Your Favorites” in the Tidal section of ROON just not in my ROON library. And under tracks in the Tidal section it says " Failed to load tracks :frowning: "

Hi @Eric_Luther,

Can you try clearing your cache? Please see the following steps:

  • Find and open your Roon database
  • Navigate to Roon/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon and verify if the issue still occurs

Thanks for the reply but that didn’t fix it…

4 posts were split to a new topic: Roon not fetching playlists from TIDAL

Hi @Eric_Luther/@Johan_Hallberg,

How are your router DNS servers configured? Are you using ISP-provided DNS or Google/Cloudflare? We have seen users have a better experience in the past if they change their DNS servers to Cloudflare (, Google ( or Quad9 (

Same thing here - changing the DNS servers didn’t fix the problem.

Can we expect any more input from ROON support?

Hi @Eric_Luther/@Johan_Hallberg,

Can you please try to reproduce the issue and let me know the exact local time + date when you notice this behavior?

Also, can you please provide an overview of the network and how the Core is connected to the network and the model/manufacturer of all your networking gear?

It’s easy to reproduce the incident - it happens every time I go to the TIDAL page in ROON. Just now for instance - at 11:20 AM EST on 1/7/20 I go to my TIDAL page in ROON and get the same error message as noted in my initial post. When I go to Settings/Services/TIDAL it’s always “synching library now”.

I have a simple setup = an xFi Gateway Router and a ethernet-connected Intel NUC 7 running ROCK that is connected via USB to a pro-ject pre box S2 DAC into my receiver.

Thanks in advance for any insight you might have.

PS: When I add TIDAL albums within ROON they do show up in my TIDAL app, it just isn’t working in reverse.

Hi @Eric_Luther/@Johan_Hallberg,

Thanks for sharing the setup details and timestamp.

Now that I have this information, I have enabled diagnostics mode for your accounts and what this action does is automatically upload a set of logs to our servers for analysis.

Once these are received, I will request some feedback from QA regarding the traces, thank you in advance for your patience while this analysis is underway.

Thanks for the reply…

Hi @Eric_Luther,

I appreciate your patience while we had a chance to review logs from your machine. We are seeing signs that this could be related to your Roon Remote/Client and as such, I suggest performing a reinstall of the Roon app on your PC. To do so please, use these instructions (on the PC, not the NUC):

  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder

Thanks for this - this is what I see in the Data folder of my ROON ROCK NUC - which folder do I rename? The RoonOS folder?

Hi @Eric_Luther,

This is not the correct directory, you would need to go to your local Roon Remote installation, try pasting this in your Windows Explorer address bar %localappdata%, there, find the Roon and rename this to Roon_old.

Thanks - I did just as you instructed and yet the same problem persists.

Hi @Eric_Luther,

Let’s try a fresh database in that case.

  • Make a Backup of your Roon database
  • Stop Roon Server from running via the ROCK Web UI
  • Navigate to the folder you were in before:
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Start Roon Server from the WebUI
  • Verify if the issue occurs with a fresh database

Thanks and I did as instructed. Now I can’t connect to the Remote Core from either my PC or my iPad. I get this message:

Here’s a screenshot from my current Web UI page:

Hi @Eric_Luther,

Can you try clicking on “Select a different Core”? Since we have set your old database aside, the ROCK might pop up in the window following select a different Core since it is essentially a “new” install.

Sure I can…hold on.

It’s rebuilding my database but the same original TIDAL problem/message remains.