Tidal issues since last update

Core Machine (Operating system/System info/Roon build number)
Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Mix of Ubiquiti and Cisco router and switches always worked fine.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

All endpoints
Description Of Issue

I have been having constant Tidal sync issues since last update to Roon. I come to use Tidal and Whats New screen wont load, playlists wont load, I look in services and it appears to be stuck syncing, Nothing in my system has changed, network is the same its always been using cloudflare and google DNS. Logging in and out helps for a short time then it returns to the same state.

I just noticed this message as the library is stuck syncing when I have not added anything to it in a while.

I am on latest version of all software. Please advise as this version seems very broken.

Reinstalled RoonOS and delected cache folder. Seems to have stopped the error and after syncing again it seems to have settled down. Will see if this holds.

1 Like

Hi @CrystalGipsy,

Thanks for checking that aspect. My suggestion to you would have been to clear out the Cache, which you have already done so. Do let me know if the issue return or if the cache clear has resolved the behavior.

And how does one clear the cache in Roon?

@erizock21 -

  • Exit out of Roon
  • Find and open your Roon database
  • Navigate to Roon/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon and verify if the issue still occurs
1 Like

Perfect! Thank you :pray:t2:

1 Like

7 posts were split to a new topic: Roon + TIDAL Issues

@noris I had issues with Tidal login again today. I had to restart my network gear yesterday and this caused Roon to loose Tidal account into. I had to restart Roon server on ROCK and login again.

It’s broken again today and nothings changed. This is really becoming rather tiresome @support. Nothing seems to stop Roon from loosing Tidal credentials.

Hi @CrystalGipsy,

When Roon is next in this state, could you provide a copy of your Roon logs by using these instructions?

Sure will do. Been ok for last few days fingers crossed it sticks.

1 Like

A post was merged into an existing topic: TIDAL + local library not working

So this evening for no reason whatsoever Tidal logged itself out of Roon again and had to redo it again for the umpteenth time.

@noris logs can be downloaded from here


Hi @CrystalGipsy,

Thanks for sending those logs over. I am not seeing any TIDAL token issues in your logs, so I don’t belivie this is a case of your TIDAL token expiring and having to re-login. It looks like there were a few issues communicating with our servers in your log and perhaps that is what triggered this. If you haven’t tried this procedure yet, I would give this a try as it may help:

  • Log out of TIDAL
  • Reboot the Core
  • Log back in

If the issue occurs after the above procedure, please also note the exact local time + date you notice being signed out at (if possible) and send me another set of logs. Thank you.

Done all of that so many times. It does seem to happen on reboot or if lost internet for some reason. Loss of internet from my providor is occuring more regular than normal as everyone’s now using it at home all day so putting more stress on their network. That said it should not effect why Roon keeps doing this.

Hi @CrystalGipsy,

Are you able to manually reproduce this issue by unplugging/re-plugging the Ethernet cable on your Core? Or does it require a reboot/the router itself to not have any network connection for this issue to occur?

It’s random really not guaranteed it will do it but I can try.

Ok just rebooted and its not logging in instantly . But it has now.

Hi @CrystalGipsy,

I’m not sure I quite understand this message. Did it take a few minutes and ROCK logged in properly to TIDAL by itself with no intervention on your end?

Yes. Likely due to my switch as it has spanning tree enabled so it takes 30 secs for any device to get connected as it does all it checks first.