Tidal login issue "network error: please check your internet connection"

Just recently, when I launch roon on either iPad or Amazon Fire, I go to settings, services, and I try to login to tidal. I get “network error: please check your internet connection”. I see this has come up in past on the forums but don’t see solution. I logged out and in on both apps, restarted, no luck. Tidal plays fine from tidal app but not roon. Any suggestions? Thanks

Try quitting Roon (or Roon Server, whichever you’re using as your Core) and restarting the app.

Cheers, Greg

Greg’s solution worked for me. I have roon core on a sonic transporter which is like having it on your Mac mini. I restarted the sonic transporter and that solved the problem.

Hi @Woraphot_Jangkamonku ----- Thank you for the feedback and my apologies for the inconvenience here. In order to accurately evaluate this issue, I’d like to gather some information from you in regard to what equipment you are working with. Can you please describe in detail, as shown here, your current setup. The more detailed you are the easier it will be to troubleshoot the problem. Thanks!


Hi @support

I’ve been having this “network error: please check your internet connection” problem all week. Have tried resetting, rebooting etc
Am on HIFI with Tidal & able to login on pc app, browser, ipad app etc
Located in Australia
PC Windows 10 > Squeezebox > Amp plays local data files

Please assist

Try the things in this thread.

I’ve tried everything. Very frustrating. Had it going great ever since my sign up

Are you able to see your account information in Roon in Settings > Account?

What are you seeing when you click Edit next to TIDAL on Settings > Services?

I can see my account information in Settings > Account

On Settings > Services I see [pic attached]

Hi Michael,

So what happens if you enter your Tidal login information?

Cheers, Greg

1 Like

This is the error after I put in my login/password and click login. I’m logged in on iPhone apps etc.

Hi @mdm1979 ----- Thank you for the follow up and the feedback, both are appreciated! Can you verify if you are able to login in to TIDAL successfully via a web browser or the application?

Furthermore, and my apologies if I have missed this in your report, have you tried power cycling your hardware yet?


I’m using Tidal with Roon through iPad application. Very often I don’t get my Tidal library inside roon app because roon fails to connect to Tidal. This happens all the time especially after roon server restart.

I’m getting Network error: Please check your internet connection

Deleting tidal account through settings/services inside roon app doesn’t help. restarting roon server doesn’t help.

However after few days the login starts to work again. It seems there is some problem with authenticating inside roon server or in the roon app. Very very annoying!!!

I’m running Fedora 25, latest roon x64 server, latest ipad app.

I even changed the password on Tidal and nothing helps.

The problem is fixed with 2 consecutive restarts (stop/start, stop/start) of roon server. At least now Tidal is working, but men this is annoying!

Seems like my browser wont log in, yet apps other than Roon do

Hi @mdm1979 ----- Thank you for the follow up. My apologies for the confusion on my part, but based on your screenshot you are unable to access TIDAL a web browser, correct?

Furthermore, are you able to connect to other websites?


All sites work, Tidal doesn’t work on my browser or Roon at home but I am able to login successfully to Tidal through browser at work. Hopefully the Roon 1.3 update can repair this issue.

No luck with latest update either

Inability to login TIDAL through Chrome points to an issue outside of Roon. I would suggest to check your firewall, VPN or any other software which is responsible for network control and installed on that machine.

I’ve tried everything. Turned off firewall, reset browser, modem. I’ve now contacted Tidal.