Tidal media is loading slowly 3

Core Machine (Operating system/System info/Roon build number)

|Model Name:|MacBook Pro|
|  Model Identifier:|MacBookPro16,1|
|  Processor Name:|8-Core Intel Core i9|
|  Processor Speed:|2.4 GHz|
|  Number of Processors:|1|
|  Total Number of Cores:|8|
|  L2 Cache (per Core):|256 KB|
|  L3 Cache:|16 MB|

Roon Core 1.7 Build 710 Stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wifi Router ASUS RT-AC88U, 10 feet away from the laptop, on WiFi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Chord Hugo 2 + 2Go
Chord Mojo + Poly
All latest firmware installed


Error: Tidal media is loading slowly

It happens on random occasions.
Ethernet cable or Roon server is not an option for me.

Hi @arazmj,

Can you go to Settings > Services, click Edit next to TIDAL, and then lower the streaming quality to the lowest setting? After doing that is there any change?

The issue happens randomly. Currently, I cannot replicate the issuye and it’s working fine with master quality and upsampling enabled.
This is the network activity for the main Roon process.

This is the nettop output for Roon process.

Roon.87476                                                                                                            108 MiB         176 MiB     0 B     102 B      74 KiB
   tcp4<->                     en0   Established        3486 B          2099 B       0 B       0 B       0 B    23.66 ms
   tcp4<->                     en0   Established           0 B            54 B       0 B       0 B       0 B    36.88 ms
   tcp4 *:62176<->*:*                                                                                  Listen
   tcp4<->                                            en0   Established           0 B           171 MiB     0 B       0 B      73 KiB  18.97 ms
   tcp4<->                                            en0   Established          23 KiB          89 KiB     0 B     102 B     355 B    19.59 ms
   tcp4<->localhost:50854                                                   lo0   Established         171 KiB         240 KiB     0 B       0 B       0 B     0.22 ms
   tcp4<->                                              en0   Established           0 B             0 B       0 B       0 B       0 B   22056.00
   tcp4<->chromecast:8009                                                en0   Established           0 B             0 B       0 B       0 B       0 B     9.00 ms
   tcp4<->google-home-mini:8009                                          en0   Established           0 B             0 B       0 B       0 B       0 B     3.00 ms
   tcp4<->localhost:50274                                                   lo0   Established         367 KiB         437 KiB     0 B       0 B       0 B     0.22 ms
   tcp4<->localhost:50263                                                   lo0   Established         370 KiB         367 KiB     0 B       0 B       0 B     0.22 ms
   tcp4 *:9102<->*:*                                                                                   Listen
   tcp4<->*:*                                                            en0        Listen
   tcp4 *:9150<->*:*                                                                                   Listen
   tcp4 *:9101<->*:*                                                                                   Listen
   tcp4<->localhost:9004                                                    lo0   Established           0 B             0 B       0 B       0 B       0 B     0.22 ms
   tcp4 *:6700<->*:*                                                                                   Listen
   tcp4 *:9100<->*:*                                                                                   Listen
   udp4 *:65404<->*:*                                                                       en0                       120 KiB          51 KiB
   udp4 *:55796<->*:*                                                                       lo0                      4452 B          1908 B
   udp4 *:56213<->*:*                                                                                                   0 B             0 B
   udp4 *:61392<->*:*                                                                                                5713 KiB         449 KiB
   udp4 *:56909<->*:*                                                                       en0                      5713 KiB         449 KiB
   udp4 *:1900<->*:*                                                                                                   20 MiB         449 KiB
   udp4 *:61581<->*:*                                                                       lo0                         0 B           449 KiB
   udp4 *:1900<->*:*                                                                                                   11 MiB         449 KiB
   udp4 *:45454<->*:*                                                                                                   0 B             0 B
   udp4<->*:*                                                                                     20 MiB           0 B
   udp4<->*:*                                                            en0                         0 B           150 KiB
   udp4 *:63892<->*:*                                                                       en0                       607 KiB         679 KiB
   udp4 *:5353<->*:*                                                                                                   42 MiB           0 B
   udp4 *:52819<->*:*                                                                       lo0                         0 B           679 KiB
   udp4 *:5353<->*:*                                                                                                 1504 KiB           0 B
   udp4 *:60544<->*:*                                                                                                   0 B             0 B
   udp4 *:9001<->*:*                                                                                                    0 B             0 B
   udp4 *:59146<->*:*                                                                                                   0 B             0 B
   udp4 *:9001<->*:*                                                                                                    0 B             0 B
   udp4 *:9003<->*:*                                                                                                   11 KiB           0 B
   udp4 *:9003<->*:*                                                                                                   38 KiB           0 B
   udp4 *:63834<->*:*                                                                       lo0                        12 KiB          20 KiB
   udp4 *:9003<->*:*                                                                                                 8553 B             0 B

I will send you the same info once I got the error again.
The thing that I am not sure is that why there is no option to enable some buffering on the streaming side? Why does Roon jumps to next track when getting that error?

This happens on Tidal Lowest Quality.

This is very annoying any suggestion?

Hello @arazmj, in our networking best practices, we recommend Ethernet to the core to avoid issues like these. Could you please connect your core to Ethernet and see if this helps the issue?

Would you just give us a little more technical details why there is a such networking practice with Roon?
I am in networking field for more than 10 years.

I think my requirement is valid. I want to use my laptop as core with my Hugo 2 + 2Go device as a to-go setup. Furthermore, I cannot use Ethernet cable in all places.

Hi @arazmj — While I understand your preference here is to use WiFi, we definitely find that Ethernet is much more reliable, and even if it is not a permanent solution connecting via Ethernet as a test to see if the same behavior occurs will be a great data point!

@Dylan I have my core connected to internet by Ethernet. I disabled WiFi on the core to make sure. Still getting the same error on both Qobuz and Tidal. Running the latest version of Roon.

Anyone can help here? It’s a Gigabit port.

Update I have upgrade my internet speed from 250Mpbs to 450Mbps. Did not help

Hello @arazmj,

I am very embarrassed that we didn’t see this post until today. Please, accept my deepest apologies :pensive:

Are you still running into the same issues with TIDAL and Qobuz? We’d love to help :nerd_face:


A post was split to a new topic: Tidal media loading slowly with ROCK Core setup

A post was split to a new topic: TIDAL media loading slow