Ubuntu Server 22.04

Tomorrow Ubuntu 22.04 should released and so my question. Has already someone upgraded (with do-release-update -d) to the new version and see problems with this version?

If you’re on 20.04 Long-Term Support, then I’d recommend waiting. I’d certainly try the upgrade in a VM first. Also the Release Candidate has only just been published, so I don’t expect the final build for a couple of days.

1 Like

I installed Roon on a freshly installed Ubuntu 22.04 LTS server last night. do-release-upgrade from 20.04 did not work for me, but that was probably user error. After a fresh install of ubuntu server 22.04 from USB, and installing a couple of extra dependencies (lbzip2 and libnss-mdns) Roon server is working without issue.

To complete the install, I ssh’d into the server, then:

sudo apt update
sudo apt install -y lbzip2
sudo apt install -y ffmpeg
sudo apt install -y libasound2
sudo apt install -y cifs-utils
sudo apt install -y libnss-mdns
curl -O http://download.roonlabs.com/builds/roonserver-installer-linuxx64.sh
chmod +x roonserver-installer-linuxx64.sh
sudo ./roonserver-installer-linuxx64.sh

Good news.
I have been running Ubuntu server 22.04 also on a RPI installed with Roon bridge.

Works perfect

A current LTS release doesn’t show available upgrades until the point release, e.g., 22.04.1, is out, which is usually around September.

Incidentally, I attempted an upgrade on my MacBook Pro and this failed. However, the hardware and build is uncommon, so I’m not too surprised. A fresh install went smoothly.

I won’t be updating my servers for some months, if not longer.

2 Likes

Yeah I was kicking myself after the do-release-upgrade caused a kernel panic on boot. Definitely agree anybody already running 20.04 will be best to stay put for now.

I just updated my RoonCore (NUC7i3BNK) from Focal Fossa 20.04.4 LTS server to Jammy Jellyfish 22.04 LTS server with do-release-upgrade and it worked like a charm.

I just had to uninstall/reinstall QuteBrowser and update my ~/.config/qutebrowser/config.py (I’m using QuteBrowser as display).

Everything else is running without a glitch. :ok_hand:

2 Likes

Just upgraded to Ubuntu 22.04 using the “do-release-upgrade -d” option and Roon Server is working for me on Intel NUC.

4 Likes

Ubuntu works perfectly.

2 Likes

In the evening I’ve now also updated to server 22.04.
Roon itself had no problems with it, but:

  • Logitech Mediaserver → you’ve to install a nightly build from 8.3, because Ubuntu has updated perl
  • liquidsoap cannot build with the Focal OPAM, because there isn’t a version for Ubuntu 22.04, but I solved it with installing with options from a new installed OPAM.

@Mark_Mitchell I just wanted to say thank you for your post. The roon instructions did not work for me. But your very clear and concise guide helped me with the installatiin and i now have the headless server i wanted. Roon should take your post and include it in their setup guide

1 Like

Here are a couple of tweaks I found for Roon on Ubuntu Server. The first is using the low latency kernel instead of the generic one that is installed by default. The second is installing the Ubuntu Studio tweaks - this seems to just affect swappiness which I was changing anyhow, but it’s all wrapped up in a nice package. I’m running headless on a low power machine, and both these worked for me. Free to try…

Instructions to install the low latency kernel

Instruction to install the Ubuntu Studio tweaks

I’m very keen to know if anyone has other optimisations or tweaks to share for Roon on Ubuntu Server.

4 Likes