UPDATED: Any experience with NUC10i7FNH + ROCK + Qobuz? [Was: Intel NUC + ROCK -- Qobuz won't work]

Core Machine (Operating system/System info/Roon build number)

Intel NUC10i7FNH; 8 GB RAM (Crucial DDR4 3200 MT/s (PC4-25600 SODIMM 260-pin); 256 GB SSD (Samsung 970 EVO Plus M.2 NVMe)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Ancient DSL Modem (ActionTec PK-5000) --> Ethernet Cable --> Roon Core on ROCK on NUC

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

All music content files are on a 5 TB WD portable external disk

(1) [Wifi Networked Mac running Roon Bridge] --> USB --> HRT Music Streamer II+ DAC

Description Of Issue

I’ve just (2 hours ago) set up the above Intel NUC. Everything appears to be working, except that Roon can’t play anything from Qobuz.

Until this morning, I ran Roon Core on a Windows 10 laptop that was connected to the internet in exactly the same way and via the same exact ethernet cable that is now connected to the NUC.

Here are some screenshots, with the endpoint being the Mac indicated above under Audio Devices:

(1) Roon playing my own local music without problems:

(2) Roon failing to play Qobuz (this was on all the 10 or so different tracks and albums I tried, not just this one):

(3) The Qobuz app on the same Mac playing the same exact track without problems, 2 seconds later:

I am extremely disconcerted by this, as I never had a problem of this kind with Roon playing Qobuz when Roon Core was on the Windows laptop. If Roon on the NUC can’t play from Qobuz, I’m going to have to return it (which I don’t want to do, because I wanted to move away from Windows and to an always-on appliance).
@support (and anyone else) can you help with this please? Thanks in advance!

UPDATE: I now appear to be having problems playing even my local music from the NUC to the remote Mac endpoint. Internet connectivity to the building checks out fine via Speedtest. Now looking into connections specifically to the NUC. Still hoping for any suggestions, though***

FURTHER UPDATE: Rebooted modem, etc. Now back to playing local music to Mac endpoint, but not Qobuz. Same thing with other wifi endpoints such as my iPhone*

It occurred to me that it will be more useful to ask specific questions than to make a long post as above and then say “Help!” :slight_smile:

I realize that the NUC I’m having difficulties with could be defective in some way (e.g., network card). But, assuming for the moment it’s not defective, and as the NUC does work for local music, I’m wondering about general, somewhat known things that could cause Qobuz-specific issues.

So, does @support or anyone else have any information about the following questions, please?

  1. Is there a general reason why Qobuz might fail to work on a Intel NUC10i7FNH but work on a Windows 10 laptop even though the NUC is connected to the internet in exactly the same way as the Windows 10 laptop previously was? (I’m thinking of things like known processing/buffering/throughput/networking differences between the two types of devices, if those are at all relevant to Qobuz).

  2. Is there a general reason why Qobuz might work worse on an Intel NUC10i7FNH than on some other NUC such as a NUC8i7BEH…? Again, I’m wondering about any known differences between the two NUCs that could affect Qobuz function.

Thanks in advance for any ideas!

Can you get into the modem set up page and see where it is pointed to for DNS servers?

1 Like

@ged_hickman1 – Thank you for that suggestion! I’m not at the NUC location (home) currently, but I’ll make sure to check that in the evening. Thanks again.

[EDIT/UPDATE: @ged_hickman1 One clarification I should make: The NUC does appear to be able to log in to Qobuz, and will sometimes play one track from there – but then after that it will hang on track after track, skipping each one without being able to load it. Is that still consistent with a possible DNS server issue?]

  1. No
  2. No

I am sure that Ged is going to suggest trying or if your DNS is not set to those and seeing if that makes a difference. Also, try rebooting the router after updating the DNS if you follow Ged’s advice. (waves @ged_hickman1). Sometimes pending router updates can cause issues.

If that doesn’t work…

I would simplify playback with the NUC. Turn off all DSP, etc and connect the DAC directly to the NUC and then test.

If that doesn’t work, then I’d load windows on the NUC (temporarily) which would allow you to run diagnostics. Since this is a new install and you can load Windows without a license to just test things.


@Rugby – Many thanks! A lot of helpful troubleshooting steps for me to try, thanks to you and @ged_hickman1 – much appreciated,

Hi @otinkyad,

Using a different OS on the NUC is a good test to run. Like @ged_hickman1, I suspect this might be a DNS issue, I’ve seen DNS issues impact operating systems in different ways.

Is this Modem also doing routing capabilities, as in it hands out IP addresses or is it just ROCK connected to the modem directly? Are you able to try a DNS change here?

Does the issue only occur on the HRT zone or does it occur if you try to play to your Mac’s System Output zone as well?

Hello @noris – many thanks for getting back to me on this!

The modem is also handling routing and handing out IP addresses. As you and @ged_hickman1 and @Rugby all suggested, I am planning to try the DNS server change. However, it’s been a while since I last did admin on the modem, and since then, my wonderful ISP seems to have changed modem admin login credentials on me. So I’ll have to get that sorted out with them before I can configure the modem. Will report back once I’ve (hopefully) been able to change DNS servers.

The Qobuz issue does occur on all zones, including ones that are physically connected to the NUC (e.g., a Marantz Pre/Pro, connected via HDMI – I didn’t list all zones in my initial post, just to simplify). All zones are able to play my local music.

Thanks; will report back as soon as ISP wrangling allows…

Hello @noris (and @ged_hickman1 and @Rugby ). My updates are unfortunately all negative.

Configuring the modem to use DNS servers or did not help with the Qobuz issues on the NUC, not even when turning off all DSP, and not even when playing to a device that is physically connected to the NUC (a Marantz pre/pro connected via HDMI).

In all these cases, the NUC can play my local music just fine.

And in all these cases, the Windows 10 laptop plays not only my local music but also Qobuz seamlessly, when connected in exactly the same ways as the NUC to ethernet and endpoints.

Not sure what’s going on, and quite discouraged… I’m a bit hesitant about the Windows installation idea that @Rugby suggested. @noris, do you have any suggestions other than that? And if Windows 10 install is the only option here (for diagnostics), any pointers on how to do a free install? (A quick web search just now did not yield any clear information.

Thanks –

I suggested Windows because I assumed it was an environment you are familiar with; however, you could always load up a Linux distro like Ubuntu.

As for free, you use the Microsoft tool to create a Windows install which you would create on a USB key. Windows will allow you to install it without activating with a license and will function for 30 60? days. I do it all the time loading up a new PC to verify that the hardware and software works before wasting a license activating it.

OK, that’s very helpful, thank you!

[I am somewhat familiar with *using* Windows, but have only done an install once – for the laptop that has been my dedicated Roon machine – and the Microsoft tool mention was a useful reminder, thanks.]

Just thought I’d provide an update: I’ve installed Windows 10 on the NUC, and Qobuz is playing just fine to all endpoints…

@noris (A) is there anything that can be done to address my issue (Roon Core on ROCK not playing Qobuz) on the ROCK end? Even if this is a DNS issue, is that something that can be addressed in ROCK? (updated network drivers or something? just guessing). If one operating system can negotiate the networking setup, shouldn’t it be possible for an OS that is custom-built for Roon (with its prioritization of streaming services) to be able to negotiate the same network setup on the same hardware?

Sorry if I sound frustrated. But I purchased this $600 NUC because it is specifically listed as supported on the Roon ROCK page. And if Roon Core/ROCK doesn’t have streaming functionality on this NUC (when Roon on every other OS+machine combination I’ve tried does, in the exact same network environment), the $600 is basically a waste for me (and it turns out I can’t return it – Amazon won’t accept computer returns). And I already had a Windows machine (a laptop) that was dedicated to Roon – I wanted to move away from Windows and just have an always-on appliance and not have to deal with Windows…

And a second question for @noris (B) do you have any reason to think that a NUC8i7BEH would handle things better?

Any thoughts on (A) and (B) would be appreciated – thanks in advance.

1 Like

Hi @otinkyad,

Thanks for installing Windows on the NUC and confirming that Qobuz is working as expected on it!

You could try to set up a manual DNS by using Static IP in the ROCK Web UI. Ultimately though, it can be a networking issue that impacts Linux but Windows has additional mitigation in place to prevent.

No, if both are running ROCK, I don’t believe it would make much of a difference.

As for next steps, we can either:

  1. leave Windows on the NUC as it is working (not sure if you used a trial though)

  2. Try to install RoonServer on Ubuntu and verify if Ubuntu has the same issue (as I mentioned, this may only impact Linux).

  3. Re-install ROCK and we can try to troubleshoot ROCK directly, using the Static IP DNS change I mentioned above and by looking at logs.

Please let me know how you would like to proceed, thanks!

Hello @noris – many thanks for getting back to me!

OK, that’s very helpful for my understanding, thanks.

Well… right after my previous post, I re-installed ROCK on the NUC10, just in case I had messed up the install the first time, but things were no better with Qobuz. So then, as I had read about many people reporting other Roon+NUC10 problems (at least, through August or so), I went ahead and did acquire a NUC8i7BEH. (I’m hoping I may actually be able to return the NUC10 after all – long story). I installed ROCK on the NUC8, and Qobuz does appear to be running substantially better than on the NUC10. Not anywhere near as smoothly as with Windows, and Qobuz album art/album info appear not to update well (or appear at all), but most of the time I can at least get the audio streaming. I don’t consider it acceptable (my listening is always tinged with apprehension – will it keep working? will the album art/info update? – and that really detracts from the enjoyment), but, clearly better than on the NUC10. The caveat is that I have not tested the two NUCs concurrently, so I can’t rule out other factors contributing to the difference. But if anything, network stability at my location has been worse during the days I’ve used the NUC8 than it was when I was using the NUC10. This is just one anecdotal non-scientific data point, of course, but my strong impression is that the NUC8 works better.

I think I would not want to do the Windows option – I think I’d rather just use my Windows laptop than try to manage a headless Windows installation (and also pay for a new Windows license).

Before deciding between options 2 and 3, I’d like to wait a few days, if that’s OK. There is an ISP plan upgrade that I have scheduled for later this week, and if it happens and actually changes anything about my internet connection (e.g., faster download speeds, without making anything else worse) maybe that would move the NUC8+ROCK+Qobuz combo into acceptable stability.

If that doesn’t work, I think I might try the STATIC IP DNS change first, before the Ubuntu install.

So I hope it’s OK if I get back to you in a few days? – Thanks again for your help!

1 Like

AS a side note, I think the “use the old Windows 7 license key” actually still works for activating Windows 10. So, if you have an old Win 7 license key you could try using that as a test, of course only if you decide to keep Windows. No use in wasting the activation otherwise.

@Rugby – thank you – yes, I think I was vaguely aware of this from looking up info on how to do Miscrosoft Tool installs. I don’t have a Windows 7 machine, though. Oh! I just remembered I think I have a Windows 8 tablet somewhere…

Aside from the cost of a license, though, I’ve been shying away from managing a headless Windows install. If you have experience with this: (a) is it perhaps less painful than one might think (specifically, the managing-while-headless aspect)? I’d be using Windows Home, not one of the LTSC or Enterprise versions. (b) any resources you can point me to on how to do this? I’ve only found suggestions to use VNC…

Thanks in advance for any info –

Won’t work, Microsoft DID close down using Win 8 license codes.

Ah… oh, well!

@Rugby – at the end of the day, I want an always-on Roon device. Not comfortable doing that with my Win 10 laptop – and in any case I have been unable to figure out how to stop the monitor from going to sleep and causing everything to hang – hence the NUC. If ROCK ends up not working well in my network environment even after help from Roon support, then I will want to look into headless Win10 or Ubuntu. A bit concerned, from what @noris said, that Linux may have networking issues that are handled by Win10.

So, would still appreciate any thoughts on ease of Windows 10 headless management! – TIA

1 Like

@Geoff_Coupe – Thank you very much! I

I had done general searches for “Windows 10 headless admin”, and didn’t find much that was very helpful. But I didn’t think to do Roon-specific searches. Now that I’ve done the latter following your pointer, I see there’s so much more Roon-KB and Community info that’s helpful – thanks again!

1 Like