Very Large Album will not load [Resolved Build 223]

The album is the set of Bach Cantatas by Gardner. There are 56 CDs in the set, but I have been lazy about merging them all (they did not come in all together) and I have 45 CDs merged into the set. I can find the album, but when i click on it, an error message flashes by (subliminally i think I see something about a network error) and then i am left with the error message “Error loading saved page”.

I am using a sonictransporter as core, and I have multiple remotes: this macbook, an ipad, and an iphone. The same behavior occurs on all of the remotes.

I believe the problem did not start suddenly. i think I saw this same behavior intermittently, like when i would be playing one of the discs from the album and would hit the back button to view the album, but now it happens no matter how I try to access the album. I do not believe it coincided with the upgrade to 1.3. I think I am fully current in software levels on core and remote at this time. I have not had the problem with other multi-disk albums, but I am not sure I have another this size. The closest I easily find has 21 disks and is fine.

I have tried restarting the core. I have restarted all the remotes. I have selected the album, clicked edit, and both re-scanned the album and re-identified it. I can find works on the album, and I can play them without problem, so the underlying files appear to be fine. @support please advise.

Is all your music on the same disk / folder ?

What or how is the folder structure of those you having an issue with ? Are they different from other collections?

Your post is quite informative, but what is the version of your core and controllers ?

All of my music is on the same disk. It is a MyBook Duo NAS, wired into the network direct to the router, as is the sonictransport, I rip my musiv to this disk using DBPoweramp, which puts the music into a shared music/m4a/artist/disk folder. This means there is a folder for each of the 45 disks in this album. This is the same as for all other disks in my collection. For John Eliot Gardner (the artist), there are 62 folders for individual disks, 56 of which were from this box, 45 of which are merged into this album. I was intending eventually to merge all 56.

I might add that I migrated over from Sonos in October, and have been pleased with the way Roon handles multidisk sets such as this. I have been methodically making my way through the set. For Sonos, i had to be very careful when ripping the CDs to make sure the album title included what disk, or else it would be very hard to listen to the disks in any order and keep track. By having Roon group the disks and order them for me within the album has been great. i look forward to it working bug free in the near future!

Sorry, I meant o add that I am using 1.3 build 208 on the Core and all remotes.

Can’t help you but can just say that I own much bigger boxes which open correctly, albeit dead slowly even on a SkullCanyon NUC.

So there’s something a bit more specific going wrong here.

Since I loaded the last verion onto my remotes, problem solved. Interestingly, right before i did that, the problem cropped up on a 2 disk album, so it was no longer an issue of size (as Ludwig suggested). Anyway, I see a few bugs, but all are minor.

Sounds like you where having the same issue as I have had:

I have the same problem with all my remotes, Ipad, Iphone,Imac, android tablet since I upgraded from Roon server to Roon core.
It makes Roon as good as unusable, I see nowhere a response from Roon.
I am thinking about going back to LMS and quitting Roon.

I have no problems with this with OS X and Windows and iOS remotes. My largest box set in Roon is 160 discs.

I suspect you simply have a gross performance problem, but let’s flag @support and see what they say.

1 Like

@Mike_Agsteribbe – can you give us some more details here?

What albums are you having this issue with? Can you give us the details of your setup, as described here?

The problem arises with albums which contain 2 or more disks, f.i. The Matthew passion.
I am using Vortexbox with a built in HD of 2 TB.
As a remote I use an iPad with the latest Roon version which controls Roon 1.3. There are about 34000 tracks. The memory for photos and artwork is set to 512MB

@support -Problem is back for me, but quite intermittent. If I close the app and reopen it, sometimes it will load the album OK. That seems to exonerate the database. If I had to guess, I would say something nasty is happening in the connection between controller app and the core when loading info about multiple disc albums into the app. When it happens, other things seem to look different in the app, for example, going to the overview page I no longer see what is new in my library. It seems to be a good idea at these times to close the app and reload it.

I have been trying to merge disks that belong in multi-disk albums, and in that context, when this problem occurs the merge disk screen opens but no disks or tracks show. I am looking forward to this getting fixed.

OK so I have another observation. I had said it was intermittent. it is a problem all the time on my ipad. It is only on the Mac that it is intermittent. This morning I went to play a disk from the Bach Cantata album and absolutely could not open the album on the ipad. I closed and reopened the app several times, even going so far as to restart the ipad. On the Mac it opened first time. On the other hand I ahd sen the problem before on the Mac. I just figured every added observation would help. @support do let us know if you have managed to reproduce this bug in house. If so, I can stop posting these added observations.

We tentatively believe we have a set of steps that reproduce this issue – we’re confirming and testing now, and will update everyone as the ticket is opened and sent over to the developers to fix.

Thanks for all the details guys!

Thanks very much for this. As a new Roon user, I started to organize my classical sets and ran into this problem quickly (with a 15 disc Angela Hewitt compilation), failing on iPhone, iPad, and Surface. Looking forward to the fix.


I am suddenly having the same issue with connections to core (on ST-AP) from multiple iOS devices when playing sets with multiple discs. Music played, but devices repeatedly lose connection, “error loading saved page” message, attempt to reestablish, getting 'initializing" message from core. Restart core solves the problem but only temporarily.

1 Like

This item seems to be closed by support, but is not solved at all!
Albums containing 2 or more disks do not load and keep the Roon logo spinning until a complete reset is done.
This bug should be solved asap because it restricts the usability of Roon for my library.

It doesn’t say “Closed” in the thread title, and nor have the Roon team released a fix yet.


All (@Alan_Spool / @Mike_Agsteribbe / @wkimbel87) — Checking in to see how things are holding up after the last update(s). Has the experience been the same or improved?

Looking forward to your feedback!

It works again, loading of large albums is no problem anymore. Thanx for the solution of this problem.

1 Like