Volume limit prevents speedy adjustment from max after reboot

I really like the volume safety limits - I have them on a few zones.

That said I’ve had a problem a few times where after a device has been reset it goes back to 100%. This wouldn’t be so bad, except the system prevents you from quickly reducing it with the slider - you have to notch it down with the minus - one point at a time - until you’re out of the red, which can take ages. Not ideal when sound’s blasting out!

Seems like it would be safe to let you always slide to a lower volume.

1 Like

I had this on my pi’s with HifiBerry amp boards it was a bit annoying . As Roons volume is in tandem with Alsa master output it would set it to 100% on reboot as that was Alsas default level. I worked out that if you set Roon to your desired level then ssh into pi and type
alsactl store it would set this as the default Alsa level on reboot.

I agree though the controls are too fiddly to get it down quick.


@support totally agree…a lowering of the volume immediately should be possible in all circumstances especially if it’s at 100

Hello @hifi_swlon,

Thanks for contacting support, I’d be happy to assist here. Can you please provide more information regarding your setup using this thread as a guide?

A few other questions/observations:

  • What DAC are you noticing this issue on?
  • Does this issue only affect a particular zone?
  • I have just tried to set Volume Limits on one of my DACs and then unplugged it and plugged it back in, even restarted Roon and it kept the same values.
  • Is there any specific reproduction steps that seem to cause this behavior?
  • Are you using WASAPI or ASIO drivers for your DAC?
  • Are you using DSP volume or Device Volume?

Please let me know when possible.


Seems to be an issue with rpi dac hats

Yeah it’s on pi hat zones - think have seen it on both hifi berry dac plus and Iq audio, both running dietpi. Regardless, whichever device finds itself in that position, it would be better to be able to quickly ‘slide your way out of it’, volume limits or not. :wink:

1 Like

Hello @hifi_swlon/@wizardofoz,

Thanks for letting me know. Can you please provide reproduction steps for this issue?

Do you have to play content and then reset the device while there is music playing or does this issue occur regardless if music is playing or not? Are you using DSP Volume or Device Volume? Does this issue occur for all file formats?

Please let me know when possible and we can take a look at the behavior on our end.


Ropieee is set to reboot on a regular basis and when it does it comes back with 100% volume even tho the device settings in Roon are min and max of lesser levels per my screen shot above, reboots are to encipher the software updates are completed on a regular basis

Hello @hifi_swlon/@wizardofoz/@CrystalGipsy,

I wanted to let you know that I have discussed this case with one of our senior developers today. They have noted that while volume limits set in Roon should reflect the levels you can set in Roon, the actual levels are stored with the Operating System. If the operating system is persisting the volume levels across reboots, this is why you are seeing this behavior.

I’ve passed the request about making the volume slider more speedy on to the product team and will update this thread when I have some feedback from them.


1 Like

To resolve the issue as a workaround for now I removed the volume limits in roon and now at least I can drag the slider down to a normal volume in one quick swipe negating the 70 Od clicks on the - button every time. Also you can quickly pause the music too while you adjust it

I still think it would be better if the - button was to the left of the slider thus not so close to the plus button and the 100% end of the slider.@support

Hello @wizardofoz,

Thank you for providing your feedback here. I would recommend also posting your suggestion in the 'feature request" section of the site.

Our product team and developers keep a close eye on that category, so that’s definitely the best place to propose a change like this and get feedback from the Community.


Have to say I don’t really see this as a feature request… it’s something that needs addressing.

1 Like

I tend agree its not really a feature is a simple relocation of existing layout buttons to avoid potential destruction of ones speakers where roon volume level used.

Thank you! That worked perfectly.