ARC fails when syncing to core [Update to Build 1148]

So I seem to have full connectivity. No issues there at all. When the app moves on to sync to my core, it fails. I get a red dot with an x in it with the text “Something went wrong while syncing to your Roon Core.”

@Gregg_Church, please complete the following template, so you may be assisted. Thanks.

Roon Core Machine

<!-- Include your operating system and machine info (Model, CPU, RAM) -‐>
<!-- Write below this line -‐>

Networking Gear & Setup Details

<!-- Your network gear (model of routers/switches) and if on WiFi/Ethernet, are you using YPN -‐>
<!-- Write below this line -‐>

Connected Audio Devices

<!-- Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.) -‐>
<!-- Write below this line -‐>

Number of Tracks in Library

<!-- Tell us how large your music library is, eg. “30,000 tracks” -‐>
<!-- Write below this line -‐>

Description of Issue

<!-- Tell us about the problem you’re having in as much detail as possible. Screenshots are always appreciated! -‐>
<!-- Write below this line -‐>

Continuing the discussion from Arc fails when syncing to core:

My apologies.

Here ya go…

Roon Core Machine: Intel Core i5-9400F CPU @2.90 GHz running Windows 10 Home 64 bit/ 8 GB RAM

Networking Gear : Router Ubee DDW36C into a TP Link TL-SG1024D Switch connected via Roon Core via ethernet

Connected Audio Devices: 3 Raspberry Pis running Ropiee all connected via ethernet. One Cambridge DACmagic connected via optical at Core machine.

50,781 songs in library. Both local and through Tidal subscription

Mobile Device: Samsung Galaxy S8+ Model SM-G955U1 running Android 9.0

Description Of Issue : The auto setup for connectivity seems to work relatively fine. Sometimes my phone will see it, Others not so well. Upon restart it sees it right away. When the app moves on to sync to my core, it fails. I get a red dot with an x in it with the text “Something went wrong while syncing to your Roon Core.”

No problem. I suspect Roon support will take a look at your logs. But please be patient as the forum is very busy, and there are many open tickets.

I uploaded my logs so they’ll be available if need be.

Same issue, it shows my core as available and then this nugget of a descriptive error when trying to connect. I’ve tried multiple internal listening ports and manually set corresponding port forwarding even though this is failing locally just to be sure (which btw requires a logout/login on the arc app or it just spins forever trying to reconnect, presumably right now it only pulls down the listening port when you first login and caches it with no option to auto or manually retry other than logging out - kudos on that little bit of error detection and alerting team).

Roon Core Machine

Core = ROCK , Version 1.0 (build 227) stable. Intel NUC.
Server version = Version 2.0 (build 1128) production

Networking Gear & Setup Details

Wifi, Asus AX/v6 Mesh.
Connectivity shows as working fine from the ARC setup on Roon desktop and on the client for all tested ports.

Connected Audio Devices

ARC client is a Samsung S20Fe

Number of Tracks in Library


Description of Issue

Client detects the core, states it is available, then states “something went wrong while syncing to your roon core” when trying to connect

This, Null Tag, might be the culprit (I snipped the succesful syncs on earlier elements)

09/20 22:08:52 Trace: [library/mobilesync] syncing tags…
09/20 22:08:52 Error: [library/mobilesync] unexpected error: System.ArgumentNullException: Value cannot be null. (Parameter ‘collection’)
at System.Collections.Generic.HashSet1..ctor(IEnumerable1 collection, IEqualityComparer1 comparer) at Sooloos.Broker.Music.LibraryGenre.GetImage(Library library) at Sooloos.Broker.Music.MobileSyncManager.<SyncTags>g__ToTagItem|41_3(LibraryTagItem item) at System.Linq.Enumerable.SelectListIterator2.MoveNext()
at System.Linq.Enumerable.WhereEnumerableIterator`1.ToList()
at Sooloos.Broker.Music.MobileSyncManager.g__ToTag|41_5(LibraryExplicitTag tag)
at Sooloos.Broker.Music.MobileSyncManager.SyncTags(MobileSyncClientState clientstate, MobileSyncResponse response)
at Sooloos.Broker.Music.MobileSyncManager.Sync(MobileSyncRequest req)
09/20 22:08:57 Info: [stats] 23226mb Virtual, 2046mb Physical, 958mb Managed, 368 Handles, 74 Threads

I am getting the same error. Port forwarding set to automatic on the router. Watching…

I am also getting syncing error

I just put in a support request for the same issue

Hi All,

Thanks for the reports!

I think your hunch might be onto something here, @Derek_Coleman ! I’ve activated diagnostics mode for your accounts and indeed, I am seeing this error in most of the logs. I’m checking with the team on this issue, thanks for flagging us!

1 Like

Roon Core Machine

Barebones Case/MB model: shuttle XH110
Processor Intel(R) Core™ i5-7400 CPU @ 3.00GHz 3.00 GHz
Installed RAM 8.00 GB (7.89 GB usable)
System type 64-bit operating system, x64-based processor
Edition Windows 10 Pro
Version 21H1
Installed on ‎11/‎15/‎2020
OS build 19043.1826
Experience Windows Feature Experience Pack 120.2212.4180.0

Networking Gear & Setup Details

AT&T Gigabit Fiber, Gateway Model: BGW320-505
Set up with IP passthrough to
Orbi Pro SXK80 modem, SXS80 mesh satellite

Core PC connects through gigabit wired Ethernet

Connected Audio Devices

NAD c658
Bluesound Node 2i, Vault 2i, Powernode
Multiple RPi Roon Bridge devices (mostly DAC HATs, but one USB DAC)
Occasionally AirPlay and Chromecast devices

Number of Tracks in Library

27,000 tracks

Description of Issue

I upgraded my Core to 2.0, and in settings it says ARC is “Ready.” The ARC iPhone app finds the Core and says it is “Online and Ready,” but when I attempt to sync, it fails and says “Something went wrong while syncing to your Roon Core.”

Same error on local Wi-Fi and mobile data, and both networks are extremely fast. I’ve tried rebooting the core and deleting/reinstalling the app. Where should I troubleshoot next?

I have also tried:

  • rebooting the fiber gateway
  • rebooting the router
  • turning UPNP off then back on
  • setting up manual port forwarding in the router
  • restarting the phone

Here’s the IP passthrough configuration. DHCP for the LAN is handled on the router.

Hi @Andy_Spinks ,

Thanks for the report! I’ve activated diagnostics for your account and I noticed you are getting the same error as the users above, so I have merged your report here. Please see my message from above, thanks!

1 Like

Hi, I have the same issue

Roon Core on NUC Intel
Rooter Bitdefender Box 2

Made the port forwarding in the Router for Roon Core

Hey @noris et al., I think I managed to fix ARC syncing for my library.

Here’s the short version of what I did:

  1. Restored a backup of my database from about a month ago and re-lauched.
  2. Gave it 30 minutes or so for Roon to update the database to 2.0 format, resync Tidal, and generally settle out.
  3. Went into Settings > Setup and gave the restored core a slightly different name.
  4. Deleted the ARC app from my phone and re-installed.
  5. Logged in to ARC and made sure to choose the newly-renamed core.

The Long Version:

Based on @Derek_Coleman’s investigative work above, I thought it was probably an issue with the database. I initially tried restoring a backup from 2-3 days ago, but this didn’t fix it.

Next, I tried creating a new, empty roon database (using a different installation of roon) and setting up ARC on it, and the iphone app was able to sync with the new database!

At that point, I remembered that a week or so ago I was having a problems with the iPhone app crashing, and the fix ended up being to clear the image cache:
iPhone App crashing repeatedly - Support - Roon Labs Community

So at that point I tried restoring a backup from a few days before I cleared the image cache to fix the app issue. That version of the database wouldn’t sync, so I cleared the image cache and tried again, but still no sync.

By this point, I had realized a significant side effect from all my experimentation: All these different versions of the database had the same core name, and they seemed to stay “visible” to the Roon apps even after I though I had killed them. :zombie: I was able to connect to the empty one and rename it, so that eliminated one duplicate.

Next I restored a database backup from about 6 weeks ago, before the problems with the iphone app started happening. (Not a big deal, because I have not been making significant changes to my roon library for years–mostly because it has not been available to use outside my home :wink:). It took a good while after the database restoration for it to become usable, maybe 5-10 minutes. Once I could connect to it, I went to Settings > Setup and gave it a new name to distinguish it from the other “zombie cores” I had spawned. At some point in there I also rebooted the core pc to try to flush out some of those zombies.

With my restored and renamed database up and available, I deleted the Roon ARC app, settings, and data from my phone, then reinstalled and tried again. Boom! That fixed it. (Although it did take me a minute to get my Roon Remote apps connected to the new core database.

P.S. Here’s where I learned that troubleshooting process with empty/restored databases:

1 Like

I have the same problem. Tried both with manual NAT and through HAProxy on the firewall. Same symptom. Roon server tells me that
“Your Roon Core was automatically configured and has been confirmed to be securely accessible by Roon ARC.”

When connecting with my iPhone with the Roon ARC app, it logs in ok, begins syncing and then gives the error: “Something went wrong while syncing to your Roon Core.”

No errors in Roon Core:

09/22 02:26:37 Info: [mobile] GOT HTTP API /hello
09/22 02:26:37 Trace: [mobile] Got Hello Request body={“coreId”:“xxxxxxx-62a7-4e1d-a362-xxxxxxxxxxx”}
09/22 02:26:42 Info: [mobile] GOT HTTP API /hello
09/22 02:26:42 Trace: [mobile] Got Hello Request body={“coreId”:“xxxxxxx-62a7-4e1d-a362-xxxxxxxxxxx”}
09/22 02:26:47 Info: [stats] 28028mb Virtual, 2808mb Physical, 1001mb Managed, 355 Handles, 93 Threads
09/22 02:27:01 Info: [mobile] GOT HTTP API /hello
09/22 02:27:01 Trace: [mobile] Got Hello Request body={“coreId”:“xxxxxxx-62a7-4e1d-a362-xxxxxxxxxxx”}
09/22 02:27:02 Info: [stats] 28028mb Virtual, 2808mb Physical, 1024mb Managed, 355 Handles, 91 Threads
09/22 02:27:03 Info: [mobile] GOT HTTP API /sync
09/22 02:27:03 Trace: [library/mobilesync] sync, request token=, apiversion=1
09/22 02:27:03 Trace: [library/mobilesync] cleaning up files that predate 9:da5f73aedf924cd48649f2e8ab884ad9:0
09/22 02:27:03 Trace: [library/mobilesync] no clientstate for this token, starting from scratch
09/22 02:27:03 Trace: [library/mobilesync] syncing profiles…
09/22 02:27:03 Trace: [library/mobilesync] 1 added, 0 updated, 0 removed
09/22 02:27:03 Trace: [library/mobilesync] syncing markers+metadata…
09/22 02:27:03 Trace: [library/mobilesync] 143254 added, 0 removed
09/22 02:27:03 Trace: [library/mobilesync] truncated to 50000 added, 0 removed
09/22 02:27:03 Trace: [library/mobilesync] syncing album ratings…
09/22 02:27:03 Trace: [library/mobilesync] 1 updated
09/22 02:27:03 Trace: [library/mobilesync] 2 updated
09/22 02:27:03 Trace: [library/mobilesync] 3 updated
09/22 02:27:03 Trace: [library/mobilesync] 4 updated
09/22 02:27:03 Trace: [library/mobilesync] 5 updated
09/22 02:27:03 Trace: [library/mobilesync] 6 updated
09/22 02:27:03 Trace: [library/mobilesync] 7 updated
09/22 02:27:03 Trace: [library/mobilesync] 8 updated
09/22 02:27:03 Trace: [library/mobilesync] 9 updated
09/22 02:27:03 Trace: [library/mobilesync] 10 updated
09/22 02:27:03 Trace: [library/mobilesync] syncing playlists…
09/22 02:27:03 Trace: [library/mobilesync] 16 added, 0 updated, 0 removed
09/22 02:27:03 Trace: [library/mobilesync] syncing tags…
09/22 02:27:03 Trace: [library/mobilesync] 10 added, 0 updated, 0 removed
09/22 02:27:03 Trace: [library/mobilesync] syncing recents…
09/22 02:27:03 Trace: [library/mobilesync] 500 added
09/22 02:27:03 Trace: [library/mobilesync] 0 removed
09/22 02:27:03 Trace: [library/mobilesync] syncing locations…
09/22 02:27:03 Trace: [library/mobilesync] 5 added, 0 updated, 0 removed
09/22 02:27:03 Trace: [library/mobilesync] synced changes, incrementing 9:da5f73aedf924cd48649f2e8ab884ad9:0 to 9:da5f73aedf924cd48649f2e8ab884ad9:1
09/22 02:27:04 Trace: [library/mobilesync] sync completed in 711ms, response is 10134781 bytes

hi, I made all the 5 steps and no result, you were lucky
Hope Roon guys will help

I can’t get Roon 2.0 to do my initial sync with my Arc app. I have a UK BT smart hub router on which I have opened port 55000 and I am getting a purple Ready to go tick. My Roon app connects fine but not my Arc app

Restart the router and you’re core and try are are app again.