Cannot connect to Synology NAS DS 1517+

I cannot get a network share connection with my Synology NAS via smb to use the media folder there as my library

I can connect to the Synology NAS using Finder and smb:// which is the IP address for the NAS and then it prompts me to mount the Media folder just fine

But when I use the same address in the Roon app it fails to connect. I have added username and password and workgroup to no effect. I have tried to use the filename path rather than the IP address to no avail.

Plex will run media off this same NAS with no issues, but I can’t get Roon to see it, Any thoughts?

Mac Pro running High Sierra 10.13.3
Synology 1517+ 20TB
Connection via hardwire for both


Try without the workgroup field filled

Hey @James_Hanson — Thank you for your report!

To start, may I kindly ask that you provide some more detail regarding your network setup? What kind of router are you using? Are there any switches involved and if so, what kind?

May I also ask that you please try the following:

  • While it may be elementary, try rebooting your NAS, Core, and networking hardware and try again.
  • If there are any special characters in your password for the Synology, try changing the password to exclude any special characters and try again with the new password.


I have used every different combination or workgroup, username & password, or lack if any of them I can think of

Reset everything, changed password to letters only
Can still connect via Finder and smb:// and mount media folder
but no dice with Roon App

Network is a Verizon router that passes to a Luxul 3100 Wireless access point
Mac Pro and Synology NAS are connected via hardwire direct out from the Verizon router to a Cat 5E wiring in the house. Each is also connected to a Linksys switch in different rooms.

Thanks for the update @James_Hanson!

Is the Linksys switch a managed switch?.

I usually like to mention that we’ve tracked a number of issues to in the past to managed switches(examples: here, here, and here).

If it is, would recommend enabling flow control on the switch, as we have seen that settings resolve a number of issues for other users in the past.

The simplest way to confirm whether the switch (managed or not) is contributing to these symptoms would be to temporarily test with the switch removed from your network. Whether things improve or not, the results of that test would be a great data point.


No controls on the switches just 5 port boxes

Hey @James_Hanson,

Thanks for the clarification. In our KB Article about this there is a link to a post that details some additional setup you should do when using a Mac as your Core with a NAS. Can you give that a try and see if that allow you to connect?


That seems to be an older version of the Synology control software. The new version doesn’t reference Windows File Service. Here are screencaps of what it does show


Can you share a screenshot of the error you get when you are adding the folder in Roon?


I was testing the smb connection to my Synology NAS with the smb-settings shown in your screenshot. It worked here. This is a screenshot of the entered values:

Did you also add the shared folder name in the “Network Share Location” (in the screenshot above it is “/music” right after the IP address)? This shared folder has to be entered correctly regarding case-sensivity. (In my case “smb://” does not work).

I was just wondering, as it is not explicitly mentioned in the previous posts, is your iMac the core device or just a remote for Roon?


You win the prize. No one else put the folder name after the IP and it sent me right in. Muchas Gracias, now I can see what this thing actually does.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.