Cannot delete album from Roon

Was this issue resolved? I’m experiencing the same behavior here with one album.

Hi Dylan,

Try restarting your Roon Core software and see if the album is gone.

Cheers, Greg

Hey Greg - I did try that several times (server and client) with no luck.

Ok, let’s alert @support.

Cheers, Greg

Hi @Dylan_Eddy ---- Thank you for the report and sharing your feedback with us, the insight is appreciated!

Moving forward, to help us better understand what could be causing this behavior in your setup, may I very kindly ask you to please provide the following information:

  • A brief but accurate description of your current setup, using this link as a guide.

  • The album in question, is this locally stored or an album added to your library from TIDAL?

  • When you do try to delete the mentioned content are you presented with a warning or error message in the application?


Hey Eric - Here ya go:


  • I’m running the latest versions of Roon/Core (1.3 (build 269, 64bit)

  • Roon: macOS High Sierra 10.13 on a 27" iMac 4GHz i7 with 32GB RAM and 1TB SSD

  • Core: macOS Sierra 10.12.6 on a Mac mini 2.3GHz i7 with 16GB RAM and 1TB SSD

  • My music is stored on a Synology RS815+ NAS running DSM 6.1.3-25253 Update 8


  • Router: Pakedge RK-1 with latest firmware
  • Managed Switches: Pakedge SX-24 POE with latest firmware
  • Everything is wired over cat5e/cat6


  • Ripped from double CD, lossless FLAC.

Interestingly, Roon wouldn’t pickup the first track on the second disc which is why I tried to delete in the first place.

  • When attempting to delete I get a “File not found” error next to each track.

Thanks for the follow up and taking the time to answer my questions, @Dylan_Eddy! Very appreciated :sunglasses:

Moving forward, can you please provide me with a screenshot of your storage tab so I can see how the synology is being accessed via the application, and can you also confirm that you have no issues “writing” to the NAS from the OS.


Here ya go:

Thanks @Dylan_Eddy for supplying the requested screenshot, very appreciated!

Iterating on the second part of my previous post a bit (i.e “…also confirm that you have no issues “writing” to the NAS …”). Can you please confirm that you are able to create a “new folder” on the NAS, both from the OS level and from within Roon.


Yup, all works as it should. I’m able to create folders from the OS and Roon. Initially I was able to delete the album using Roon but it still lingers in the Roon library/interface even though it doesn’t exist on the NAS.

Great! Thank you for confirming that for me @Dylan_Eddy!

Moving forward, I just enabled some extra diagnostics on your account and what this means is, when you start Roon again (on the MacMini core) it should submit a report to our servers with logs so we can have a closer look into this behavior. With this in mind however, I would like you to please try to “delete” album once more and note the time when the error occurs.


Time: 11:54AM

Interestingly, this time the album deleted without an issue. But when re-adding the double album back to the library, only the first album is being recognized. I’ve rescanned the library several times but the second album isn’t being added.

… weird.

Hi @Dylan_Eddy ---- Thank you for touching base with me, confirming that we received the mentioned report.

This is indeed a very interesting observation. This time around the album deleted BUT upon re-import the second CD didn’t show up, correct? Based on this latest observation it feels like something is going on with the communication between your NAS and Roon.

If possible, I would like to have run a small test for me, just to see how things behave with the NAS “removed” from the mix. Can you try adding a “test watch” folder to Roon, and this time try to import the album from the internal storage on the MacMini.


That worked. Guess thats good news. Now I need to sort out why its not working with my NAS. I’ve never had a problem as of yet and I’ve got several thousand albums.

Is there anything I should be investigating?

Hi @Dylan_Eddy ---- Thank you for touching base with me and sharing the results of the proposed test, very appreciated!

Moving forward, based on this observation would it be possible for you try testing with the NAS mounted directly to the router, thus bypassing the mentioned managed switch? Not saying that the switch is the cause here, but we have seen issues with these types of devices crop up with these devices in the past ( Example: #1, #2, #3 #4).

If this test does happen to yield a positive result, I would recommend enabling flow control on the switch, as we have seen it help other users.

Furthermore, can you please verify that jumbo frames are not being used with the NAS.