Cannot favorite (click the heart)[Ticket in]

@John_V ---- Thank you for the post and sharing this very detailed report with me. Your diligence and attention to detail are very appreciated :clap::+1::microscope:

Moving forward, upon seeing your post this morning I have been trying to enable diagnostics on your account so I can have our team take a closer look at the mentioned time frames in your report. I have now tried re-enabling this feature 3 times now and the report has yet to make it our servers :thinking:

In light of the above and in the interest of expediting this process to the best of my ability, may I very kindly ask you to please use the instructions found here to send us a set of logs from your core machine and the remote this task was performed on. From your profile I know you are using Rock so I’d like to see the logs from the device you were using to control the core from as well.


[Downloaded - Removed by Support]
[Downloaded - Removed by Support]

I think this should do it. The control is a MBP.

Thank you so much @John_V! Confirming that the materials have been received!


Here’s a clue: it happened to me yesterday. It was a Tidal track. I tried to click the heart to favorite it from the now playing bar at the bottom and on the main now playing screen. Flashed as solid and then went back to heart outline.

I was using a Roon remote on windows. I closed that remote and reopened it, and the track had a solid heart. It was already favorited even though it didn’t show until I closed and reopened the remote app.

So, it may be a display issue, not a DB one.

From this thread, I’m not sure whether this is intentional behavior or a bug, but here’s a screencast of what happens when I try to star a track that’s not in my library, from either the queue view or the now playing bar: (will be visible for the next week).

Here’s a written description of the current behavior of the star icon on a…

  • Queued track: shows dropdown with 2 choices, “Play from here” and “Remove”
  • Currently playing track: goes to artist page

I can’t imagine this is intentional, particularly the track behavior where a totally unrelated dropdown menu appears. In both cases, I’d rather see no icon if this is actually not doable from this screen (and there’s a great reason why it couldn’t also add it to my library or prompt me about doing the same).

Thanks for the report @t812 but this actually looks right to me.

Just to reiterate, in Roon, “Favorites” means the content in your library you’ve marked as such. Once you favorite a track (or album, or artist, etc) you can easily find this content again later by pressing the Favorite button at the top of the various browsers, which will filter your collection down to just your favorites.

Not everything you play in Roon is actually in your library – you can also play content from TIDAL that’s not in your library. Because favorites are a subset of your library, non-library content can’t be marked as a favorite. If it was, it wouldn’t show up when you browse your favorite albums, artists, tracks, etc.

I would like to make this experience clearer since it’s clearly confusing people, but the issue in this thread is that content which should be “favoritable” doesn’t react properly in the UI – you click the heart and it flashes, but the heart doesn’t “fill in”.

In the video posted above, the hearts are greyed out, because the content is not in your library.

It’s clear the graphical treatment here could be better, but you can see the difference playing content from your library:

Versus what’s shown in your video @t812:

Love that Chicano Batman btw :wink:

Anyway. we’ll get the treatment cleaned up, it’s not as clear as I’d like.

Also thanks for the detailed information @John_V – I’m going to have our QA team walk through these steps again and see if we can finally pin this one down. As mentioned before, we’ve never been able to reproduce this issue at will, but I’m sure we can fix it once we know how to make it happen.

Thanks for your patience everyone!

@mike thanks for clearing that up, and for supporting Chicano Batman :wink:

If you’d like me to make a separate Discourse topic with some thoughts how I’d want the UI to communicate the current behavior[1], let me know. The gist is that I expect a heart to do one thing and one thing only (possibly with a confirmation dialog if it may have unintended consequences). If that one action isn’t possible, don’t show the icon or make it more obviously disabled (I couldn’t tell that it was disabled), and make clicking it do nothing. Bonus for a tooltip explaining why it’s disabled on hover.

[1]: I don’t love the current behavior (specifically that “non-library content can’t be marked as a favorite” - if I try to do so, add it to my library and favorite it, perhaps with a confirmation) but that’s a bigger discussion.



Quite often, when I click the heart to add a Tidal track (one already in my library) to my Roon favorites, the heart will light up, then turn back off. The track is actually being added to favorites, but the indicator won’t stay on. (Clicking the heart once adds it to favorites, but clicking it twice does Not ban the track.)

This is on iPhone, not sure if it also happens on other remotes.

Here’s a screen capture video of what I’m seeing. (Clicked the heart three times in Now Playing, then switched to album view to show it is being added to favorites,)!AphM1uAPWeuhl9gfCwVFhtFQNjnvKA

Tapping on the ‘heart’ icon to toggle it as a favorite has a glitch if you do it at the bottom of the screen (currently playing area) - it responds by filling in the icon then it becomes empty - as if it was toggled off.

Is that on a local or Tidal track?

There is a long-standing occasional issue with this area, which might be the same as you are outlining here

Have a read through and see if it is related

Yes, that is the same issue. You would think this would be easy to fix - since the track IS favorited - it’s just a UI feedback bug.

1 Like

Yes, this bug and the occasional “Add to Library” bug is annoying as well.

1 Like

Just for the records: The problem has been there since I started to use Roon almost a year ago. In the meantime I use Roon on daily basis and this bug starts to get really annoying.

I am mainly using my Android tablet as Roon Remote but I experienced this problem on my Windows PC as well.

I am experiencing exactly what @mike described in one of his earlier posts.

I am only working with local content as I don’t have a Tidal subscription.


@support I noticed this issue tonight. When I tried favoriting a track via the playback controls or queue the interface flashed for a second but the heart didn’t stay lit up. Track was actually favourited if I looked at the album details.

Favorting from the track list in album details view seems to work fine for me.

I did some research a while ago. Skip to the summary.

Not fixed, now years since noticed.


The problem still exists in 1.6 as far as I could see. The only interesting thing is that the problem appeared and disappeared without restarting the Roon Remote or the Roon Core. In earlier releases I always had to restart Roon Remote and the problem was gone for an unspecified time frame.

10 posts were split to a new topic: Cannot favorite TIDAL tracks that are not part of library

Closing this thread since the favorite button is no longer shown in the footer.