Can't add albums to library, “+” button and it keeps spinning [Ticket In]

Roon Core Machine

iMac 2011 i5, 32gb RAM.

Networking Gear & Setup Details

ASUS (the problem is not network-related)

Connected Audio Devices

Not relevant

Number of Tracks in Library


Description of Issue

This was working ok until the day before yesterday, can’t say if it’s related to any upgrade. Since yesterday I can’t add any album from Tidal to my library. I click the “+” button and it keeps spinning. Going back to Home, it doesn’t appear in the library, but curiously I can add the music to playlists. It’s really annoying but I even tried to clear the cache already, and already logged out and in again from Tidal. I tried with several albums already.

Hey @Jorge_Alberto_Araujo,

Thanks for taking the time to write in, and I’m sorry to hear you’re running into issues adding albums from Tidal to your Roon library.

Are you able to add the album directly from Tidal?

I see you’ve already tried logging out and logging back into your account, but I’d like to start troubleshooting by restarting your Roon Core and then checking to see if your recently added titles are in your library.

Please go to Settings>Services>Tidal>Edit>Logout
Restart your Core
Then repeat those steps and sign back into Tidal.

When in Settings, clicking the ‘Edit’ button for Tidal, are you able to share a screenshot of what the Tidal pop-up looks like?

I’ll monitor this thread for your reply :+1:


A post was split to a new topic: Can’t add Tidal albums to library since yesterday

Hi, Benjamin, I tried what you said:

  1. Yes, I can favorite the albums directly on Tidal.

  2. Logged out of Tidal, restarted roon (which I did by closing the app, waiting a few minutes and launching it up again – I’m on the core machine, of course), logged in again. Some albums I tried to add friday are on the library, but the problem persists: I’m still not able to add SOME albums, the button “add to library” inside the ellipsis is greyed out, and the “plus” button is clickable but does nothing (keeps spinning after click). I managed to add one, but not another. Other functions work well, I can play, add to playlists etc.

  3. Screenshot attached.

OBS: My roon app was recently updated, now running 1.8 build 952


1 Like

Hey @Jorge_Alberto_Araujo,

Thank you for letting me know, and for the information above. I am going to take this over to our QA team for further investigation.

In the meantime, we’ve just released a new Roon build (970) if you could please update and confirm the issue still persists after this, that would be helpful!

Thanks for your continued patience here :pray:

1 Like

Hi, I might add some interesting info to this problem. I just updated the core as you suggested, and I noticed something: I have an album already in my library that’s in my queue (John Coltrane, Ballads, from Tidal). When it’s playing and I click on the album cover, it still shows me the “+” sign to add it to my library (and it’s clickable and spins), but when I click on the ellipsis the “add to library” is greyed out. Also, the heart doesn’t appear for the album or for the individual tracks. But if I go through the menus My Library → Albums and find this specific album, I click it and then the heart icons are all there, but it doesn’t show the music that’s playing (that moving EQ icon beside the song).

It seems there is something broken between these instances, when I click on the album from the queue the behavior is one, and from the library the behavior is another.

On the other hand, I just managed to add “Stranger in Town” by Paul Desmond without any issues.

1 Like

Hey @Jorge_Alberto_Araujo,

Thanks for the additional information. Are you able to provide more specific details about your current network setup? Is your core connected via ethernet or wifi? We strongly recommend that your core be hardwired to your network.

Also, we sync with Tidal on a timer, I’m wondering if there might be a delay with how frequently this is happening. Going back to Settings>Services> Edit (Tidal) you will see the ‘Last Library Sync’ where you can also manually sync your library now. When was the sync time on your core? If you click this, do you still run into similar patterns?

Yes, it’s connected via an ethernet cable, it’s a good connection (400MB+).

I checked, it had just synced, and still the problem persists. I attached two pictures. You can see the time of the sync and, after that, an album that already was previously in my library, still with the “+” icon.

Hey @Jorge_Alberto_Araujo,

Thanks for the update. Our team would next like to dig into the backend of things to take a deeper look.

If possible, could you get it into the state where you click on + and it starts spinning, and note the local time? From there, our team can take a look at logs to see what might be happening.

Thanks, Jorge :pray:

Just Roon’s documented standard behavior. The tracks in your queue are still the ones from Tidal that you added previously, not the ones from your library. Read also:

Additionally, if you want to vote for a change in behavior:


Just clicked, it’s spinning. Clicked at 7:33 AM GMT -3 (São Paulo, Brasil). Screenshot attached.

It’s not just that, it’s an inconsistency. Even if the track was added to the playlist before, and now the album is in my library it should either not show the “+” icon (and show the heart one) or give some feedback if you click to add an album that’s already on your library. Notice that, if you click on the ellipsis, the “add to library” option is greyed out! The way it is, it’s all “manual” and a “guessing game” (if it is by design as you suggested). What doesn’t make sense to me is having an “+” that keeps spinning, says the album was (just) added, and doesn’t do anything really. I honestly can’t see how it does so on purpose. But I’ll follow your suggestion and vote for the feature you linked to.

1 Like

This has happened to me many times, and it is quite as you describe the situation: inconsistent and annoying. There are other user interface components where in-library albums are not consistently marked as such. I have opened support threads about this and have given up expecting any better .


I have had this many times myself and I agree it is beyond annoying and IMHO totally nonsensical.
I hope someday it will be looked at .


Thank you for the timestamp @Jorge_Alberto_Araujo,

Our team was able to dig into the logs and will be discussing possible reasons for the constant ‘+’ spinning on their next call.

I will follow up as soon as we have more information to share!

1 Like


As a next step, can you try to add an album from an artist you’ve never listened to before and see if that works, or if you run into the same issue?

I just did it with Usher’s “Confessions”. I clicked the “+” button, it added the album and the button became the heart. I then removed it from the library, no issues that I could notice.

1 Like

A post was split to a new topic: Albums not being recognized

Hey @Jorge_Alberto_Araujo,

Thank you for confirming this. We can now confirm that this issue is similar to an issue we are aware of and are working on a fix. Essentially, Roon may be getting confused about which album to access when there could be two copies of the album available.

While I don’t have a specific timeline I’m able to share with you, the minute I get an update, you will be the first to know :+1:

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.