"Discography Unavailable" error [resolved, networking/DNS issues]

This is a truly annoying bug. I had hoped it was fixed in this new update.
You wrote that people were given the possibility to check if it worked. So, why did you not ask the users that actually wrote about the problem here in support? That would have actually made a lot of sense.
Don’t you think so?

1 Like

Hey @Squeezemenicely – that’s actually a different issue, although I agree it’s annoying.

The bug we fixed was that Roon would load the page and the Discography tab wouldn’t be present. In your screenshot Roon actually isn’t able to load the page at all, whether it’s due to a server issue or some connectivity problems in your setup.

@support can help figure out the issue, but for what it’s worth these artists’ Discography tabs are loading properly for me:

I’d recommend checking your network and restarting your Core – if you’re still having an issue, the support team can definitely help.

Thanks and sorry for the frustration here.

I just checked, it’s loading… I checked the server directly too, it’s working there.

This is a networking issue or something is wedged up locally. Mike’s suggestion of restarting things is a good idea.

Are both your Core and remote updated?

Hi, I really forget which thread it was - either this one or the other about Discography not showing. There were a few users with the same issue. There is as some other user had stated a quick fix.
Change the SORT BY in Discography - from Title to Popularity - or the other way around - and the albums appear.

The bug was acknowledged. Guess, it was not fixed and another issue has been.
But as you see on my screenshots, the problem is still there

1 Like

Yes all is updated and I have restarted both twice. The bug came with a later update of 1.8 - don’t remember which one

1 Like



This is the thread - or atleast one of them, I am not alone

scroll down… you will see albums in your library below the tracks.

Yes, I know that. Thanks. But when I select Discography - which shows ALL recordings - mine and Qobus - or should show them, I get Unavailable as in the above screenshot. This all worked in the initial few 1.8 releases. Does not anymore

I think @support needs to pull your logs and see what’s up … either you have a corrupt db or something is funny with the network.

paging @support

This is what it should look like and it does after selecting and changing SORT BY

it works when sorting but not when not sorting? what if you go back to sorted by release date?

Once it was changed, it stays ok. But the same will happen with every other artist.

Read the second post in this thread by @Alexander_Bashlaev
That is where I picked up on the idea of changing the sort option. This guy has the same problem. We posted this in support 15 days ago.

That’s just cache… this sounds like a networking issue.

@support, pull some logs…

Well, how come it has been fine ever since Discography was introduced and broke in 778?
as @Alexander_Bashlaev also states in teh support issue?

I have not changed any Hardware in my network - it is all the same stuff, no setup changed.

Hope Logs will find the answer for all the users with this problem.

Just got your logs… your logs are full of network timeouts… queries to our services are not coming back reliably.

We are seeing no slowness on our server side infrastructure, and queries for me are very fast from within Roon and also fast when I run your queries by hand. Something is misbehaving on your local network or your ISP.

To get to the bottom of this, we need to know much more information about your location, ISP, network setup, Roon setup, etc…

Btw, some of your queries are very fast and what we’d expect, so this is not some universal problem at your location.

Something else is happening on your system… the NTP timestamps we see are way off too.

1 Like

That also explains the slowness.

I am in Berlin, germany
Fritz 7590 router
DSL 250 1&1 (Telekom)
Roon core is on a Win 10 Nuc

antivirus? firewall? anything beyond pure basics? wifi? ethernet? good cables? how’s browsing the internet from that win10 nuc? anything in the windows event viewer/system log? how does the time on your pc compare to reality?

Avira Antivirus
connected through Ethernet with good cable
browsing Internet and downloading - all functions very fast and responsive.
Time is exactly same as in reality.
Absolutely no issues with the Nuc. Have been happily running Roon Core on it , since I bought my lifetime sub.

Also I have another NUC and sub running at a different location with an entirely different setup, running ROCK - and the issue with the Discography is exactly the same. This is not even in teh same building, different ISP everything.

@support, can you pull logs from that ROCK? It’ll be a much simpler issue to resolve over there since ROCK has diagnostics tools to help evaluate network connectivity.