Issue: "Too Many Failures. Stopping Playback"

Roon Core Machine

SonicTransporter v2.8

Networking Gear & Setup Details

NetGear AC4000, connected directly through ethernet

Connected Audio Devices

ultraRendu v2.8 (ethernet)
SMSL M300 MKII Audio AK4497 Balanced (USB)
McIntosh C50 (primary system; USB)
Yamaha TSR 5810 (secondary system; AirPlay via wifi)

Number of Tracks in Library


Description of Issue

Since 2 days ago I started receiving this message: “Playback was interrupted because a track failed to playback.” And then “Too many failures. Stopping Playback”. This happens with multiple (although not all) tracks, and with playlists, where the message cascades across multiple tracks from different albums. For those tracks, I then see a ‘Corrupt’ tag in red next to the title. Qobuz continues to work well and is the only reliable source for now.

Hey Luca,

It seems that you are trying to play some local files which is identified as corrupted by Roon, can you try to locate the file and play with another player, for example apple music app or any player on pc, to see if the file is really corrupted? thx

Hi Yaohan

Thanks for the reply. I am actually unable to access anything on the SonicOrbiter right now. I can see the storage folder, but it seems empty when accessing it from Windows. What could be the cause of it? Roon can definitely still see the database

I have rebooted the SonicOrbiter and can now access all files and folder on my computer. I can also play all tracks. However Roon cannot see any of the files - all tracks and albums are currently tagged as ‘unavailable’ and ‘corrupt’. If I go to the Album menu, I only see 10 albums from Qobuz, and none of the 1,500+ from my library.

Anything I can do to restore Roon functionalities?

reading your description, i would say the you might have a malfunctioning storage where your library is. if it is a internal storage of SonicOrbiter, then you will need to contact them for further assistance.

I don’t think so. I can access the files and folders from my computer, and can play the files. It’s Roon that cannot access anything anymore

Hey Luca,

The mystery here would be why Roon doesn’t have access to the files your computer does. as the file is in sonicorbiter, i think they have a better insight in how to grant access to Roon.

Hello Luca,

There are some recent posts suggesting a similar problem - you may want to try the steps suggested by @Arlen, here and here, which appears to have worked for some other users.

Edit: if not, you may have to go the ‘long road’ - uninstalling and reinstalling the Roon server software from your SonicTransporter, and then (probably) having to reload a recent backup - if you have one - to get back to a state as close as possible to where it all went pear-shaped. It’s what I resorted to before noting these posts. So it seems worth trying the shortcut first - toggling local playback twice.

Hi ToneDeaf

Thanks a lot for the tips. I will definitely try to follow them. I am not sure of what’s going on - I tried rebooting the Core, and had partial success in that some of the files that were unreadable became readable, but then after some time they became unreadable again. Which in my mind further confirms that this is a Roon issue, as the tracks are there, I can access and play them from a computer, and Roon can also do that - at times - so they cannot be corrupt.

When you say to reload a backup, is that a metadata backup, or the actual tracks? Can I reinstall Roon without deleting all tracks from the storage on the SonicOrbiter?



A post was split to a new topic: ESXi server issue

(Definitely first try toggling local playback on the sonicTransporter - if it works it is by far the simplest way of getting things going again!)

I meant a Roon database backup, not the actual tracks.
And yes, if needed you can reinstall Roon from the software manager in the web interface, assuming you can access it normally. It does not affect your music files /tracks, but you will end up with a fresh Server instance - hence the need to restore a database backup if you don’t want to start from scratch.

Am I correct in thinking that you can still access your music files / tracks outside Roon? It sounds like you still can, which was the same for me - the lack of access was Roon-specific, everything else about the sonicTransporter and the installed software seemed to be functioning normally, including web interface access and remote accesss to files on attached disks. If your symptoms are different the solution may have to be different too. (The only signs I had of malfunction were 1) Roon remotes not discovering the server on the sonicTransporter ; and 2) Roon Server logs not updating, even after Roon Server restarts and SonicTransporter reboots)

All else failing, Andrew Gillis from SGC should be able to help with diagnosis.

Hopefully you get it sorted quickly. :crossed_fingers:

Thanks ToneDeaf - you are correct, I can still see and play my tracks using a PC, but they are unavailable through Roon. While trying to fiddle with it, I found that sometimes Roon can see the tracks, and sometimes it can’t, and I don’t know what’s causing this. It is quite a pain, and it looks like it’s a software issue.

I have tried with the local playback protocol, but it hasn’t worked for me. In fact I think it made things worse, as I now have 0 tracks on many playlists, while earlier on they had all tracks, and many of them were tagged as corrupt or unavailable.

I think I might try to reinstall Roon - which is obviously a big hassle. Any idea of how I can export my playlists if I do that, or whether I am going to lose them?

Sorry to hear that Luca.

It seems you have Roon Server running currently, without having needed to re-instal the software, but it is not in a stable state. Not clear to me as just a fellow sonicTransporter user if it is the Roon Server instance, the Roon database or something else with the sonicTransporter and attached media that causes the behaviour you see. It starts to look different from my situation, where Roon Server was not presenting itself at all, despite the sonicTransporter interface indicating it was running.

Roon and SGC support (the latter via their support forum where you can raise a ticket if required) may need to have a closer look and advice on specific next steps for your situation. As you system is still running and accessible, Roon may well ask for your server logs and/or SGC may be able to access remotely to troubleshoot, as they have done for me and others in the past.

As to your question on being able to reinstate everything - including your playlists - after reinstalling Roon server: Roon support here should be able to advice more authoritively for your situation. For me this was the case - after removing and reinstalling the server software, it presented itself as a ‘new’ instance and after logging in I could access and restore a database backup without issue. So if you have a recent uncorrupted backup available and accessible, I would imagine you could be in business as soon as Roon Server and the Sonicorbiter are behaving.

Good luck!

ps - as a stop-gap to keep the music running perhaps worth seeing if you can run Roon Server on a different machine, Mac, PC, whatever in the mean time. You could point it at the same watched folders or take a copy. Or even try to use/restore a Roon database from a sonicTransporter backup if you can access one. If similar issues appear, at least it may help to narrow down what’s going on. If not, you have access to your music.

Thanks ToneDeaf - hugely helpful, as always. I have in the meantime been in touch with Andrew Gillis at SGC and upon verification, it looks like there might be a hardware issue. I will follow up with him.

Do you know of any way to export/save playlists?

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.