Issue with display (favorite, tags, tracks multiplication, mouse acting like an eraser on Surface remote)

Core Machine (Operating system/System info/Roon build number)

Windows 10 64 bits
Roon version 1.7 (build 528)
Intel Core i9-9900K CPU @ 3.60 Ghz
32Go RAM
Motherboard Maximus XI Hero
Roon core on C drive which is raid 1 array of two SSD 970 EVO NVMe M.2 of 1To
Library on internal HDD Seagate Ironwolf ST4000VN008 4To
Graphic card Nvidia GeForce 970

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Lumin T2 and Core machine connected to Netgear GS105 switch.
The switch Netgear GS105 is itself connected to an Orbi mesh Netgear system (used only as switch, not router) to dispatch for wifi connected end points. Remotes will be connected in wifi to the Orbi.
The Orbi mesh Netgear is itself connected to the router (Livebox Pro by ISP Orange)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Roon Core optical digital output to stereo system
Lumin T2 via ethernet
2 Chromecast Ultra by ethernet
4 Chromecast audio by wifi
2 Google Mini by wifi

Description Of Issue

On remote, whether Android or ios, when I am trying to change the favorite status of a track and clicking the heart. It is flickering but going back to initial status.

When checking on Core or after killing the app and restarting, the change is appearing.

It is doing also the same with tag. I am tagging a track but the tag doesn’t appear near the track name as it should.

I have seen also an issue even on Core not refreshing to the new favorite status whilst opening the remote on my Surface Book2 the change was properly displayed.

It looks like a problem of refresh and synchronization of displays between remotes and Core.

When making a change in Core, the display has no issue on Core (no flicker and changes are appearing directly on display), but it doesn’t refresh on remotes when the screen is already at the same spot of the library.

When coming from a different spot of the library in the remote then it will display properly the changes directly.

Have you rebooted everything not just the remote?

Hi ged_hickman1,

I thought I had, but did it (again?) and now seems to be resolved…

IT Crowd strikes again!

Would be great to have Roon more stable in itself!

Great thanks!

Okay so now display doesn’t refresh when deleting tracks from remote or on Core (connected via remote desktop).

At first there is no change after deleting the tracks on disc4. When I checked “view file info” it cannot find the file.

Then I moved to disc5 and return to disc4. Deleted tracks are shown as unavailable as shown below.

Then I moved to another completly different album and go back to that album. Then the display is properly refreshed as below.

Please don’t tell me that I need to restart Roon each time because it is happening all the time now!

I insisted in trying to select my tracks…bad luck not only now the tracks don’t disapear but now they are multiplied (deleted and non deleted ones).

I am still trying to select my library and Roon still have weird display refresh rate like for instance again multiplication of tracks whilst other tracks of the album have been just deleted…

This topic will close 2 days after the last reply.

This issue is not resolved…

Thanks

Hello @mevh and thank you for the information. I tested this out on my end and I couldn’t reproduce the same result. Are you experiencing this issue with any remote that you use? I’d like to try using a different remote next and see if you have the same result. Let me know once you test that and we’ll move to the next step!

Hi @nuwriy, I am having problems with remotes and directly on Core as described above.

May be the issue is that my library is just too big for Roon, currently with 95919 tracks?

One of the reason I am deleting tracks rather than just hiding them…

May I suggest you test behaviour of Roon with very large number of tracks?

BR

Hey @mevh, thanks for your patience on this one and the good info! We test a variety of core machines and database sizes to ensure things run smoothly. We haven’t been able to reproduce the behavior you’re experiencing and having more information on the issue would help.

What I’m looking for is to determine whether ANY remote connected to that core has this issue. Could you please try a different remote and let me know?

Hey @nuwriy,

I have been working today on selecting on a single disc album.

I have had next to me: the Core PC, and three remotes: Android Redmi Note 5, ios iphone 8 and windows 10 Surface Book2.

Nothing happening on neither ios nor Android remote. But then there was a weird display behaviour on windows 10 remote ONLY on my Surface Book2 (not the Core which is on another PC).

After a while of shifting from one remote to the other will following actions:

  • favorite move to forbidden (so toggle from not favorite to favorite to forbidden)
  • tag set at track level either to tag “Track selected” or to “NOT selected”

The testing was done by doing one action in sequence on each remote and for instance changing track on the Core, so that all remotes and Core would be used for the selection work.

The Windows 10 Surface Book2 remote failed in displaying first a tag implemented.

Below tag “NOT Selected” implemented on Calypso track on the Surface appearing on the iphone remote (16th April 12h29 CET French Time)

But not on the Surface remote whilst it was implemented here. Note that some of the doted lines have disapeared also and also the playing moving bars next to the track World Before Columbus (16th April 12h29)

At this point of display failure, the mouse of the Surface remote is acting as an eraser but not on everything on the display: (16th April 12h32)

I have shot a small video where you can see the mouse erasing some of the display but I cannot upload here.

Shutting down the Surface Roon remote and reopening is resolving the display issue.

I have stopped the experiment at that point for now.

I have further tried to delete tracks.

This can only be done from the Core or from the Windows 10 Surface Book2 remote. It cannot be done from Android or ios remote.

I have removed one track from Core (16th April 17h09 CET French time) and one track from Surface remote (16th April 17h12 CET French time) .

I thought nothing had happened bad so decided to remove all the non selected tracks from Surface remote point. Then I noticed the last track was duplicated artificially on display on Surface remote. (16th April 17h14 CET French time)

I went to check on the Core and see the same artefact: (16th April 17h15 CET French time)

I cannot be sure if it was the deletion operation on Core or remote Surface that trigered the issue that specific time.

I have checked the actual album folder. Tracks 3 and 5 have been well deleted. Track Women on the Tier is only one file as always, so there is only a display issue again. (16th April 17h23 CET French time)

When stopping and restarting Roon Core the display on Roon Core is correct again: (16th April 19h02 CET French time)

There was also a tag display issue on the track “Caramel”.

Here is before Roon Core restart: (16th April 18h58 CET French time)

And here is after Roon Core restart: (16th April 17h59 CET French time)

I have then stopped Roon Core then stopped and restarted the whole computer on which is the Core. I then deleted, from the Roon Core itself, all the tracks I did not wanted to keep from that Suzanne Vega album.

Then I have again weird display of some of the tracks: (16th April 19h21 CET French time)

Then I am closing and restarting the Roon Core software and the display is as it should be: (16th April 19h29 CET French time)

Hi @mevh,
Thanks for the detailed report! I’d like to get this in front of our QA team for further testing in our QA labs. To make sure that the team has everything they need to troubleshoot this, I’m hoping that we enable diagnostics on your Core machine.

First, I was hoping you could reproduce the issue and make a note of when you deleted the track in your local time zone as well as the name of the track (and which album it’s from) that you’re trying to delete. Respond here with that information and we’ll enable diagnostics for this incident.

Hi @nuwriy,

I am living in France so all time are CET French time.

The screenshots for Mozart Serenade box set have date and time included as well as album references. For the others I will edit the post and put the date and time I took the picture or screenshot.

The next album is Miles Davis Amandla.

Then for yesterday Thursday 16th April post, it is Suzanne Vega Retrospective: The Best of Suzanne Vega.

I hope this will be enough for the reference points in the log.

Hi @nuwriy,

This other user seems to also have issues with multiples tracks displayed whilst only one file.

Hi @nuwriy,

I have done some further trials. I thought I would share both what went without issues and then what went wrong again. All images are screenshots with date and time. I have done plenty so that all tracks/album references are visible.

In this post here are two examples that went well with deleting tracks on the Core itself. I had only to identify again the Rory Gallagher album, but that is to be expected (sometime) in the way Roon seem to deal with identification. For these operations I had on purpose closed the Surface remote.

AND THEN

Hi @nuwriy,

After the above, I decided to work from Roon remote on my Surface Book2. I did not deleted tracks, just making selections (so means changing favorite status and tags). This was on Dua Lipa on Qobuz.

I had the mouse eraser effect as can be seen.

I have therefore decided to desinstall Roon on my Surface Book2 and reinstall. This is where I am now. I will report later if any changes in doing so. I will work mainly from the Surface Remote as I feel there is something wrong with it.

Hi @nuwriy,

After reinstalling the Roon remote on my Surface Book2, I have been listening mostly on either Lumin T2 or Sound Blaster end point and controled through Surface Roon remote.

I have selected tracks (favorite, tags) using the Surface remote.

I have then deleted tracks from Roon Core on Johnny Cash Out Among the Stars album and did not had any issue.

As said before I am aiming at sharing when it works and when it doesn’t, to help find out what is happening differently in the log hopefully.

All screenshots are hopefully self explanatory and including date and local time.

Hi @nuwriy,

I have now worked fully (selection (favorite, tags) and deletion) from Roon Surface Book2 remote.

I had no problem.

Same as above screenshots are all with time and date.

Hi @nuwriy,

I have pursued selecting on my Surface Book2. So sequence of favorite change, tags and then deleting tracks, then changing album tag. Identifying album if required.

This time I have started my VPN to check if this could be the reason of a problem of the Roon remote display (syncing).

I had no problem at all

I have checked on the Roon Core afterwards, and everything is fine also.

4 posts were split to a new topic: OpenGL Error message on remote