Kernel panic on nuc5i3yk [NVMe incompatibility on 5th Generation NUC)

Install rock on a ssd but after reboot I’m getting a kernel panic:

mount: can’t read ‘etc/fstab’: No such file or directory
mount: mounting /overlay/boot/roonos-1/rootfs.img on overlay/ro failed: No such file or directory

Kernel panic - not syncing: Attempted to kill init! exitcode=0x00000100

ssd: intel ssdpekkw128g7
Nuc: nuc5i3ryk
Memory: 8Gb

Windows 10 was preinstalled on the nuc.

The image I flashed is: roonbox-linuxx64-nuc3-usb-factoryreset.img.gz

What should be done?

.gz is a zip file, I assume you followed the instructions that tell you how to unzip it and create the installation media? The excellent Computer Audiophile ROCK installation guide is below.

I installed it but on reboot I get the kernel panic.

Have you tried starting again with a new download?

I did with the same result.

Did you do the bios settings, and is it the latest bios?

I installed the latest version of the bios and did the bios settings.

Let’s see if @danny can spare a moment to take a peek.

Something is wrong with your install… It is panicing because it can’t find the root filesystem

Tell us what you did, explicitly, since there must be a step or detail that is not how everyone else is doing it.

Its unclear from your description, did you flash the SSD with the factory reset? Or a USB stick? What did you use to flash?


I’m having similar issue with NUC 5I5 installation, 16gb, Samsung 128gb M.2 NVMe

I updated BIOS to latest, set to legacy boot, though legacy didn’t show me any drives. I then rebooted from USB with the factory image reset which had been upacked with Etcher on OSX. It installed the image just fine, but when I rebooted to SSD I received this set of errors starting with /etc/fstab and it hangs.


I used an usb stick to flash.

Asking @support to look into this… This means your install is corrupt somehow.

1 Like

Hi @Tom_Schmidt and @Bert_van_der_Leest ---- Thank you for the reports and sharing your feedback with us, both are appreciated!

Moving forward, Bert, I understand that you had tried starting again with a new download. When you performed the reinstall did you also try re-flashing the mentioned USB stick?

Tom, how about you have you tried performing the install again and re-flashing the USB device you used to perform the install?


Yes I tried the process from post BIOS fix forward 2 times, no joy. I did a full format on the USB stick FAT32 also.

Previously mine was running W10, with UEFI boot to the Samsung drive (there were 3 options). When I deselected UEFI and selected Legacy boot, there are no options shown for boot order for Legacy.

Also, mine is a NUC 5I5RYH

Yes, I reflashed the usb stick with Etcher. What I also did was create a bootable usb stick with GParted and after installing Rock I used it to see what partitions were made and there were 4 partions. But after a reboot from ssd still the kernel panic.


Hey @Tom_Schmidt,

When I deselected UEFI and selected Legacy boot, there are no options shown for boot order for Legacy.

There is: Open Boot section, pick Boot priority tab. Now you should see two tables - UEFI on the left and Legacy on the right. When you enable Legacy boot you should get list of drive underneath similar to pick below:

I reflashed the .img file using etcher. Did the boot with usb stick w/ROCK, it successfully installed ROCK. Rebooted without USB stick and get the same kernel panic.

Hardware issue maybe?