Linn Devices only showing up as AirPlay with QNAP Core after updating to build 1148 [Update Roon to Build 1154 (Linux Release Only)]

:mega: Staff Note :mega:

Roon Core 2.0 build 1148

Networking Gear & Setup Details

Ethernet - netgear switches

Connected Audio Devices

Various - Linn DSM

Description of Issue

On upgrade to 2.0 I can no longer see the LINN DSM audio devices on the network, apart from via Airplay. The previous configuration under 1.8 showed them available direct, i.e. not via airplay.

How can I get these devices showing as available audio zones again?

1 Like

Is your “Subnet for Linn streaming” still valid, i.e. in your local LAN segment? (Settings → Setup)

not sure what you mean - all Roon Core and Linn devices are all on same subnet. there are no options to configure LAN segment settings in Settings → Setup that I can see. If Roon Core cam see the Linn DSMs as Airplay, then it should see them as controllable audio devices. I have made no changes to LINN Konfig settings between running on Roon Core 1.8 and 2.0 - all Linn DSMs are set to Roon visible.

1 Like

At the bottom of the Settings → Setup screen there is a “Subnet for Linn streaming” setting. Not that I have any Linn devices so I can’t experiment with this, but if somehow the subnet configured there is different from the subnet that your Linn devices actually live on then I can imagine that the Roon core has difficulty seeing them.

By the way, the release notes for today’s 1148 does mention that they made some changes for stability’s sake related to some Linn devices; perhaps that change causes you problems.

@Jay_Whyatt I have a Linn Selekt DSM Surround and it shows up after the update today:

1 Like

I can’t see the Subnet for Linn Streaming setting …

1 Like

The subnet is below “HQPlayer”

Try to shut everything down - incl. your router. Pull the power cord to your router and wait 15-20 sec. Than power on the router and than the rest. Hope this helps.

I rebooted everything and still can’t see Subnet for Linn Streaming.

1 Like

I tried Roon core on one of my other QNAP NAS servers and I have exactly the same issue. No Linn audio devices showing.

Same problem with my Akurate, Majik and Sneaker.

Same here after updating from 2.0- to 2.0.3 this morning. Can no longer see my Linn AEDSM (other than via airplay).

The Linn Streaming subnet setting has disappeared from the settings and no longer exists as an option.

I note that the 2.0.3 changelog states that “we have resolved a long-standing issue in which the presence of certain Linn devices on a user’s network could result in repeated crashes of RoonServer”

It would appear that it has been resolved by disabling Linn devices… Hopefully this is flagged for a very rapid fix.

Is everyone with this problem using a NAS?

I just set Roon up (temporarily) on a Windows PC. The Linn subnet setting then reappears in the control point and can be changed to the correct subnet.

Closing that and going back to the NAS server (after stopping, restarting and reauthorising Roon) the problem is back.

I’m guessing that whatever Roon has done to the Linn streaming code to fix their ‘longstanding issue’ has broken something with RoonOnNAS.

Might be bad news ion regards to getting a fix…


Using a Synology NAS as Roon core and a Linn selekt dsm. No problems after updating.

I’ve got same problem after update. Running Roon on QNAP NAS (TS-453A).

I can’t see any option to update the subnet as described above.

Having shelled out for a lifetime subscription I’m extremely p*****d off at this major update failure.

A further update fixing this problem needs to be released without delay.

I’m p*****d off to, but it appears it is a problem with 2.0.3 and RoonOnNAS on QNAP only, which I guess makes it harder to test for.

I made a thread on the QNAP NAS section: Problem with 2.0.3 and RoonOnNAS?

This bug might be based in RoonOnNas rather than Roon itself (I think RoonOnNAS packages the Linux server, which itself mostly uses the Windows files + Linux dotnet I think), so we are multiple layers of abstraction from the original code.

That said, RoonOnNAS is linked from the Roon website in the same way as other downloads, so while they might not support it themselves they are happy to let us pay for Roon on the basis we should be able to run it on a NAS.

Lets hope it is sorted swiftly nonetheless…

1 Like

I’m fully updated on Synology DSM and see the Linn Streaming option. May just be a QNAP issue?

so sad···.
Please deal with it as soon as possible.

I have the same problem since last update. Linn can be accessed only via Airplay (QNAP. Roon Version : 2.0 (build 1148) production). Please help.

Have any of you folks who are experiencing this issue on a QNAP tried temporarily turning off the device’s firewall? This issue could be related to a network discovery strategy that is being blocked.

It needs to be fixed quickly even if that means reverting the Linn “fix” in the latest Roon build. In the meantime, it might be worth exploring if there’s a configuration change you can make to get it working again.