Metadata Improver error message

Alright, this happens frequently when adding content to any of my Cores…
Dropped the Logs from my Linux based core here

I suspect it’s the Roon Service not responding:

03/31 15:31:08 Warn: [metadatasvc] FAIL [1] (890ms) NetworkError
03/31 15:31:08 Trace: [music/genres] failed to get genre update in 160441ms: Result[Status=NetworkError, ErrorText=The remote server returned an error: (403) Forbidden.]

A post was split to a new topic: Medatata Improver Error: Nucleus

A post was split to a new topic: Metadata Improver Error on SonicTransporter

Make sure your roon clients are all fully updated to B528. Do Sonicorbiters for some reason seem to have this issue a lot?

2 posts were split to a new topic: Metadata Improver Error (Resolved)

A post was split to a new topic: Metadata Improver Error - Help

Some form of feedback on this would be appreciated @noris.
This is very annoying and not up to Roons usual standard of stability.

Hi @Mikael_Ollars,

Thanks for the ping. I spoke to QA about this issue recently and they have noted that this is likely due to a setting on your current network setup. What we have found is that this issue occurs when packets are being fragmented on a network and the complete packet does not reach the Core in one piece. I’m looking over the network setup you mentioned previously:

As a temporary test, I was wondering if you could plug the Core directly into the router, reboot it and verify if the same issue is still occurring.

Are there any other apps which filter network traffic on your end and might cause packet fragmentation? Do you have VPN/VOIP apps perhaps?

Another good test here would be to try using a mobile hotspot instead of the current network connection. If you have one available, I would be interested to know if the same message appears following a reboot of the Core.

This issue happens on my hard wired Cores also, one Unix based, and two ROCK-units. The only thing separating them from my router and then the fibre media box is a dumb HP ProCurve gigabit switch.

Nope, nuttin’… Not even antivir… (only Windows Defender/Security Essentials on my Windows machines, of which none are acting as Core)
No configuration of the router either, no prioritized traffic or whatsoever.

Well, i was in my cabin this weekend and brought my portable Roon (the MacBook Pro 2017 which has been mentioned previously.) and since Roon cannot start up local audio without an Internet connection (freakin weird behaviour?) i connected it to my iPhone using Internet Sharing over 4G for startup. And wadda ya know, the Metadata improver service just stopped… No changes had been made to the media library at this time.
So, reboot the setup and do the whole thing over again, and there you have it, no errors.

Just had to relocate my Linux Roon Core. Powered down and then booted up again, and this issue still persists:

(Timestamp top left, CET)

Hi @Mikael_Ollars,

Thanks for running this test! So from what you’re saying is that this issue doesn’t occur on your hotspot but it does on the normal ISP network.

If you bypass the procurve switch as well, is there any change in behavior? How do you have the router and media box set up? Are they using default MTU values or did you set the MTU to something other than 1500?

No, thats not what i’m saying? This issue is independent of the network of choice. It happens on my regular LAN/WLAN as well as via a hot spot.

There are no particular setups being done to the router, all default. I just now noticed there was a newer firmware out, so i updated. I am convinced this is not the issue though.
Even if network stability was the cause for this, the metadata improver service for sure would need to perform more stable than it is at the moment. I mean, i stream TV and music on a daily basis as well as work from home over a VPN connection. None of these activities have any issues whatsoever, but Roon is a primadonna needing particular treatment?
I will directly attach my RoonUXCore wired to the router for a test later, but this is not a feasible solution in the long rung, theres no shelving around my router and it will need to be placed on the floor.
And to make things clear, this was not an issue before the previous version of Roon, and i haveNOT changed anything in this period.

Okey, i tried a couple of boots with my RoonUXCore hardwired to the Router, but i was unable to recreate the error at this time? I moved the Core back to its original position and performed a couple of reboots but even there, with the HP ProCurve in the equation everything worked just fine…

So, unable to recreate the error for the time being… :slight_smile: I even bought a few downloads and added to the library but they all identified just fine, and no messages about the metadata improver service fail.

1 Like

Hi @Mikael_Ollars,

Thanks for trying the Core directly connected to the router and for clarifying that this issue occurred via the hotspot as well. Do let me know if the issue returns, hopefully testing with the direct router connection resolved the issue, but let’s see.

2 posts were split to a new topic: Metadata Update Error: Windows 10 [Resolved]

3 posts were split to a new topic: Metadata Improver Error: SonicTransporter - Have to reboot

Hi Noris, just a quick update here. This issue occasionally still surface, and one reboot seem to always solve it for a longer period.
Something struck me regarding this though. I have, at the moment, a few Roon Cores running on my network and perhaps a pattern is showing? :slight_smile:
When i shift the Core to another hardware, i am asked to de-authorize the previous one, right? This works just fine, unless the Core has been offline for a looong time or was recently restored from backup which forces me do to a login, and that takes more than 2 minutes of annoying animated Roon logo, but still;
The de-authorized Core is still “licensed” as far as it’s concerned, for a few hours mostly. It seems that the Metadata improver error is ever present when i return to this core that has been deathorized after a day or so?

I am thinking along the lines of you not seeing the logs from a deauthorized core or so?

Hi @Mikael_Ollars,

Thanks for the additional info, but I’m not quite sure I understand here.

So you’re saying that the message only appears for you on the newly authorized Core that hasn’t been authorized in a few days? And this message appears pretty much as soon as you re-login?

Ah, no, nevermind that theory. :blush:
I thought it might have something to do with more than one core trying to get activation, but that doesn’t add up.

The only thing worth noting is that this occasionally resurface. But it’s completely random, and no changes have been made on my network or at my ISP. I can only conclude something is strange on the server side.

1 Like

Hi @Mikael_Ollars,

Thanks for letting me know. This issue is still one that we’re looking into, so if you do notice any patterns in the behavior please do let me know. We will of course also keep investigating this issue from our end with the reports we’ve gathered so far.

Has something changed regarding this in the latest release or server side?
A couple of weeks (or one at least) has passed since the metadata improver error reared its ugly head now.
And i have made some additions and adjustments to the library.

1 Like